95 GT missing & popping
Forums at Modded Mustangs
Home Register FAQ Members List Calendar Timeslips Blogs Garage Gallery Auto Loans Search Today's Posts Mark Forums Read Auto Escrow


Go Back   Forums at Modded Mustangs > Mustang Forums > 5.0 Mustangs > 94-95

ModdedMustangs.com is the premier Ford Mustang Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old January 14th, 2010, 11:46 AM   #1
Newbie
 
 
Join Date: Jan 2010
Posts: 2
bullit1995 is on a distinguished road
iTrader: 0 reviews
Default

95 GT missing & popping


Original problem was loss of accel at 3K rpm. Shop found loss of fuel press under accel & discovered extreme rust problem in gas tank, fuel pump, sending unit, also fuel filter plugged. All parts replaced. BUT, now car runs worse, missing at all rpm, popping, like cross-wired, but not. The following have been replaced, distr pickup, distr module, cap, button, coil, plugs. The following have been checked/tested, MA sensor, wires, TPS, idle/air control, fuel press (again), also compress test and checked injectors for cleanliness and press drop test. A reman computer has also been installed. Nothing helps at all. Ideas?
The car is stock except for Flowmasters, 110K miles. The shop doing the work is highly trusted, very experienced mechanic but this seems to have him stumped.

Last edited by bullit1995; January 14th, 2010 at 11:57 AM.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old January 14th, 2010, 11:48 AM   #2
Newbie
 
 
Join Date: Jan 2010
Posts: 2
bullit1995 is on a distinguished road
iTrader: 0 reviews
Default

Help! No response yet, I must leave the country in 5 days and I really want to have my car running again. Thanks!

Last edited by bullit1995; January 14th, 2010 at 08:25 PM.
  Reply With Quote Quick reply to this message
Old January 15th, 2010, 08:59 AM   #3
Dino Dino Bambino
 
Bullitt95's Avatar
 
2006 Mustang GT
12.8 @ 108
 
Join Date: Apr 2007
Location: Al Ain, UAE
Posts: 1,846
Bullitt95 will become famous soon enoughBullitt95 will become famous soon enough
iTrader: 0 reviews
Send a message via ICQ to Bullitt95
Default

Sounds to me like the ignition timing could be off.
Plugged up cats could also cause the engie to run poorly so you might wanna have those checked.
__________________

2006 GT - 5MT - 305rwhp 317rwtq
1995 GT - 4AT - Modded - SOLD
1995 GT - 4AT - Project - SOLD
  Reply With Quote Quick reply to this message
Old January 22nd, 2010, 05:54 PM   #4
Regular
 
03 Mach 1
 
Join Date: Oct 2006
Location: Tallahassee,FL
Posts: 234
kreil45 is on a distinguished road
iTrader: 0 reviews
Default

how does it smell could be running lean.
  Reply With Quote Quick reply to this message
Old January 27th, 2010, 06:54 PM   #5
Hardcore Enthusiast
 
number1gt's Avatar
 
2002 mustang gt
 
Join Date: Jan 2010
Posts: 1,894
number1gt will become famous soon enough
iTrader: 0 reviews
Default

Originally Posted by Bullitt95 View Post
Sounds to me like the ignition timing could be off.
Plugged up cats could also cause the engie to run poorly so you might wanna have those checked.
he is right i does sound like that is whats wrong. i had a car brought in to me and had similar problems. his cats were plugged up
  Reply With Quote Quick reply to this message
Old January 30th, 2010, 05:07 AM   #6
Regular
 
 
Join Date: Nov 2009
Posts: 65
sameerb1 is on a distinguished road
iTrader: 0 reviews
Default

I dont know should i continue in the same thread, but yesterday my car started the same problem as above.

at idle the car is allrite, the problem starts if i raise the auto windows, like all the power will be drawn in to lowering the windows and the car shuts down.

when i drive the car, at first gear after couple of seconds it will start missing and breathing heavy and go to low rpms' i would need to keep on pumping the accelaration to keep engine running instead of a steady accelaration press.

on idle if i press the accelartor slowly to go to high revs, there is smoke coming out from both exhausts, one blue and the other gray (white and black??), so even smoke is not same color.

what could be wrong here? i will try to take the car to mechanics today if i can drive it. it stopped in an empty area where nearest mechanic will be about 25km away. need to atleast drive that much, dun wan to give the tow guys anything...
  Reply With Quote Quick reply to this message
Old January 30th, 2010, 10:00 AM   #7
Dino Dino Bambino
 
Bullitt95's Avatar
 
2006 Mustang GT
12.8 @ 108
 
Join Date: Apr 2007
Location: Al Ain, UAE
Posts: 1,846
Bullitt95 will become famous soon enoughBullitt95 will become famous soon enough
iTrader: 0 reviews
Send a message via ICQ to Bullitt95
Default

Try cleaning the MAF sensor.
__________________

2006 GT - 5MT - 305rwhp 317rwtq
1995 GT - 4AT - Modded - SOLD
1995 GT - 4AT - Project - SOLD
  Reply With Quote Quick reply to this message
Old January 30th, 2010, 11:26 PM   #8
Regular
 
 
Join Date: Nov 2009
Posts: 65
sameerb1 is on a distinguished road
iTrader: 0 reviews
Default

^ i removed the MAF cable and it is running better and not chocking much, but still the RPM going up and down.

I left it in the garage to re-route the wirings and look if all electrics work fine and also sorting out the gear and install king cobra clutch!
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools


Threads Similar to: 95 GT missing & popping
Thread Thread Starter Forum Replies Last Post
CAR Audio/Video=Pics,Ideas,& Info/SQ & SPL Post your Systems+ Pros&Cons Just Another Stang Audio/Video 22 April 6th, 2010 01:03 PM
4th Annual Rock & Roll Car Show & Cruise-In 10/16 & 10/17 j21moss Midwest 0 October 7th, 2009 11:12 PM
HELP!! Popping!! AndrewA. 99 - 04 5 September 6th, 2008 11:42 PM
Missing N popping jivepepper 99 - 04 11 July 1st, 2008 09:26 PM
Engine Popping shawn91stang 5.0 Mustangs 4 January 7th, 2007 02:50 PM



All times are GMT -4. The time now is 08:25 PM.
Modded Mustangs is ©2005-2008, All Rights Reserved, And is Not Affiliated with Ford Motor Company.
Forum is powered by vBulletin ©2000 - 2014, Jelsoft Ent. Ltd. & SEO by vBSEO 3.3.2 ©2009, Crawlability, Inc.

powered by vBulletin ©2000 - 2014, Jelsoft Ent. Ltd.