95 mustang gt runs like crap
Forums at Modded Mustangs
Home Register FAQ Members List Calendar Timeslips Blogs Garage Gallery Auto Loans Search Today's Posts Mark Forums Read Auto Escrow


Go Back   Forums at Modded Mustangs > Mustang Forums > 5.0 Mustangs > 94-95

ModdedMustangs.com is the premier Ford Mustang Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old March 23rd, 2010, 08:25 AM   #1
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

95 mustang gt runs like crap


ok i have a 95 mustang gt 5.0 auto, it has 3.73 gears b&m shift kit, bbk underdrive pullys, hooker headers, h pipe, 40 series flowmasters, cold air intake, msd blaster coil, msd cap & rotor, sct chip, egr delete/smog the car runs nothing like it should it is about as fast as a Geo metro, The car runs fine down low you get on it and it goes no where, No check engine light nothing loses pretty much all power around 4200 rpm and will start cutting out. it has new header gasket because they were leaking. new plugs. wires, cap and rotor are new still nothing still doggy and slow up high. i don't even know where to began to look on what would be making it so doggy and slow if anyone has any info please feel free i am willing to listen and try anything thanks KYLE
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old March 23rd, 2010, 09:12 AM   #2
Regular
 
95stroker's Avatar
 
1995 Mustang GT
 
Join Date: May 2008
Location: Lincoln, NE
Posts: 254
95stroker is on a distinguished road
iTrader: 0 reviews
Default

Is it a catted H-pipe? If so, could be something as simple as clogged cats?
  Reply With Quote Quick reply to this message
Old March 23rd, 2010, 12:24 PM   #3
Dino Dino Bambino
 
Bullitt95's Avatar
 
2006 Mustang GT
12.8 @ 108
 
Join Date: Apr 2007
Location: Al Ain, UAE
Posts: 1,803
Bullitt95 will become famous soon enoughBullitt95 will become famous soon enough
iTrader: 0 reviews
Send a message via ICQ to Bullitt95
Default

Yeah, clogged cats will definitely make the car feel doggy (pun intended).
Also try cleaning the MAF sensor wire.
__________________

2006 GT - Red - 5MT - 305rwhp 317rwtq
1995 GT - Green - 4AT - Modded - SOLD
1995 GT - Red - 4AT - Project - SOLD
  Reply With Quote Quick reply to this message
Old March 23rd, 2010, 12:44 PM   #4
Enthusiast
 
 
Join Date: Oct 2007
Location: Memphis TN
Posts: 609
95project is on a distinguished road
iTrader: 0 reviews
Default

Incorrect tune or check the timing
__________________
95 GT- AFR 185's, Comp CAM, Trick FLow TH upper and lower, 30lb injec, 76MM C&L kit, Full MSD, BBK Pulleys, 3:73, BBK Long Tubes, X Pipe, Magnaflow Cat back, Cobra front control arms, MM CC plates LCA's and Panhard bar, tuned by Adam @ Pops Racing.
  Reply With Quote Quick reply to this message
Old March 23rd, 2010, 01:38 PM   #5
Regular
 
2001,Ford,Bullitt Mustang
 
Join Date: Jan 2010
Location: Leitchfield
Posts: 220
00mustang92 is loose again, somebody get the straightjacket
iTrader: 0 reviews
Default

cats could be stopped up.
  Reply With Quote Quick reply to this message
Old March 23rd, 2010, 03:16 PM   #6
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

the car does not have cats.. and even before chip it really didn't run much better! i am gonna check the timing and i am buying a new maf sensor. but if it is neither of them what do you think it could be! ps thanks for all the help and answers kyle
  Reply With Quote Quick reply to this message
Old March 23rd, 2010, 03:23 PM   #7
Priest of the Car Gods
 
ReverendDexter's Avatar
 
Clapped-out '90 GT 'vert
~5.5 seconds off TTOD :(
 
Join Date: Jan 2007
Location: Rohnert Park, CA
Posts: 17,313
ReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond reputeReverendDexter has a reputation beyond repute
iTrader: 0 reviews
Default

How do the plugs look?
__________________
Function > Form, always
  Reply With Quote Quick reply to this message
Old March 23rd, 2010, 11:55 PM   #8
Regular
 
95 & 97 GT
 
Join Date: Jan 2007
Location: Garland, tx
Posts: 108
4.slo? is on a distinguished road
iTrader: 0 reviews
Default

Sounds like you have a bad fuel pump not supplying enough fuel when needed. Hook up a fuel pressure gauge to your fuel rails and monitor it make sure the psi is not dropping.
__________________
<img src=http://i676.photobucket.com/albums/vv122/ralvarez26/splogoub7.gif border=0 alt= />
97gt Pi swapped, sreamin demon coils, taylor wires, diablo chip, cai, 3.73s. 9.3 in 1/8 with no traction.
Boosted 95GT under construction.
  Reply With Quote Quick reply to this message
Old March 24th, 2010, 01:03 PM   #9
Regular
 
2001,Ford,Bullitt Mustang
 
Join Date: Jan 2010
Location: Leitchfield
Posts: 220
00mustang92 is loose again, somebody get the straightjacket
iTrader: 0 reviews
Default

fuel filter? Plugs & plug wires? Motor could b bad?
  Reply With Quote Quick reply to this message
Old March 24th, 2010, 07:08 PM   #10
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

cap, rotor, plugs are new wires are not that old. what should the fuel pressure be? and the motor does not smoke only has 88k on it. i will check the maf, fuel pressure. the car idles and runs fine if you are not getting on it! but when you do get on it that is when it starts running like crap.
  Reply With Quote Quick reply to this message
Old March 25th, 2010, 12:11 AM   #11
Regular
 
95 & 97 GT
 
Join Date: Jan 2007
Location: Garland, tx
Posts: 108
4.slo? is on a distinguished road
iTrader: 0 reviews
Default

Should be at about 30 to 40 not too sure. Also maybe your pressure regulator is messed up, make sure no gas in line when you remove the vacuum line to it.
__________________
<img src=http://i676.photobucket.com/albums/vv122/ralvarez26/splogoub7.gif border=0 alt= />
97gt Pi swapped, sreamin demon coils, taylor wires, diablo chip, cai, 3.73s. 9.3 in 1/8 with no traction.
Boosted 95GT under construction.
  Reply With Quote Quick reply to this message
Old March 25th, 2010, 12:15 AM   #12
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

i will check fuel pressure and pull the vac on the fuel pressure reg line and see what is going on. i will post up what it say/does tomorrow thanks everyone for all the answers and trying to help me out
  Reply With Quote Quick reply to this message
Old March 25th, 2010, 09:47 AM   #13
Dino Dino Bambino
 
Bullitt95's Avatar
 
2006 Mustang GT
12.8 @ 108
 
Join Date: Apr 2007
Location: Al Ain, UAE
Posts: 1,803
Bullitt95 will become famous soon enoughBullitt95 will become famous soon enough
iTrader: 0 reviews
Send a message via ICQ to Bullitt95
Default

Did you clean the MAF sensor? Pull it out of the housing and gently clean the wire with a cotton bud soaked in brake cleaner.
  Reply With Quote Quick reply to this message
Old March 25th, 2010, 12:59 PM   #14
Regular
 
2001,Ford,Bullitt Mustang
 
Join Date: Jan 2010
Location: Leitchfield
Posts: 220
00mustang92 is loose again, somebody get the straightjacket
iTrader: 0 reviews
Default

My dad had a truck once that run like that. Fuel pump went out off it when he put the new one in it run twice of good as it ever did. Could be a vacuum leak somewhere. Had buddy wit one once and put it back on and it fixed his problems
  Reply With Quote Quick reply to this message
Old March 25th, 2010, 01:54 PM   #15
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

checked the vacum line was dry so reg is good and working the car held 40psi running for 5min! i will clean the maf sensor and see what it does and ill let you know thanks for all the info.... kyle
  Reply With Quote Quick reply to this message
Old March 25th, 2010, 05:45 PM   #16
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

i just wanna get this thing running right so i can put my nitrous on it! i am to the point of messing with it about to put it on and blow it up lol! if anyone else has ideas to try let me know thanks kyle
  Reply With Quote Quick reply to this message
Old March 26th, 2010, 12:40 PM   #17
Regular
 
2001,Ford,Bullitt Mustang
 
Join Date: Jan 2010
Location: Leitchfield
Posts: 220
00mustang92 is loose again, somebody get the straightjacket
iTrader: 0 reviews
Default

Really don't no wat else it could be then wat I have told ya
  Reply With Quote Quick reply to this message
Old March 26th, 2010, 02:49 PM   #18
Regular
 
95 & 97 GT
 
Join Date: Jan 2007
Location: Garland, tx
Posts: 108
4.slo? is on a distinguished road
iTrader: 0 reviews
Default

Originally Posted by kyleboyd View Post
checked the vacum line was dry so reg is good and working the car held 40psi running for 5min! i will clean the maf sensor and see what it does and ill let you know thanks for all the info.... kyle
ok 40 psi is good at idle, but I meant drive it and monitor the fuel pressure when you're driving and when you drive it like you stole it. I think your fuel pump is weak.
__________________
<img src=http://i676.photobucket.com/albums/vv122/ralvarez26/splogoub7.gif border=0 alt= />
97gt Pi swapped, sreamin demon coils, taylor wires, diablo chip, cai, 3.73s. 9.3 in 1/8 with no traction.
Boosted 95GT under construction.
  Reply With Quote Quick reply to this message
Old March 26th, 2010, 08:09 PM   #19
Newbie
 
 
Join Date: Mar 2010
Posts: 16
kyleboyd is on a distinguished road
iTrader: 0 reviews
Default

ok get this pulled the maf cleaned it and put it back on! the car had no difference! bought a new one car wouldn't rev above 3200... took it back thougth it was a bad one got my old one back! i said heck with it pulled the wireing off the maf and started car revs way better i know its not good on it but took it around the block car runs better then it ever has before. Any answer to that one?
  Reply With Quote Quick reply to this message
Old March 26th, 2010, 10:46 PM   #20
Regular
 
95 & 97 GT
 
Join Date: Jan 2007
Location: Garland, tx
Posts: 108
4.slo? is on a distinguished road
iTrader: 0 reviews
Default

Bad MAF.
__________________
<img src=http://i676.photobucket.com/albums/vv122/ralvarez26/splogoub7.gif border=0 alt= />
97gt Pi swapped, sreamin demon coils, taylor wires, diablo chip, cai, 3.73s. 9.3 in 1/8 with no traction.
Boosted 95GT under construction.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools


Threads Similar to: 95 mustang gt runs like crap
Thread Thread Starter Forum Replies Last Post
Still runs like crap.....need HELP! 1sl0w88 5.0 Mustangs 8 July 2nd, 2009 03:19 PM
Replaced siezed smog pump runs like crap now Bad4u2 94-95 7 April 17th, 2009 09:13 PM
Install done but runs like crap!!! TimboStang 2005 - 2010 7 October 13th, 2008 02:57 PM
Car Runs Like Crap 1bad5.0 94-95 9 January 15th, 2008 03:38 PM
5.0 conversion runs like crap dons86 5.0 Mustangs 5 September 2nd, 2006 04:16 PM



All times are GMT -4. The time now is 10:22 AM.
Modded Mustangs is ©2005-2008, All Rights Reserved, And is Not Affiliated with Ford Motor Company.
Forum is powered by vBulletin ©2000 - 2014, Jelsoft Ent. Ltd. & SEO by vBSEO 3.3.2 ©2009, Crawlability, Inc.

powered by vBulletin ©2000 - 2014, Jelsoft Ent. Ltd.