97 gt speedometer problem - Forums at Modded Mustangs
Reply
 
LinkBack Thread Tools
post #1 of 21 Old May 27th, 2010, 11:37 AM Thread Starter
Newbie
 
Join Date: Mar 2010
Location: Southeast Missouri
Posts: 47
 
iTrader: 0 reviews
Send a message via MSN to mike-oat
97 gt speedometer problem

Yes, i was wanting to know if someone knew why my speedometer doesnt work and neither does my mileage odometer. my mileage odmeter is stuck on 61,594. Any help would be greatly appreciated thank you!

michael oatman
mike-oat is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old May 27th, 2010, 11:52 AM
Regular
 
war1ock's Avatar
 
Join Date: Dec 2009
Location: Guilford, IN
Posts: 384
 
iTrader: 0 reviews
The 2 gears inside the speedo are most likely broke. Pretty common problem

Quote:
Originally Posted by Boercker View Post
ram it in the whole and see what happens (my philosophy)
Quote:
Originally Posted by BakerFX4 View Post
Im more a meth kinda guy. Primarily on the weekends.
1997 GT. K&N Filter, Smoked Angel Eye Headlights, Sequential Taillights, Summit O/R H Pipe Flowmaster 40s
war1ock is offline  
post #3 of 21 Old May 27th, 2010, 01:17 PM Thread Starter
Newbie
 
Join Date: Mar 2010
Location: Southeast Missouri
Posts: 47
 
iTrader: 0 reviews
Send a message via MSN to mike-oat
how can i check that out to see if thats the probnlem
Quote:
Originally Posted by war1ock View Post
The 2 gears inside the speedo are most likely broke. Pretty common problem

michael oatman
mike-oat is offline  
post #4 of 21 Old May 27th, 2010, 01:27 PM
Regular
 
Join Date: Jul 2008
Location: Lapeer and Detroit, Michigan
Posts: 448
 
iTrader: 0 reviews
I believe the odometer is read off the speedo sensor as well.

You can check it by jacking up your car. Go the the rear of the transmission. On the drivers side there is in the 98s an electrical connection plugged into a sensor. Undo the plug, unscrew the one bolt holding the sensor in, pull out the sensor. On the end of the sensor should be a gear. Inspect that for damage.

98 Mustang GT 13.795 @ 98.87 N/A
Main mods: PI Swap, 3.73 gears, E85


My Mark VIII and T56 swap
cruizer is offline  
post #5 of 21 Old June 6th, 2010, 09:08 PM
Enthusiast
 
sn95mustanggt's Avatar
 
Join Date: May 2009
Location: NEBRASKA
Posts: 876
 
iTrader: 2 reviews
I wish my odometer would stop counting up!
sn95mustanggt is offline  
post #6 of 21 Old June 6th, 2010, 09:16 PM
Regular
 
brandywine112972's Avatar
 
Join Date: May 2010
Location: easley, south carolina
Posts: 205
 
iTrader: 0 reviews
my speedometer works fine, but my odometer and trip dont work. the 2 gears need to be replaced, but it seems to be a pita to do. maybe one day i will do it.
brandywine112972 is offline  
post #7 of 21 Old June 7th, 2010, 05:10 AM
Hardcore Enthusiast
 
'97'Cobra's Avatar
 
Join Date: Feb 2008
Location: Denton, TX
Posts: 1,935
     
iTrader: 2 reviews
lol same here. Who has the time to fix a odometer?! I guess ill just stay stuck on 89k....


Quote:
Originally Posted by BWAL09 View Post
i usually wave first, but if the guy is sexy and i'm drunk, i might lift up my shirt and flash him as well.
MM Cobra Club Member #61
'97'Cobra is offline  
post #8 of 21 Old June 7th, 2010, 07:15 AM
Regular
 
brandywine112972's Avatar
 
Join Date: May 2010
Location: easley, south carolina
Posts: 205
 
iTrader: 0 reviews
mine is stuck at 167k. car runs strong, so i dont know if it has had a heart transplant or its a different gauge cluster.
brandywine112972 is offline  
post #9 of 21 Old June 7th, 2010, 01:38 PM
Rollin' 18/ pushin' 2
 
97S281's Avatar
 
Join Date: Feb 2007
Location: The lost highway
Posts: 8,314
                   
iTrader: 18 reviews
If the speedometer AND tyhe odometer aren't working it is most likely the vehicle speed sensor located on the transmission. It will take you longer to jack the car up enough to reach it than it will take to change it.




MODS IN GARAGE

All SVO'D UP
97S281 is offline  
post #10 of 21 Old June 7th, 2010, 04:11 PM
Regular
 
Join Date: Jun 2010
Location: Aurora, CO
Posts: 470
 
iTrader: 0 reviews
guess odo's breaking on mustangs are pretty common. mine broke... and didnt get fixed till i dunno how much later but hey i swear its only got 70k on it!! lol


PI Manifold. 75mm tb/plenum. Magnaflow X pipe. FR driveshaft. MGW shifter. New brakes and clutch stuff.
LoveStangs88 is offline  
post #11 of 21 Old June 7th, 2010, 04:38 PM
Banned
 
Join Date: Oct 2009
Location: Massachuesetts
Posts: 276
 
iTrader: 0 reviews
Send a message via AIM to PurpleStang96
haha i'm at like 58k an it jsut stopped working...hahaha i didnt know everyone had the same problem!!

1996 Mustang GT 56,000 miles
5 speed
K&N intake
black leather
blue led dash/hvac mod
cervini's 3 1/2 cowl hood
17x8/10.5 Black bullit wheels
Mac hpipe/slp resonators
more to come......
PurpleStang96 is offline  
post #12 of 21 Old June 7th, 2010, 11:03 PM
Regular
 
whiteboy05's Avatar
 
Join Date: Dec 2009
Location: Houston TX
Posts: 131
 
iTrader: 0 reviews
Send a message via Yahoo to whiteboy05
mines stuck at 109 lol

Airaid Cold air, Sct tuner, X-Pipe ans Zex Wet Nitrous Kit
whiteboy05 is offline  
post #13 of 21 Old June 7th, 2010, 11:19 PM
Enthusiast
 
Join Date: Feb 2010
Posts: 992
   
iTrader: 0 reviews
just go to the junkyard and find a stang with low miles and pull the cluster, take it home, clean it up, install......car loses 50k miles
BAD98GT is offline  
post #14 of 21 Old June 8th, 2010, 12:00 AM
Regular
 
whiteboy05's Avatar
 
Join Date: Dec 2009
Location: Houston TX
Posts: 131
 
iTrader: 0 reviews
Send a message via Yahoo to whiteboy05
quick ? is anyone mph off by 5 mine is how do i fix thats

Airaid Cold air, Sct tuner, X-Pipe ans Zex Wet Nitrous Kit
whiteboy05 is offline  
post #15 of 21 Old June 8th, 2010, 02:52 AM
Regular
 
Join Date: Jun 2010
Location: Aurora, CO
Posts: 470
 
iTrader: 0 reviews
Quote:
Originally Posted by BAD98GT View Post
just go to the junkyard and find a stang with low miles and pull the cluster, take it home, clean it up, install......car loses 50k miles
Owned

Quote:
Originally Posted by whiteboy05 View Post
quick ? is anyone mph off by 5 mine is how do i fix thats
did you just get new gears? maybe something with the computer.


PI Manifold. 75mm tb/plenum. Magnaflow X pipe. FR driveshaft. MGW shifter. New brakes and clutch stuff.
LoveStangs88 is offline  
post #16 of 21 Old June 8th, 2010, 06:16 AM
Hardcore Enthusiast
 
'97'Cobra's Avatar
 
Join Date: Feb 2008
Location: Denton, TX
Posts: 1,935
     
iTrader: 2 reviews
Quote:
Originally Posted by LoveStangs88 View Post
Owned



did you just get new gears? maybe something with the computer.
98's are still gear and cable driven i thought


Quote:
Originally Posted by BWAL09 View Post
i usually wave first, but if the guy is sexy and i'm drunk, i might lift up my shirt and flash him as well.
MM Cobra Club Member #61
'97'Cobra is offline  
post #17 of 21 Old June 8th, 2010, 09:15 PM
Regular
 
whiteboy05's Avatar
 
Join Date: Dec 2009
Location: Houston TX
Posts: 131
 
iTrader: 0 reviews
Send a message via Yahoo to whiteboy05
no my gears are going in saturday cause the ups guy couldnt find my house last friday. they were supposed to go in last saturday but Yea F*****G ups guys i hate em.

Airaid Cold air, Sct tuner, X-Pipe ans Zex Wet Nitrous Kit
whiteboy05 is offline  
post #18 of 21 Old June 8th, 2010, 10:05 PM
Regular
 
Join Date: Jun 2008
Location: Thibodaux, LA.
Posts: 86
 
iTrader: 0 reviews
Send a message via AIM to Skinnywhiteguy223 Send a message via Yahoo to Skinnywhiteguy223
mines stuck at 195k .... what is the problem with this crap.... id like to fix it to see what the gas mileage but hey who needs good gas mileage

Live Fast. Die Fun



www.myspace.com/icebreakertaker
Skinnywhiteguy223 is offline  
post #19 of 21 Old June 11th, 2010, 12:23 PM
Newbie
 
Join Date: Jun 2010
Location: Joplin Mo
Posts: 18
 
iTrader: 0 reviews
so my speedometer works but my odometer and my trip dont. Any suggestions on what i should try to fix it?
97 Mustang is offline  
post #20 of 21 Old June 13th, 2010, 09:56 PM
Newbie
 
Join Date: Jun 2010
Location: Joplin Mo
Posts: 18
 
iTrader: 0 reviews
Any ideas?
97 Mustang is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome