Fuel Rail Pressure Sensor help - Forums at Modded Mustangs
Reply
 
LinkBack Thread Tools
post #1 of 36 Old April 4th, 2010, 07:09 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
Fuel Rail Pressure Sensor help

Hey guys. So I wanted to take my car out to make sure the fuel pressure was good and everything. mell0 helped me do my dash pod and boost gauge setup (thanks andy) So I tied the boost vac line in to the fuel rail pressure sensor. I got a code saying "Fuel Rail Pressure Circuit Malfunction"

I thought maybe I pinched off a line, so I re-routed that to a differant vacuum line. Thats all set.

But the on my dads scan tool, I can datalog (kind of) And my fuel pressure seem to jump around a lot. I went WOT in 2nd and hit like 65lb, then driving around it was going like 39, 38, 42, 40, 44, 39...a couple times it hit 36, and twice it hit 34...I dont know if thats too low? So is it possible that my Fuel rail pressure sensor is shitting the bed? Could I use the one off my Dad's 03 Mach 1 to see if thats what it is? Thanks for all the help guys - Shaun


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
Sponsored Links
Advertisement
 
post #2 of 36 Old April 4th, 2010, 07:10 PM
Hooo Ha Ha
 
sharkbait's Avatar
 
Join Date: Apr 2009
Location: Pasadena MD
Posts: 11,220
                     
iTrader: 10 reviews
Send a message via AIM to sharkbait
Well i think its going to fluctuate as you drive. Your fuel pumps have variable speeds while mine runs full power all the time


853rwhp @ 23psi
75mm Turbo 5.4 swap E85
#turbo2v

10.11 @ 138mph STOCK LONGBLOCK
9.20 @ 138 on 16psi - New Longblock /w Powerglide

www.JPCracing.com 410-729-0005 ext. 11

PM me if you need any parts or advice!
sharkbait is offline  
post #3 of 36 Old April 4th, 2010, 07:24 PM
Hardcore Enthusiast
 
mell0's Avatar
 
Join Date: Feb 2010
Location: Gettysburg, PA
Posts: 1,888
       
iTrader: 0 reviews
Send a message via AIM to mell0
yep, my fuel pressure gauge fluctuates as i drive around. usually between 35 and 45 like you said. and my bad with that setup for the boost gauge. a few people suggested it to me, and it's been working for me.

2002 Procharged GT
12.503 @ 113.08
351rwhp 353rwtq
Car Videos: http://www.youtube.com/user/mell00ut5?feature=mhee
mell0 is offline  
post #4 of 36 Old April 4th, 2010, 07:27 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
Quote:
Originally Posted by mell0 View Post
yep, my fuel pressure gauge fluctuates as i drive around. usually between 35 and 45 like you said. and my bad with that setup for the boost gauge. a few people suggested it to me, and it's been working for me.
nah dude dont be sorry at all. It took 2 seconds for me to extend it. And I said I did it anyways

But, it hit 65lb at WOT, that was odd.

And you know what andy, when I was on the way back home going to my house, it started having those idle issues again too. So idk if it was because the fuel rail pressure sensor, or because I cleared the computer. But it seems to be doing okay now...every now an then its a pita.


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
post #5 of 36 Old April 4th, 2010, 07:34 PM
Hardcore Enthusiast
 
mell0's Avatar
 
Join Date: Feb 2010
Location: Gettysburg, PA
Posts: 1,888
       
iTrader: 0 reviews
Send a message via AIM to mell0
Quote:
Originally Posted by Shaun03GT View Post
nah dude dont be sorry at all. It took 2 seconds for me to extend it. And I said I did it anyways

But, it hit 65lb at WOT, that was odd.

And you know what andy, when I was on the way back home going to my house, it started having those idle issues again too. So idk if it was because the fuel rail pressure sensor, or because I cleared the computer. But it seems to be doing okay now...every now an then its a pita.
damn dude, yeah besides that cold start your car seemed like it was idling fine at my house. maybe because it was colder on that trip home. you said it went away when the temps around here got warmer. maybe it is temp related?

2002 Procharged GT
12.503 @ 113.08
351rwhp 353rwtq
Car Videos: http://www.youtube.com/user/mell00ut5?feature=mhee
mell0 is offline  
post #6 of 36 Old April 4th, 2010, 07:42 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
It might be. But, the 2 days before it was fine. Not any problems. Then stuck in traffic alittle it kind of did that. I changed the line from the Fuel rail pressure sensor, so maybe thats all it needed. It should be all set anyways, if not, Ill use my dads sensor on the Mach 1 (if itll work) and see if thats the case.


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
post #7 of 36 Old April 4th, 2010, 10:16 PM
Regular
 
yellow04GT's Avatar
 
Join Date: Feb 2008
Location: vermont
Posts: 414
 
iTrader: 0 reviews
mine throws the same code. mine only does it once and awile on start up. I think mine is because I removed the check valve in the fuel tank. so when I start my car I just turn the key on wait a couple seconds and that seems to help.
yellow04GT is offline  
post #8 of 36 Old April 5th, 2010, 08:46 AM
US Air Force (retired)
 
Eagle2000GT's Avatar
 
Join Date: Aug 2007
Location: Shelbyville, IN
Posts: 10,021
                     
Garage
iTrader: 1 reviews
If you are data logging its supposed to read approximately 40 psi all the time. It is a computer calculated differential pressure across the injectors. An aftermarket gage is not computer corrected and will jump all over the place.

ProCharger P-1SC, 9 psi, STD 396/383; Uncorrected 388/375; SAE 383/370.
<---Mods listed in New Garage.
Eagle2000GT is offline  
post #9 of 36 Old April 5th, 2010, 10:43 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
So I think my fuel rail pressure sensor is shot. Because its hard to start sometimes, and its running like shit at idle. I can smell gas. I cant find any besides the one at Autozone its Holley and its $237. This sucks


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
post #10 of 36 Old April 5th, 2010, 10:56 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
I think this is what I need to get: MOTORCRAFT 3R3Z-9F972-AA
03-04 Mustang SVT Cobra Fuel Rail Pressure Sensor MOTORCRAFT 3R3Z-9F972-AA

But will it work on an 03 GT? And from what I read its cause by hitting the rev limiter. Cause it causes all the injectors to close, and the fuel spikes and breaks the sensor. Makes sence, but I havent hit the limiter in a while, so I though. Maybe I did by accident.

Any help is really appriciated and reps!


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
post #11 of 36 Old April 6th, 2010, 08:35 AM
Regular
 
yellow04GT's Avatar
 
Join Date: Feb 2008
Location: vermont
Posts: 414
 
iTrader: 0 reviews
Shaun have you moddified your fuel hat or lines at all? If you removed the little plastic line on the factory fuel hat try turning the key on the on position wait till the fuel pumps shut off then crank it over. this may help.
yellow04GT is offline  
post #12 of 36 Old April 6th, 2010, 02:48 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
Yea I usually do that before I start it. It does help sometimes. But idle is my problem. I really think its my fuel rail pressure sensor. Cause it smells rich as hell at idle, and Ive heard these are common.


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
post #13 of 36 Old April 6th, 2010, 05:25 PM
April 2012 ROTM
 
wishIhada5.0's Avatar
 
Join Date: Feb 2008
Location: About an hour east of Pittsburgh
Posts: 4,729
       
iTrader: 0 reviews
Send a message via AIM to wishIhada5.0
Quote:
Originally Posted by yellow04GT View Post
mine throws the same code. mine only does it once and awile on start up. I think mine is because I removed the check valve in the fuel tank. so when I start my car I just turn the key on wait a couple seconds and that seems to help.
I just got done putting the GT pump in my car a few days ago...it wont make fuel pressure until you start cranking it over..I have no idea why lol you can sit there with the ignition on all day and it just wont make pressure until you go to start it but back on topic..to the OP...its normal for the pres. numbers to fluctuate like that

True blue crew founder/member #1 Newest Project: 2010 Ram 2500 Cummins G56 RCLB Rollin' Coal Crew Founder
wishIhada5.0 is offline  
post #14 of 36 Old April 6th, 2010, 05:47 PM
MM Fanatic
 
Trick Tuners's Avatar
 
Join Date: Nov 2006
Location: San Diego
Posts: 4,465
           
iTrader: 3 reviews
Quote:
Originally Posted by Eagle2000GT View Post
If you are data logging its supposed to read approximately 40 psi all the time. It is a computer calculated differential pressure across the injectors. An aftermarket gage is not computer corrected and will jump all over the place.
Correct, except its not computer calculated, its boost and vacuum referenced. Picture it like a diaphragm with boost and vac on one side, and fuel pressure on the other. When it moves toward the B/V side the pressure goes up.
Quote:
Originally Posted by Shaun03GT View Post
But, it hit 65lb at WOT, that was odd.
Are you using a boost a pump? They can cause high pressures when they are wired post FPDM.
Trick Tuners is offline  
post #15 of 36 Old April 6th, 2010, 07:43 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
No boost a pump.

Can anyone get back to me on the Fuel Rail Pressure Sensor? Would this be causing rough idles, and hard starts? Because it's throwing codes for "Fuel Rail Pressure Circuit Malfunction"


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
post #16 of 36 Old April 8th, 2010, 11:26 AM
MM Fanatic
 
Trick Tuners's Avatar
 
Join Date: Nov 2006
Location: San Diego
Posts: 4,465
           
iTrader: 3 reviews
Quote:
Originally Posted by Shaun03GT View Post
Would this be causing rough idles, and hard starts?
yes, it will. Replace it.
Trick Tuners is offline  
post #17 of 36 Old April 8th, 2010, 01:02 PM
MM Fanatic
 
0949er's Avatar
 
Join Date: Apr 2010
Location: Charlotte
Posts: 3,429
       
iTrader: 0 reviews
how confident are you in your tune?


MODS:

Vortech V1 T-Trim @ 7.5 PSI (tuned down)
Comp Cams XE270-AH
+ See Garage

432 rwhp / 396 rwtq 02/27/2011
NEW VIDEOS!
**It takes ~$60 a rwhp (over stock) for a 99-04 Mustang GT.** Do the Math
PLANS ON HOLD
0949er is offline  
post #18 of 36 Old April 8th, 2010, 01:21 PM
MM Fanatic
 
Trick Tuners's Avatar
 
Join Date: Nov 2006
Location: San Diego
Posts: 4,465
           
iTrader: 3 reviews
Quote:
Originally Posted by 0949er View Post
how confident are you in your tune?
A "bad" tune could cause the frps to pop more often, but shouldn't cause these issues or the code.
Trick Tuners is offline  
post #19 of 36 Old April 8th, 2010, 01:24 PM
BYAHHHH!
 
Scott2001GT's Avatar
 
Join Date: Mar 2008
Location: Missouri
Posts: 18,039
Blog Entries: 1
                     
iTrader: 5 reviews
yeah I have a sensor problem too.Its a code saying fuel Rail Pressure Sensor.

<img src=http://i714.photobucket.com/albums/ww144/scott2001GT/scott2001gt_sig-1.jpg border=0 alt= />

Powered by Ford
Boosted by Precision Turbo and Engine

Thanks to: Wagon Wheel Performance & STL Mustangs
Scott2001GT is offline  
post #20 of 36 Old April 8th, 2010, 02:52 PM Thread Starter
I Post Entirely Way Too Much
 
Shaun13GT/CS's Avatar
 
Join Date: Sep 2009
Location: MA
Posts: 20,598
                     
iTrader: 27 reviews
Quote:
Originally Posted by 0949er View Post
how confident are you in your tune?
I wasnt at first, but now I am. I thought it was somethin totally differant. But Im ordering a Fuel Rail Pressure sensor tomorrow or Saturday


2009 Corvette Z06 - ARH 2" Headers, off road X, Borla Stingers, BPP Ram Air Intake
Previous Cars
13 Mustang GT Bolt Ons - 11.58 @ 122.13
03 Mustang GT Vortech - 11.98 @ 118.68
Shaun13GT/CS is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  LinkBacks (?)
LinkBack to this Thread: http://www.moddedmustangs.com/forums/99-04/159853-fuel-rail-pressure-sensor-help.html
Posted By For Type Date
Fuel Rail Pressure Sensor Mazda Tribute This thread Refback October 17th, 2012 10:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome