2001 3.8 torque converter installed wrong - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 4 Old March 28th, 2014, 04:33 AM Thread Starter
Regular
 
Join Date: Dec 2012
Posts: 136
 
iTrader: 0 reviews
2001 3.8 torque converter installed wrong

i attempted my first engine swap and pulled the engine and tranny. when i went to install the torque converter i installed it on to the flexplate first then put on the transmission and bolted it on. now my car cranks slowly. i realized i installed the torque converter wrong. i know i could have possibly damaged the pump in the transmission. i will pull off the tranny today i just wanted to know how i can inspect the tranny to make sure i didnt break anything. thanks
99gt95 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old March 28th, 2014, 07:07 AM
hi you can call me mater
 
03 cristian's Avatar
 
Join Date: Jan 2011
Location: Douglas,ga
Posts: 4,844
 
iTrader: 5 reviews
Quote:
Originally Posted by 99gt95 View Post
i attempted my first engine swap and pulled the engine and tranny. when i went to install the torque converter i installed it on to the flexplate first then put on the transmission and bolted it on. now my car cranks slowly. i realized i installed the torque converter wrong. i know i could have possibly damaged the pump in the transmission. i will pull off the tranny today i just wanted to know how i can inspect the tranny to make sure i didnt break anything. thanks
Maybe drain the tranny oil and inspect for foreign material


"I wonder if I sprayed some on my junk, I could go raw dog and not get herpes. But first I'd have to find a female willing to have relations."-kmac1622
03 cristian is offline  
post #3 of 4 Old March 28th, 2014, 03:43 PM
Head Unicorn
 
bulloch27's Avatar
 
Join Date: Jan 2011
Location: Statesboro, Ga
Posts: 5,069
                 
iTrader: 0 reviews
I'd pull the trans, seat the converter properly and put it back together. Don't bother with the front pump unless the trans fails. Damage is likely though.


03 Silver Fauxbra; 06 Legend Lime GT, 89 Outlaw 10.5W Coupe, 93 Teal Cobra, 93 Red GT, 93 Teal LX
Unicorn Club Founding Member
bulloch27 is offline  
post #4 of 4 Old March 28th, 2014, 03:52 PM Thread Starter
Regular
 
Join Date: Dec 2012
Posts: 136
 
iTrader: 0 reviews
Quote:
Originally Posted by bulloch27 View Post
I'd pull the trans, seat the converter properly and put it back together. Don't bother with the front pump unless the trans fails. Damage is likely though.
ok im going to do that hope the trans is good. thanks
99gt95 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome