Air-Bag Problems 1997 - Forums at Modded Mustangs
Reply
 
LinkBack Thread Tools
post #1 of 23 Old February 2nd, 2011, 01:31 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
Question Air-Bag Problems 1997

I have a 1997 Ford Mustang 3.8 litter engine with 90,000 miles, Manuel transmission. I have the air-bag light on. I just disconnected the battery for an hour to try and remove the code off the dash. The air-bag light is still on, I went to a ford dealership. They wanted to look at it for $190 for a diagnosis. I don't have that kind of cash just for a look. Where do I go from here to remove that error?

The air-bag are still there and as far as I know they are fine. Oh and had another friend sit in the passenger seat, I saw someone give that advice to get rid of the problem but still nothing. Please HELP!
GarrettMustang is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old February 2nd, 2011, 02:12 PM
Newbie
 
Join Date: Sep 2010
Location: Kansas
Posts: 37
 
iTrader: 0 reviews
When you start your car, the airbag light might/should flash. Count the number of flashes, there should be a pause between the sets of flashes. Post the number here, to better figure it out.

Also does your horn work? A somewhat common cause of the airbag light being on, is the clockspring in the steering wheel has gone bad. I replaced mine last year.
trashpickinman is offline  
post #3 of 23 Old February 2nd, 2011, 06:43 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
I dont know if this is going to help but it flashed 15x times then stays on. Does that mean anything.
Yes the horn works fine.
Thanks for the quick response.
GarrettMustang is offline  
post #4 of 23 Old February 2nd, 2011, 08:10 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
I looked into the flashing a little closer and it turned out to be 12 for the code. 1 blip and 2 blips after that. Then repeat a couple of times.
GarrettMustang is offline  
post #5 of 23 Old February 2nd, 2011, 08:17 PM
Better than Drugs!
 
mayosailor27's Avatar
 
Join Date: Feb 2011
Location: Huntington, Indiana
Posts: 2,064
   
iTrader: 1 reviews
hey man hope over to corral.net register and use the search-- theres alot of stuff on how to do airbag shit. ill check my favorites and see if i can find it. uno momento

96 GT-sold
98 GT-parted
90 GT-traded
98 GT-traded
98 GT-parted
94 GT/Cobra-sold
95 Cobra Saleened-sold
97 Cobra-sold
99 GT-sold
97 Cobra-sold
95 Cobra- sold
97 Cobra-parts
96 Cobra-sold
96 Cobra- Project "Dead Pony"

MM Cobra member 969
mayosailor27 is offline  
post #6 of 23 Old February 2nd, 2011, 08:22 PM
Better than Drugs!
 
mayosailor27's Avatar
 
Join Date: Feb 2011
Location: Huntington, Indiana
Posts: 2,064
   
iTrader: 1 reviews
nah man didnt have it in my favs but ill look around to find some info on reseting it yourself without the dealers help. There are ways to do it

96 GT-sold
98 GT-parted
90 GT-traded
98 GT-traded
98 GT-parted
94 GT/Cobra-sold
95 Cobra Saleened-sold
97 Cobra-sold
99 GT-sold
97 Cobra-sold
95 Cobra- sold
97 Cobra-parts
96 Cobra-sold
96 Cobra- Project "Dead Pony"

MM Cobra member 969
mayosailor27 is offline  
post #7 of 23 Old February 2nd, 2011, 08:36 PM
Newbie
 
Join Date: Sep 2010
Location: Kansas
Posts: 37
 
iTrader: 0 reviews
Try checking fuse number 4 under your dash, should be a 10 amp fuse. It should only replaced with a 10 amp fuse. If the fuse is blown it could indicate and short in the airbag system. Just to be on the safe side, whenever working on airbags always keep your head and other body parts away from in front of the airbags. With airbags its just better to pull the negative off the battery and wait 10 mintues before working on them. Just in case.

Last edited by trashpickinman; February 2nd, 2011 at 08:48 PM.
trashpickinman is offline  
post #8 of 23 Old February 2nd, 2011, 08:46 PM
Better than Drugs!
 
mayosailor27's Avatar
 
Join Date: Feb 2011
Location: Huntington, Indiana
Posts: 2,064
   
iTrader: 1 reviews
just pull the fuse, disconnect the blue box under the dash so it doesnt beep at you when you first start it, then pull the bulb out of the cluster. then you have no light to look at, and when you wreck, no air bags to total you out... easy day

96 GT-sold
98 GT-parted
90 GT-traded
98 GT-traded
98 GT-parted
94 GT/Cobra-sold
95 Cobra Saleened-sold
97 Cobra-sold
99 GT-sold
97 Cobra-sold
95 Cobra- sold
97 Cobra-parts
96 Cobra-sold
96 Cobra- Project "Dead Pony"

MM Cobra member 969
mayosailor27 is offline  
post #9 of 23 Old February 3rd, 2011, 01:49 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
Okay, I found out there was a 15 amp instead of a 10 amp. Put the right one in there now it is giving me code 32.
Which I think I read something about a clockspring but not sure what do to now. I'll post later if I figure it out. Help please if you know.
Is that the code you were getting Trashpickinman? If so how did you get rid of it?
GarrettMustang is offline  
post #10 of 23 Old February 3rd, 2011, 03:10 PM
Newbie
 
Join Date: Sep 2010
Location: Kansas
Posts: 37
 
iTrader: 0 reviews
Yes, I believe I was getting code 32. The clockspring assembly was about $60 online. Fairly simple install, though you need a steering wheel puller. Disconnect battery, wait, remove air bag. Mark position of steering wheel with wheels straight before removing, wiring, column and under dash trim, then the clockspring is removed. Install is reverse. Steering wheel bolt torqued to 23-33 lb-ft.

Though it is somewhat disconcerting that a different rated fuse was in there than what I believe should be in there, according to the manual. Has anybody else owned your car before you, or any other service done for the airbags?
trashpickinman is offline  
post #11 of 23 Old February 8th, 2011, 02:34 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
Trashpickinman yea someone did owned it before me. I called him today with no answer other than he bought it from someone else. Bought the clockspring and waiting for it, so I will update everyone later this week or so. Getting the wheel puller today.
thanks.
GarrettMustang is offline  
post #12 of 23 Old February 11th, 2011, 02:02 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
I just found out that the clockspring was not connected after all. Not getting error code 32, any longer. Now Getting Error Code 33. Trying to look it up now, this is fun, 1 error code after another.

Last edited by GarrettMustang; February 11th, 2011 at 08:55 PM.
GarrettMustang is offline  
post #13 of 23 Old February 11th, 2011, 02:40 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
Does anyone have a mustang "passenger compartment fuse block" diagram for 1997 (or 1995 - 1998)?
GarrettMustang is offline  
post #14 of 23 Old February 11th, 2011, 04:37 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
Nevermind on the passenger compartment fuse block diagram I found it, checked every single fuse on the car, they are all the right amp and are not broken.
Anyone know what this means? Code 33 = Passenger Side Air Bag Circuit High Resistance or Open
What do I do?!? HELP PLZ!
GarrettMustang is offline  
post #15 of 23 Old February 14th, 2011, 01:58 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 9
 
iTrader: 0 reviews
BUMP anyone know what to do if you get air bag diagnostic code #33? HELP PLEASE
GarrettMustang is offline  
post #16 of 23 Old February 14th, 2011, 02:30 PM
Newbie
 
Join Date: Sep 2010
Location: Kansas
Posts: 37
 
iTrader: 0 reviews
Unfortunately, with code 33, it starts getting trickier and harder to diagnose. With "32" its usually the clockspring, "33" could be the airbag itself, or the wiring. PM me GarrettMustang, if you'd like me to send you the full troubleshooting steps, though I've never attempted them.
trashpickinman is offline  
post #17 of 23 Old March 30th, 2011, 11:38 PM
Hardcore Enthusiast
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 2,510
Blog Entries: 3
 
iTrader: 3 reviews
I own a 98 v6 and have a code 12 ( it blinks 1 then 2 so I assume 12). Im going to check the fuse 2morrow and post what I find
07gtS197 is online now  
post #18 of 23 Old March 31st, 2011, 01:17 AM
Regular
 
Join Date: Nov 2010
Location: Rock Hill, SC
Posts: 398
   
iTrader: 1 reviews
my 01 has a code 21 - Diagnostic Monitor Not Mounted to Vehicle Properly. turns out the module is behind the radio and has two studs and the nuts are missing. anybody know what size the nuts are?


Mods in Garage

My Youtube Channel watch my funny videos, make me daz moneyz

Quote:
Originally Posted by walt1120 View Post
Listen hoe, the terminator cobra is the most baddest piece of engineering ever to exist. A man becomes baddest the moment he sits in one.
mycurse01 is offline  
post #19 of 23 Old April 2nd, 2011, 05:08 PM
Hardcore Enthusiast
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 2,510
Blog Entries: 3
 
iTrader: 3 reviews
mycurse01 I just checked and if ur talking about the green bolts they are 8mm. Also I need help reseting my airbag computer so any info would be appreciated
07gtS197 is online now  
post #20 of 23 Old April 2nd, 2011, 07:49 PM
Regular
 
Join Date: Nov 2010
Location: Rock Hill, SC
Posts: 398
   
iTrader: 1 reviews
Quote:
Originally Posted by 00MustangGtPremium View Post
mycurse01 I just checked and if ur talking about the green bolts they are 8mm. Also I need help reseting my airbag computer so any info would be appreciated
thanx for the reply. i finally got off my lazy ass and pulled the radio out again. these are what i was talking about.


they are the same as the nuts for the tailights just witout the washers. so i will just match them up to the hardware store.

as for your question, when i was looking up my airbag stuff this site has alot of info. Mustang Air Bag Diagnostic Codes


Mods in Garage

My Youtube Channel watch my funny videos, make me daz moneyz

Quote:
Originally Posted by walt1120 View Post
Listen hoe, the terminator cobra is the most baddest piece of engineering ever to exist. A man becomes baddest the moment he sits in one.
mycurse01 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome