Forums at Modded Mustangs

Forums at Modded Mustangs (https://www.moddedmustangs.com/forums/)
-   2.3 Mustangs (https://www.moddedmustangs.com/forums/2-3-mustangs/)
-   -   No power whatsoever. 45 mph tops. (https://www.moddedmustangs.com/forums/2-3-mustangs/479946-no-power-whatsoever-45-mph-tops.html)

byargeon1 September 15th, 2014 11:49 PM

No power whatsoever. 45 mph tops.
 
Guys I have a 93 lx 4cyl 2.3 auto with 112000 miles on it that is driving me nuts. It takes 2-5 tries before it actually will stay running and when it does finally stay it vibrates like crazy. When I go to drive it if I don't hold it to the floor I go nowhere. I can hold the gas pedal all the way to the floor and might be able to reach 45-50 mph in a mile. I have replaced fuel pump twice,filter three times,maf,iat,tps,plugs,wires and checked timing. I am coming over from Chevy so please be gentle to me. It has me about to just give up and sale it. Which I would hate to do cause I love this car. Please help in any way possible. Thank any and all who help. Also it has no knocking,smoking,or overheating at all. It also has straight exhaust so no cats. Thanks.

Mikel89us September 16th, 2014 06:53 AM

Do a compression test. We can go from there.

gibbstroy November 18th, 2014 01:44 PM

Ive had an ECM go out on my 2.3, it had the same symptoms.

ghunt November 18th, 2014 04:25 PM

30 Attachment(s)
Must've not been a big deal since he hasn't been back in 2 months.


All times are GMT -4. The time now is 01:31 PM.

powered by vBulletin ©2000 - 2019, Jelsoft Ent. Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome