Anyone replaced their engine harness? - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 1 Old October 8th, 2014, 03:35 AM Thread Starter
Newbie
 
Join Date: Mar 2012
Location: Kansas
Posts: 8
 
iTrader: 0 reviews
Anyone replaced their engine harness?

I purchased a new 2.3 engine harness for my 84 SVO from latemodel. After pulling it out of the box, and looking it over I realize there are some differences vs. my original harness. It's pinned for an LA3 swap that I'm not doing, so I will have to swap the pins. There is also a bank of relays, and some fuses, that my car doesn't have. I'm feeling overwhelmed right now, and I'm not sure how I can make this work. Have any of you done this swap that could give me some pointers? I expected that it would be a big job, but the extra parts confuse me, and I'm not sure what to do.
crmnl is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome