Reinstalling my emission equipment mad my car run BETTER - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 15 Old November 11th, 2014, 03:56 PM Thread Starter
Enthusiast
 
CHIODI's Avatar
 
Join Date: Feb 2010
Location: New York
Posts: 551
 
iTrader: 0 reviews
Reinstalling my emission equipment mad my car run BETTER

So many symptoms were cleared up by installing egg and smog equip. Everyone thought I was crazy.

1987 5.0 Notch
CHIODI is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old November 13th, 2014, 11:51 PM
He of Long Wind
 
Mike in Kentucky's Avatar
 
Join Date: Aug 2010
Location: Oil Springs, KY
Posts: 2,126
           
iTrader: 0 reviews
You might be, but at least you're more environmentally friendly.

BUILD THREAD


'84 Hatch, Bracket Car, [email protected], but I'm working on it
'71 Mach One FB 351c, Slow
'73 Torino, 302, Slower


~
Mike in Kentucky is offline  
post #3 of 15 Old November 17th, 2014, 09:39 AM
dirt/street Motorsports
 
vroom vrooooom's Avatar
 
Join Date: Jan 2013
Location: the great state of Arizona
Posts: 683
   
iTrader: 0 reviews
I thought I'd take that shit of mine also but the car runs good. And just don't need to be tracking down more engine bugs. I need to move on to suspension/interior.

90 5.0 lx 5 speed. Project Classic 5.0 - BBK CAI, BBK longtubes , GT40 heads, 24 lb injectors , Edelbrock intake.
vroom vrooooom is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old December 1st, 2014, 11:41 PM Thread Starter
Enthusiast
 
CHIODI's Avatar
 
Join Date: Feb 2010
Location: New York
Posts: 551
 
iTrader: 0 reviews
I bought my car with everything removed and it ran ok but a bit shaky. Then I did a maf conversion and the engine would surge like a bitch, had to set idle to like 1000 rpm or more just get it to run. I finally reconnected the ear, then the smog stuff and I'm so happy. I've been banging my head against the wall for a year almost

---------- Post added at 11:39 PM ---------- Previous post was at 11:38 PM ----------

The car becomes much more finicky when you do an maf conversion

---------- Post added at 11:41 PM ---------- Previous post was at 11:39 PM ----------

Everything is much much smoother. If you wanna remove all that stuff the computer has to be tuned I think

1987 5.0 Notch
CHIODI is offline  
post #5 of 15 Old December 4th, 2014, 02:42 PM
Regular
 
Join Date: Jan 2012
Location: Arlington WA
Posts: 208
 
iTrader: 0 reviews
Actually, MAF is less finicky than SD, unless you have a vac leak then the opposite is true.

The ecu does NOT need a tune to run without EGR.

Odds are, you had a vac leak in the EGR and fixed it when you put the EGR back in...

Regardless of the reason though, if it runs right... enjoy it...
vristang is offline  
post #6 of 15 Old December 4th, 2014, 03:02 PM
Hardcore Enthusiast
 
428CJ's Avatar
 
Join Date: Oct 2010
Location: Boise, Id
Posts: 2,466
         
iTrader: 0 reviews
Ya, when I maf converted my car it sorted out surging and idle issues I was fighting for 3 years. I also think you just had a vacuum leak somewhere causing issues that were not related to the maf conversion.

Quote:
Originally Posted by Shift View Post
If you have $40 in your wallet and your girlfriend has $5 in hers. How much money does your girlfriend have?

$45. She has $45.

428CJ is offline  
post #7 of 15 Old December 4th, 2014, 10:41 PM Thread Starter
Enthusiast
 
CHIODI's Avatar
 
Join Date: Feb 2010
Location: New York
Posts: 551
 
iTrader: 0 reviews
I had no surges w speed density. I did after the maf conversion. Erg didn't totally clear the trouble. It really got good after I installed the smog pump and moved the pins in the ecc harness connector to work for the solenoids Engine is smoother and I can set the idle lower. I guess every car is different

1987 5.0 Notch
CHIODI is offline  
post #8 of 15 Old December 5th, 2014, 08:30 AM
Regular
 
Join Date: Jan 2012
Location: Arlington WA
Posts: 208
 
iTrader: 0 reviews
smog pump and solenoids would make NO difference to drivability like you are describing...
Plenty of us have simply removed the pump and removed the solenoids with no issues...

I think you unkowingly fixed something when you reinstalled the emissions gear, and I'm curious as to what
vristang is offline  
post #9 of 15 Old December 5th, 2014, 09:02 AM Thread Starter
Enthusiast
 
CHIODI's Avatar
 
Join Date: Feb 2010
Location: New York
Posts: 551
 
iTrader: 0 reviews
I'm curious too.I can assure you I checked and repaired any vacuum issues and STILL had idle and surge issues. Egr installation fixed the warm idle surges but I still had cold idle surges and I had to have the idle set really high. I reconnected the smog equipment and all the issues disappeared. The car starts immediately and goes right to base idle now.

I disagree that smog solenoids don't affect how an engine runs. The air it pumps into the exhaust and headers allow for smoother ventilation and exhaust burning plus the air is needed to keep the cats from failing prematurely. Furthermore , I've been told that the O2 sensors do a better job with smog equipment. Lastly, it really helps with the raw fuel exhaust smells. Finally the computer isn't throwing codes. That's a very strong argument for smog equipment.

I would think the computer would need a tune without all the stuff connected. Does anyone have a car that runs and idles pertfectly and smooth, without a tune and emissions equipment?
CHIODI is offline  
post #10 of 15 Old December 5th, 2014, 12:26 PM
MM Fanatic
 
Green_6er's Avatar
 
Join Date: Jun 2011
Location: Hickory, NC
Posts: 4,256
       
iTrader: 6 reviews
Did you plug the back of the head when you took the smog pump off?
Green_6er is offline  
post #11 of 15 Old December 5th, 2014, 01:20 PM Thread Starter
Enthusiast
 
CHIODI's Avatar
 
Join Date: Feb 2010
Location: New York
Posts: 551
 
iTrader: 0 reviews
Yes
CHIODI is offline  
post #12 of 15 Old December 5th, 2014, 09:00 PM
Newbie
 
Join Date: May 2010
Posts: 30
 
iTrader: 0 reviews
Quote:
Originally Posted by CHIODI View Post
. Does anyone have a car that runs and idles pertfectly and smooth, without a tune and emissions equipment?
Yes

ETA : quite a few
40twist is offline  
post #13 of 15 Old December 10th, 2014, 02:26 PM
Regular
 
Join Date: Jan 2012
Location: Arlington WA
Posts: 208
 
iTrader: 0 reviews
Quote:
Originally Posted by CHIODI View Post
Does anyone have a car that runs and idles pertfectly and smooth, without a tune and emissions equipment?
Mine ran great when I removed the emissions, just had the CEL light on.
When I did tune it (disabling the emissions functions), I didn't see a noticable difference either...
vristang is offline  
post #14 of 15 Old December 12th, 2014, 01:07 AM
 
Z)OoM's Avatar
 
Join Date: Mar 2012
Location: Mid-Michigan
Posts: 193
 
iTrader: 0 reviews
My 5.0 has no emissions as well. IAC causes a surge, but it ran great for 2 years.

I did have problems with my pro-m maf and 19lb injectors, stock maf cleared it up.

92 GT - Trickflow Intake, BBK LT's+Xpipe, UDP, King Cobra clutch, 3.27's. Chasing LT1's down
[email protected] - Street Tires
[email protected] - Slicks
Soon -- Gt40p/F303 PnPMegasquirt
94 Flareside F150 3" w/flowmaster, open diff-3.08's
Z)OoM is offline  
post #15 of 15 Old December 13th, 2014, 12:37 PM
He of Long Wind
 
Mike in Kentucky's Avatar
 
Join Date: Aug 2010
Location: Oil Springs, KY
Posts: 2,126
           
iTrader: 0 reviews
Quote:
Originally Posted by CHIODI View Post
Does anyone have a car that runs and idles pertfectly and smooth, without a tune and emissions equipment?
I solved my EFI problems a different way. Wouldn't go so far as to call the idle smooth though ...


BUILD THREAD


'84 Hatch, Bracket Car, [email protected], but I'm working on it
'71 Mach One FB 351c, Slow
'73 Torino, 302, Slower


~
Mike in Kentucky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome