Wrench Light - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 1 Old July 10th, 2019, 06:23 PM Thread Starter
Newbie
 
Join Date: Jul 2019
Posts: 3
 
iTrader: 0 reviews
Wrench Light

Hey! The wrench light lighten up on my 2014 and was wondering if there is any update about that light. I looked up on forums and this light seems confusing for most of us but it was post from a couple of years so is there any update about it?.

When i go WOT, the wrench light open and my rpm seems to stop at about 4800rpm but not with the rev limiter, more like the engine is stalling. But, when it does it the LIMP MODE message isn't on the cluster screen. Also. when i put the keys to on, the light doesn't open automatically but i notices that when i plug my sct x4 to tune the car, sometime(half the time) there's a error code on the tuner and i cannot tune the car. As soon as the message code appears, the wrench light open.

Most of the forums i read was saying it was the throttle body but i doubt it since it does it on either the oem one or the bbk 73mm. I looked up the connector pins and everything seems normal. I also doubt it's the MAF since the light appears when i try to tune the car(car off) and i guess any MAF error would ounly be when the car is running. As expected, no code on the check engine with this wrench light.

Any guess?
GabLeGrand is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome