Vacuum? MAF? Idk what's wrong - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 8 Old June 9th, 2013, 03:07 AM Thread Starter
MM Fanatic
 
RedFire Venom's Avatar
 
Join Date: Mar 2012
Location: Kansas
Posts: 3,015
       
iTrader: 6 reviews
Vacuum? MAF? Idk what's wrong

So I'm on my way home and I get on the highway on ramp and car starts bogging. So I played around with it a but and it bogs down any time I'm above 10 vacuum. I checked fuel pressure and its fine, so any ideas?

Quote:
Originally Posted by HighDensity View Post
That's why we give cars female names, because we enjoy shaving their parts.


RedFire Venom is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old June 9th, 2013, 11:09 AM
Premium Member
 
02sonicGT's Avatar
 
Join Date: May 2008
Location: Temecula, CA
Posts: 1,906
           
Garage
iTrader: 1 reviews
Check all vacuum and intercooler pipes. My guess is you popped a coupler.


Sent from AutoGuide.com App


SOLD : 02 Sonic Blue GT - Vortech V3-Si, Treadstone TRV25O, Tial Q, PMAS HPX MAF
SOLD : 14 Ruby Red F150 Ecoboost
15 Mustang GT PP - SCT Tune & Exhaust.
Click Here to see my 02 Vortech V3 Build Thread
02sonicGT is offline  
post #3 of 8 Old June 9th, 2013, 04:01 PM
The Little 2v That Could
 
srt10ram's Avatar
 
Join Date: Jun 2012
Location: NOLA/BR
Posts: 1,623
             
iTrader: 2 reviews
^^couplers, maf, bov, and vacuum lines are your best bet. If you can't visibly see anything mix soap and water in a spray bottle and check for leaks.


Toy - 01' Bullitt #3320: Borg Warner S475/83 - Built 4r70w
DD - 09' Kawasaki ZX6r
srt10ram is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old June 9th, 2013, 05:28 PM Thread Starter
MM Fanatic
 
RedFire Venom's Avatar
 
Join Date: Mar 2012
Location: Kansas
Posts: 3,015
       
iTrader: 6 reviews
Quote:
Originally Posted by 02sonicGT View Post
Check all vacuum and intercooler pipes. My guess is you popped a coupler.


Sent from AutoGuide.com App
Quote:
Originally Posted by srt10ram View Post
^^couplers, maf, bov, and vacuum lines are your best bet. If you can't visibly see anything mix soap and water in a spray bottle and check for leaks.
Apparently ALL of my piping from the BOV down had water in it from our mini flood last night. It runs ok now but I'm sure all the water is going to cause some long term problems

Quote:
Originally Posted by HighDensity View Post
That's why we give cars female names, because we enjoy shaving their parts.


RedFire Venom is offline  
post #5 of 8 Old June 9th, 2013, 07:05 PM
I Post Entirely Way Too Much
 
Mustang_Girl_32's Avatar
 
Join Date: Jun 2010
Location: Central Illinois
Posts: 5,410
         
iTrader: 38 reviews
I have had that a couple times when it had rained alot. It acted funny but when it dried out it was fine.




Procharger P1sc| 2 core| 353hp/347tq| Mac lt's| lethal x| slp lm1| 75mm tb/plenum| 4.10's| lca| flsfc| h&r's

Oh ya, and female owned and driven!

Sonic Blue Crew
Mustang_Girl_32 is offline  
post #6 of 8 Old June 9th, 2013, 07:09 PM
Cleg Jr.
 
bluebandit!'s Avatar
 
Join Date: Mar 2010
Location: Erie, PA
Posts: 9,436
               
iTrader: 0 reviews
Quote:
Originally Posted by RedFire Venom View Post
Apparently ALL of my piping from the BOV down had water in it from our mini flood last night. It runs ok now but I'm sure all the water is going to cause some long term problems
I'd say once it all dries it should be ok. Be grateful that you didn't suck in a lot of water and hydrolock your engine


Sent from AutoGuide.com Free App

Quote:
Originally Posted by 69fastback View Post
He's one of three smart people in this thread. He may be the smartest because he's making the swap.
bluebandit! is offline  
post #7 of 8 Old June 10th, 2013, 03:55 PM
Premium Member
 
02sonicGT's Avatar
 
Join Date: May 2008
Location: Temecula, CA
Posts: 1,906
           
Garage
iTrader: 1 reviews
Sucking a little water actually helps ti clean carbon buildup just like seafoam.

Did you drive through deep water?


Sent from AutoGuide.com App


SOLD : 02 Sonic Blue GT - Vortech V3-Si, Treadstone TRV25O, Tial Q, PMAS HPX MAF
SOLD : 14 Ruby Red F150 Ecoboost
15 Mustang GT PP - SCT Tune & Exhaust.
Click Here to see my 02 Vortech V3 Build Thread
02sonicGT is offline  
post #8 of 8 Old June 10th, 2013, 05:54 PM
I Post Entirely Way Too Much
 
sharkbait's Avatar
 
Join Date: Apr 2009
Location: Pasadena MD
Posts: 11,354
                     
iTrader: 10 reviews
Send a message via AIM to sharkbait
Use a little MAF Cleaning spray on the sensor itself and dry up the piping. You should be fine after that.

The water probobly messed with the maf signal causing it to bog down and act funny.

A little water may have made it into the engine but nothing I would worry about.
sharkbait is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome