Turn signals shut off quickly - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 2 Old June 21st, 2019, 11:40 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Posts: 9
 
iTrader: 0 reviews
Turn signals shut off quickly

Anyone know why? Is it the cheap after market multi function switch? They blink normal but as soon as the wheel turns slightly they click off. I'd like them to be on a tad longer.
ShuttleMan is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old June 23rd, 2019, 04:23 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Posts: 9
 
iTrader: 0 reviews
NVM got it.
ShuttleMan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome