Help with an 85 ltd crown vic - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 6 Old March 26th, 2016, 02:03 AM Thread Starter
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,463
Blog Entries: 3
     
iTrader: 5 reviews
Help with an 85 ltd crown vic

Hey guys, anyone know anything about these cars or the cfi 302? I recently bought one and am having some problems with it.
07gtS197 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old March 26th, 2016, 07:23 PM Thread Starter
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,463
Blog Entries: 3
     
iTrader: 5 reviews
Nobody?
07gtS197 is offline  
post #3 of 6 Old April 13th, 2016, 11:10 PM
Newbie
 
Join Date: Feb 2016
Posts: 36
 
iTrader: 0 reviews
what kind of problems?
Dans02GT is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old April 13th, 2016, 11:30 PM Thread Starter
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,463
Blog Entries: 3
     
iTrader: 5 reviews
Well

The fast idle cam keeps engaging and will not release, Im not sure what part Id need to fix it. I think I put a vacuum on the dashpot (?) and see if it releases but it also has a heated element that moves too so Im not sure which controls the fast idle cam.

Im losing coolant somewhere but its not a blown head gasket or an external leak so Im at a loss. Ive noticed that when I turn the car off the coolant lines will gurgle like theres air in the system or its boiling. Not sure what to do there.

Theres a tapping on bank 1 somewhere around cylinder 2 or 3. How do I adjust the valves? Im thinking thats the problem.

Theres probably more but I cant think of them right now lol. Ive always wanted a square body crown vic but I didnt realize some had this stupid cfi...
07gtS197 is offline  
post #5 of 6 Old April 14th, 2016, 01:01 AM
Newbie
 
Join Date: Feb 2016
Posts: 36
 
iTrader: 0 reviews
Quote:
Originally Posted by 07gtS197 View Post
Im losing coolant somewhere but its not a blown head gasket or an external leak so Im at a loss. Ive noticed that when I turn the car off the coolant lines will gurgle like theres air in the system or its boiling. Not sure what to do there.
Check your coolant pressure cap if you haven't already.

Depending how a head gasket blows, sometimes it will only push gas into the coolant, and cause it to overheat. do this one too many times and it will show itself.

No ideas for you on the rest of it.

Edit: I'm assuming it's a 5.0?

Valve adjustment should be as simple as this:
Dans02GT is offline  
post #6 of 6 Old April 14th, 2016, 09:07 AM Thread Starter
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,463
Blog Entries: 3
     
iTrader: 5 reviews
Thanks for the info. Ill check it out and yes its a 302.
07gtS197 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome