Should I be worried? - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 8 Old March 30th, 2018, 05:51 PM Thread Starter
Waldo-Mustang
 
Join Date: Oct 2015
Location: Huntington, Long Island, New York
Posts: 34
 
iTrader: 0 reviews
Should I be worried?

Hi y'all! I made the stupidest mistake anyone could ever do...
I was trying to park on the side of the road, and I didn't realize I was still rolling forward and I put my car in reverse (automatic) I heard a grinding noise and I immediately hit the brakes and put it in neutral. should I be worried? I was going no more than like 10mph

2005 mustang gt premium
automatic tranny
Waldo14 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old March 30th, 2018, 07:59 PM
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,456
Blog Entries: 3
     
iTrader: 5 reviews
I wouldnt if its not slipping. Is there a shift flare from 1-2? If Im not mistaken thats usually a telltale sign the 5r55s needs a rebuild.

I had problems with my 85 ltd where it would get stuck in high idle so Id throw it into neutral when stopping so I wouldnt have to mash the brakes. I accidently put it into reverse and immediately shifted back into neutral lol. It was fine for the rest of the time I had the car and the aod isnt the strongest trans.

07 GT Tungsten Gray

02 GT Mineral Gray

98 Crown Vic P71
07gtS197 is online now  
post #3 of 8 Old March 31st, 2018, 12:21 AM Thread Starter
Waldo-Mustang
 
Join Date: Oct 2015
Location: Huntington, Long Island, New York
Posts: 34
 
iTrader: 0 reviews
yeah, no slipping or anything major that I have noticed. prior to it I've just noticed it kinda pulls forward kinda like a hard shift when its at a cold start. usually only happens if I'm trying to cruise and not really slamming in the gas...
Waldo14 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old April 1st, 2018, 09:31 AM
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,456
Blog Entries: 3
     
iTrader: 5 reviews
Quote:
Originally Posted by Waldo14 View Post
yeah, no slipping or anything major that I have noticed. prior to it I've just noticed it kinda pulls forward kinda like a hard shift when its at a cold start. usually only happens if I'm trying to cruise and not really slamming in the gas...
That could be a sign of bigger problems but then again the 5r trans family is known to be troublesome. Just keep your eye on it and start saving for a new trans. Its only a matter of time unfortuneately with the 5r. A drain and fill wouldnt be a bad idea though.

Another thing to be aware of is that this trans loves to spit trans fluid when hot and theres no dipstick so you could be low of fluid and never know it.

07 GT Tungsten Gray

02 GT Mineral Gray

98 Crown Vic P71
07gtS197 is online now  
post #5 of 8 Old April 3rd, 2018, 05:53 PM Thread Starter
Waldo-Mustang
 
Join Date: Oct 2015
Location: Huntington, Long Island, New York
Posts: 34
 
iTrader: 0 reviews
wow really?! I didn't know that!!! I took it to a transmission place, really reliable. they didn't find anything. said everything was OK. check fluid too.
Waldo14 is offline  
post #6 of 8 Old April 3rd, 2018, 10:23 PM
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,456
Blog Entries: 3
     
iTrader: 5 reviews
How did they check the fluid level? Im not saying that theyre lying but the 5r is a sealed transmission with no dipstick so the only real way of checking the fluid id with a drain and fill.

07 GT Tungsten Gray

02 GT Mineral Gray

98 Crown Vic P71
07gtS197 is online now  
post #7 of 8 Old April 9th, 2018, 01:48 PM Thread Starter
Waldo-Mustang
 
Join Date: Oct 2015
Location: Huntington, Long Island, New York
Posts: 34
 
iTrader: 0 reviews
they took out the drain plug and stuck the finger inside, the tech said that's how they check them. never had a mustang like this....
Waldo14 is offline  
post #8 of 8 Old May 21st, 2018, 09:18 AM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 299
   
iTrader: 0 reviews
I wouldn't worry about it, but wouldn't make it a habit!!! LOL!!!
ZEN357 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome