Hydraulic clutch problems - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 1 Old May 27th, 2018, 09:18 AM Thread Starter
1C2
Regular
 
1C2's Avatar
 
Join Date: Jun 2016
Location: Sonora CA
Posts: 270
 
iTrader: 0 reviews
Hydraulic clutch problems

Hey everyone, long time no see. The other day I was driving my 94 probe gt and when I pushed in the clutch, it didn't come back up. I pulled it up with my hand and it seemed to lose pressure, but after a few pumps it regained some but seemed to have air in the line and was spongey. So I bleed it and it began to get better, buuut suddenly it took a turn for the worse and now it basically does nothing. There's plenty of fluid (although there's a little water in it), and I can't find any leaks anywhere. Not sure what the issue is, any help appreciated.

91 GMC Syclone
95 Taurus SHO mtx
99 Mustang GT-Sold
94 Probe GT
03 Mustang GT
1C2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome