maverick 88 trigger - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 4 Old November 16th, 2012, 03:05 AM Thread Starter
MM Fanatic
 
mxnate116's Avatar
 
Join Date: Jun 2007
Location: Spokane, WA
Posts: 3,357
         
iTrader: 1 reviews
maverick 88 trigger

So as of late I have been getting a lot of fail to fires out of my maverick. I have cleaned an oiled everything over and over again, except for the trigger assembly. I have noticed that when the trigger is out if its cocked back and i pull the trigger, that most of the time the hammer doesnt go all the way forward to a fire position, it stops a notch ahead, and if i pull the trigger again it goes all the way forward.

I want to pull it apart and clean and oil the whole thing but nowhere have a found a break down on how to do so, and I know that I will certainly not do it right without some kind of guide. Does anyone know where I could go about finding one? or possibly where I could just go about getting a new assembly all together?

Or possibly anyone who has had a similar issue? Its driving me insane.

mxnate116 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old November 16th, 2012, 03:54 AM
2012FFW TrueStreet Champ!
 
cruisemissile's Avatar
 
Join Date: Jul 2012
Location: East TN
Posts: 189
 
iTrader: 0 reviews
It sounds like its the trigger group to me. Also, have you checked to make sure the firing pin is moving correctly and not too stiff or hanging up? Those pin springs are very stiff sometimes! That could be an issue as well. If not, i'd send the trigger group back to Mossburg for repair or replacement!

Unfortunately common sense just isn't that common anymore.
cruisemissile is offline  
post #3 of 4 Old November 16th, 2012, 05:17 AM Thread Starter
MM Fanatic
 
mxnate116's Avatar
 
Join Date: Jun 2007
Location: Spokane, WA
Posts: 3,357
         
iTrader: 1 reviews
I think I may have gotten it, I blasted the whole thing with cleaner a few days ago and put some oil on it, must have seeped in now, because just dry firing it I had no issues. I guess we will just see next time I go out.

Should it happen again, any idea how much mossberg would charge to disassemble clean and reassemble the whole trigger assembly?

mxnate116 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old November 16th, 2012, 09:33 AM
One Man Wolf Pack
 
06RedfireGT's Avatar
 
Join Date: Aug 2006
Location: Regulatin On Some OGs
Posts: 39,159
                     
iTrader: 2 reviews
Send a message via AIM to 06RedfireGT
If it is malfunctioning they should fix it for free.

ΜΟΛΩΝ ΛΑΒΕ
06RedfireGT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome