High idle and P1121 Code... help - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 1 Old August 17th, 2018, 12:31 PM Thread Starter
Look Ma! My First Post!
 
Join Date: Aug 2018
Posts: 1
 
iTrader: 0 reviews
High idle and P1121 Code... help

So I just got a 75mm throttle body and plenum and I installed it. After I installed it I started it and the rpms went straight to 2,000. After about 5 minutes of looking at it I turned the AC on and it went down to 1,500. So I went out and got a new gasket for the IAC and the throttle body plenum to intake manifold gasket. I also went out and bought a new TPS for good measure. None of these things solved the problem. At that point I bit the bullet and took it to a shop for them to look for exhaust leaks in case I was missing one. They gave it back to me saying there were no exhaust leaks and they couldn't figure out why it was idling high. I have an SCT Tuner and had already tried setting the idle rpm to around 600 and nothing changed. It drives great and I can feel the throttle reponse and high end pick up faster. After about 3 or 4 days of driving like this the service engine soon light comes on. So I take it and get the codes read and it's giving me the P1121 code. It still runs great except for the high idle rpms. Can anyone help me? I have no idea what's wrong anymore.
Vince1221 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome