fuel gauge not working after fuel pum[ install - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 13 Old November 26th, 2009, 12:53 PM Thread Starter
Regular
 
Join Date: May 2009
Posts: 72
 
iTrader: 0 reviews
fuel gauge not working after fuel pum[ install

hey guys, so 2 days ago I installed a new airtex fuel pump in my 1998 gt. when i put the fuel pump assembly in its holder i stuck my hand in to make sure the float moved up and down. so when i turned on the car intially after install it read empty which was correct because the tank was dry, then i put in about 3 gallons of gas and it read las then quarter tank full. then i drove to the gas station and filled up, thats were the problem started, the gauge read 3/4 of a tank full when i fully topped off the tank and has been stuck there ever since. I'm going to drop the tank again this weekend, just annoys me to do somethingg twice. so you guys have any suggestions as to what it could be? I think i'm just going to switch this new pump into my old assembly because i know my old send unit works i just switched it cuz i didnt want it going out.
thanks for the suggextions in advance.
starin is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old November 26th, 2009, 05:55 PM
Hooo Ha Ha
 
sharkbait's Avatar
 
Join Date: Apr 2009
Location: Pasadena MD
Posts: 11,354
                     
iTrader: 10 reviews
Send a message via AIM to sharkbait
Did you reconnect the vacum line when re installing the tank? Theres a vacum line hose thats connect near the back of the tank (when your facing the rear of the car). Make sure that is re connected.


853rwhp @ 23psi
75mm Turbo 5.4 swap E85
#turbo2v

10.11 @ 138mph STOCK LONGBLOCK
9.11 @ 149mph - New Longblock /w Powerglide

www.JPCracing.com 410-729-0005 ext. 11

PM me if you need any parts or advice!
sharkbait is offline  
post #3 of 13 Old November 26th, 2009, 06:01 PM
Enthusiast
 
ndfrspd's Avatar
 
Join Date: Sep 2008
Location: The Motor City
Posts: 813
 
iTrader: 0 reviews
i would check that vacuum line. if you did the swap correctly and didnt manage to break anything, theres no reason why it shouldnt work as it did before. thats

ndfrspd is offline  
Sponsored Links
Advertisement
 
post #4 of 13 Old November 26th, 2009, 06:51 PM Thread Starter
Regular
 
Join Date: May 2009
Posts: 72
 
iTrader: 0 reviews
yea the vaccum line was connected, theres only one way the pump can ift in the carriage right? after i stuck the pump assembly in the carriage i made sure it could not pull out and i stuck my hand in to make sure the float went up and down without being stuck. i think i got a defective unit
starin is offline  
post #5 of 13 Old November 26th, 2009, 06:57 PM
Procrastinator
 
Join Date: May 2007
Location: Omaha
Posts: 4,558
           
iTrader: 2 reviews
is it possible that you would have bent the float? When I had my gas tank apart I had considered bending it some so that it would read empty early.
DickH is offline  
post #6 of 13 Old August 11th, 2010, 02:36 AM Thread Starter
Regular
 
Join Date: May 2009
Posts: 72
 
iTrader: 0 reviews
anymore ideas on this, i just pulled out the fuel pump again and reinstalled it and still does this, it never did this till i replaced the fuel pump

KNN FIPK kit, Hid headlights, MGW short shifter, Offroad BBK x-pipe, 4.10 gears.
starin is offline  
post #7 of 13 Old August 11th, 2010, 11:00 AM
Enthusiast
 
Join Date: Feb 2010
Posts: 992
   
iTrader: 0 reviews
the float, sending unit or vac line..thats about all it could be unless the actuall guage itself is messed up
BAD98GT is offline  
post #8 of 13 Old August 11th, 2010, 11:54 AM
Regular
 
Join Date: Jun 2010
Location: Aurora, CO
Posts: 470
 
iTrader: 0 reviews
weird, could just be the guage cuz ive never had any work done to any of my fuel parts but my needle goes 1/4th tank past full when i fill up and then im out of gas at an 1/8th tank but pissing my pants if i drop under a 1/4 cuz the needle is tricky iv ran outta gas a couple times lol dunno if that helps but 2 cents for ya.


PI Manifold. 75mm tb/plenum. Magnaflow X pipe. FR driveshaft. MGW shifter. New brakes and clutch stuff.
LoveStangs88 is offline  
post #9 of 13 Old August 11th, 2010, 05:09 PM
Rollin' 18/ pushin' 2
 
97S281's Avatar
 
Join Date: Feb 2007
Location: The lost highway
Posts: 8,333
                   
iTrader: 18 reviews
Quote:
Originally Posted by LoveStangs88 View Post
weird, could just be the guage cuz ive never had any work done to any of my fuel parts but my needle goes 1/4th tank past full when i fill up and then im out of gas at an 1/8th tank but pissing my pants if i drop under a 1/4 cuz the needle is tricky iv ran outta gas a couple times lol dunno if that helps but 2 cents for ya.

Sounds like someone pulled your needles off and didn't get them back on right. Do you have aftermarket guages?

either way you can pull the cluster face off and use a fork to remove the needle and put it back in the right place.




MODS IN GARAGE

All SVO'D UP
97S281 is offline  
post #10 of 13 Old August 12th, 2010, 02:32 AM Thread Starter
Regular
 
Join Date: May 2009
Posts: 72
 
iTrader: 0 reviews
no its totally stock, before my fuel pump when out the gauge worked totally fine, i changed the whole fuel pump and module and the needle would move to 3/4 tank full when the tank was actually full, and when it was empty it would read 1/4 full still, so then i using the stock sending unit and just installed that in, now the gauge just reads full and it been that way for 60 miles now. hardly any movement, it seems like the fuel pump assembly can go only one way in the cradle, and i made sure it is snapped in, i even stuck my hand in and made sure the float moves up and down. the float is pointed at the driver side rear wheel. i made sure the vaccum lines are hooked up too. im so lost.

KNN FIPK kit, Hid headlights, MGW short shifter, Offroad BBK x-pipe, 4.10 gears.
starin is offline  
post #11 of 13 Old August 12th, 2010, 03:23 AM Thread Starter
Regular
 
Join Date: May 2009
Posts: 72
 
iTrader: 0 reviews
i have a feeling im not installing the fuel pump correctly into the basket, can someone tell me how i get it into the basket the right way? people say its kind of trickey. ive pulled the damn fuel pump assembly 4 times now...

KNN FIPK kit, Hid headlights, MGW short shifter, Offroad BBK x-pipe, 4.10 gears.
starin is offline  
post #12 of 13 Old August 13th, 2010, 12:55 AM Thread Starter
Regular
 
Join Date: May 2009
Posts: 72
 
iTrader: 0 reviews
which way should the float point? to the driver side or passenger side?

KNN FIPK kit, Hid headlights, MGW short shifter, Offroad BBK x-pipe, 4.10 gears.
starin is offline  
post #13 of 13 Old August 13th, 2010, 08:16 PM
Rollin' 18/ pushin' 2
 
97S281's Avatar
 
Join Date: Feb 2007
Location: The lost highway
Posts: 8,333
                   
iTrader: 18 reviews
Hell dude, I don't know. But I guess you could just do it the opposite way than you have been if you think thats the problem.




MODS IN GARAGE

All SVO'D UP
97S281 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome