Turbo is done, got a question for you turbo guru's - Forums at Modded Mustangs
Reply
 
LinkBack Thread Tools
post #1 of 34 Old June 21st, 2007, 05:01 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
Turbo is done, got a question for you turbo guru's

Well got the Hellion finished today and this thing is a beast when it kicks in!

Made 420RWHP/415RWTQ with 20" heavy Foose wheels, 100 degrees, and only 7psi!

My question, car wants to stall everytime I get into boost then push the clutch in, I know it has to be the extra pressure from the turbo being spit out of the BOV which is located near the air sensor... so it is almost certain that the "wasted" boost is getting to the MAFS, could it be that the BOV is not letting all the air out like it should?
Regency 2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 34 Old June 21st, 2007, 05:07 PM
Hardcore Enthusiast
 
05mustang_TT_charged's Avatar
 
Join Date: Mar 2007
Location: LSU Country
Posts: 2,791
       
iTrader: 0 reviews
What is A/F Ratio a WOD and when you jump off the throttle. Had similar problem with that with KB. Was to rich on top in.
05mustang_TT_charged is offline  
post #3 of 34 Old June 21st, 2007, 05:21 PM
jat
Hardcore Enthusiast
 
Join Date: Jan 2007
Location: Maspeth , Queens, NYC
Posts: 1,341
 
iTrader: 0 reviews
Send a message via AIM to jat
u dont have a BOV,
u have a bypass where the compressed air is sent b4 the MAF which then decompresses.. you have a tuner problem... who tuned it?
jat is offline  
Sponsored Links
Advertisement
 
post #4 of 34 Old June 21st, 2007, 11:27 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
it's not a tuner problem, the AF is dead on! It happens when I am getting out of hard boost and letting off by punching the clutch in
Regency 2007 is offline  
post #5 of 34 Old June 22nd, 2007, 07:31 AM
 
Join Date: May 2007
Posts: 125
 
iTrader: 0 reviews
Hey my subaru did the same thing but i was pushing 20lbs. i had mine retuned a couple of times and it never fixxed it. I was running to lean at times. Turbos are so damn iffy with that damn AFR. i dont know if it will help but see if you can swith to an atmospheric BOV. That just purges the air out instead of plumbing it back into the intake like bypass valves. like i said i dont know if it will help but your tune is right on then its probaly something small and stupid wrong.
SEANMD81 is offline  
post #6 of 34 Old June 22nd, 2007, 10:47 AM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
I will ask about that
Regency 2007 is offline  
post #7 of 34 Old June 22nd, 2007, 03:31 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews

Regency 2007 is offline  
post #8 of 34 Old June 22nd, 2007, 03:39 PM
RIP Dennis
 
ChrisJ's Avatar
 
Join Date: Aug 2005
Location: Williamsburg, VA
Posts: 76,390
Blog Entries: 4
                     
Garage
iTrader: 13 reviews
Send a message via AIM to ChrisJ Send a message via Skype™ to ChrisJ
Sounds like your bashwashing your MAF...Same was happening with me when i first put my set-up on my car...

Where is your MAF located on this set-up? I cant see it from the pictures...

Speak From Experience Not From What You Have Heard.
Facebook
Google+
2015 Ford Taurus Sho NonPP / Livernois Downpipes / Magnaflow Catback / 3 Bar MAP / 170* Tstat / H&R Lowering Springs / BCB Tuned
2015 Yukon XL Denali
2008 Acura TL Type-S
ChrisJ is offline  
post #9 of 34 Old June 22nd, 2007, 03:41 PM
Regular
 
Join Date: Feb 2007
Location: Salt Lake City, UT
Posts: 298
 
iTrader: 0 reviews
That my friend is some of the hardest hardcore car porn i have ever seen. Nice Ride. BTW did u get rid of the R on the back yet?

In order to live, you must be willing to die.

06 Torch Red GT: pypes axleback, Kooks LT's, o/r H pipe. JLT bama 91 Race Tune, 4.10's
adam0421 is offline  
post #10 of 34 Old June 22nd, 2007, 03:54 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
Yes I got rid of the "R" on the back.

It is backwash on the MAF, the MAF is located right next to the air filter but it is hard to tell from the pictures.... do you think a better bypass/BOV would fix the problem? I have been trying to contact Hellion but dont answer!
Regency 2007 is offline  
post #11 of 34 Old June 22nd, 2007, 03:58 PM
RIP Dennis
 
ChrisJ's Avatar
 
Join Date: Aug 2005
Location: Williamsburg, VA
Posts: 76,390
Blog Entries: 4
                     
Garage
iTrader: 13 reviews
Send a message via AIM to ChrisJ Send a message via Skype™ to ChrisJ
From the look of the pictures you ahve the BPV shooting the air towards the inlet of the turbo...Can you get more pictures of how the BPV is set-up and how it returns?

An upgraded BPV could help you out...

I figured the car would be vented to the autmosphere...

Speak From Experience Not From What You Have Heard.
Facebook
Google+
2015 Ford Taurus Sho NonPP / Livernois Downpipes / Magnaflow Catback / 3 Bar MAP / 170* Tstat / H&R Lowering Springs / BCB Tuned
2015 Yukon XL Denali
2008 Acura TL Type-S
ChrisJ is offline  
post #12 of 34 Old June 22nd, 2007, 04:33 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
yea I'm not sure why hellion did it that way, everything is perfect and 100% quality on the kit but then it has backwash, but the tuner said it is no where near the backwash the powerhouse system has.... guy took his powerhouse system off and put a supercharger on it

Everytime I get into boost and gt out of it, I have to blimp the throttle some so it doesn't do it
Regency 2007 is offline  
post #13 of 34 Old June 22nd, 2007, 04:36 PM
RIP Dennis
 
ChrisJ's Avatar
 
Join Date: Aug 2005
Location: Williamsburg, VA
Posts: 76,390
Blog Entries: 4
                     
Garage
iTrader: 13 reviews
Send a message via AIM to ChrisJ Send a message via Skype™ to ChrisJ
Yep same thign that happened to me...

Your backwashing the $hit out of your maf...

Speak From Experience Not From What You Have Heard.
Facebook
Google+
2015 Ford Taurus Sho NonPP / Livernois Downpipes / Magnaflow Catback / 3 Bar MAP / 170* Tstat / H&R Lowering Springs / BCB Tuned
2015 Yukon XL Denali
2008 Acura TL Type-S
ChrisJ is offline  
post #14 of 34 Old June 22nd, 2007, 04:36 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
here is another picture from the website...
Regency 2007 is offline  
post #15 of 34 Old June 22nd, 2007, 04:40 PM
RIP Dennis
 
ChrisJ's Avatar
 
Join Date: Aug 2005
Location: Williamsburg, VA
Posts: 76,390
Blog Entries: 4
                     
Garage
iTrader: 13 reviews
Send a message via AIM to ChrisJ Send a message via Skype™ to ChrisJ
I think the bend in the pipe might be causeing some of your issues...The one coming right off the BPV...I think a better BPV and someone to straigten the discharge tube for the BPV and you should be set...

Speak From Experience Not From What You Have Heard.
Facebook
Google+
2015 Ford Taurus Sho NonPP / Livernois Downpipes / Magnaflow Catback / 3 Bar MAP / 170* Tstat / H&R Lowering Springs / BCB Tuned
2015 Yukon XL Denali
2008 Acura TL Type-S
ChrisJ is offline  
post #16 of 34 Old June 22nd, 2007, 04:51 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
I'm not hurting the car any am I?
Regency 2007 is offline  
post #17 of 34 Old June 22nd, 2007, 04:57 PM
RIP Dennis
 
ChrisJ's Avatar
 
Join Date: Aug 2005
Location: Williamsburg, VA
Posts: 76,390
Blog Entries: 4
                     
Garage
iTrader: 13 reviews
Send a message via AIM to ChrisJ Send a message via Skype™ to ChrisJ
Dont think so but then again I am not sure how your tune is...

My tune would jsut get extremely fat whenever I would let up on the throttle...I fixed it quickly because I did not like it...

I cant see a wideband in your picture so Im guessing you dont have one...

Are you using an xcal2 for tuning? You could datalog with the XCAL2 if you have it...

You could fix it without getting a new BPV...You jsut need to have the tube that comes from the BPV modified...
It will get annoying...

Speak From Experience Not From What You Have Heard.
Facebook
Google+
2015 Ford Taurus Sho NonPP / Livernois Downpipes / Magnaflow Catback / 3 Bar MAP / 170* Tstat / H&R Lowering Springs / BCB Tuned
2015 Yukon XL Denali
2008 Acura TL Type-S
ChrisJ is offline  
post #18 of 34 Old June 22nd, 2007, 05:06 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
Ok I will talk to the tuner about it.... I have it SCT tuned and the A/F is pretty much perfect on it.

It starts at around 14 at idle then it is almosta straight line across at 12 through the RPM range and right at 6.5RPM it dips to 11.5 (this is at 101 degrees in the shop)
Regency 2007 is offline  
post #19 of 34 Old June 22nd, 2007, 05:25 PM Thread Starter
Hardcore Enthusiast
 
Regency 2007's Avatar
 
Join Date: May 2007
Location: Memphrica
Posts: 1,143
 
iTrader: 0 reviews
I just got off the phone with Hellion and they said I should be able to hit full boost then pop it into neutral without it backwashing, so I called the tuner and he is going to have me bring it back on monday and we are going to throw it back on the dyno and check all the fitting and the BPV, hopefully everything works out!

Next on the list is a Boost Controller to get one more PSI out of it
Regency 2007 is offline  
post #20 of 34 Old June 22nd, 2007, 05:39 PM
RIP Dennis
 
ChrisJ's Avatar
 
Join Date: Aug 2005
Location: Williamsburg, VA
Posts: 76,390
Blog Entries: 4
                     
Garage
iTrader: 13 reviews
Send a message via AIM to ChrisJ Send a message via Skype™ to ChrisJ
I was just wanting you to check what the A/F is doing when you let off of it (and it backwashes)...

And yes the putting the car in neutral will work for ya...I had to do it for a week till I fixed mine...But it gets annoying...

Me personaly I would fix the backwash issue before doing anythign else...You can run the cooler to get mor boost out of it but me personally would want to fix the bakwash issue for no other reason then to not to have to put it neutral after a good pull...

Speak From Experience Not From What You Have Heard.
Facebook
Google+
2015 Ford Taurus Sho NonPP / Livernois Downpipes / Magnaflow Catback / 3 Bar MAP / 170* Tstat / H&R Lowering Springs / BCB Tuned
2015 Yukon XL Denali
2008 Acura TL Type-S
ChrisJ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome