installed lots of new parts including DS, weird noise on decel...HELP!!!!!! - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 19 Old January 21st, 2013, 02:10 PM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
installed lots of new parts including DS, weird noise on decel...HELP!!!!!!

Ok, so here is the list of parts I installed on my 2013 mustang gt prem, 3.73 gears, brembo package...just over 250 miles.

- DSS one piece alum. DS
- J&M extreme extreme LCA's (spherical bushing)
- BMR LCA relocation bracket
- BMR adjustable PHB (poly bushings)
- Eibach front and rear sways
- Tokico D-spec shocks and struts
- Steed sport extreme lowering springs
- Steeda SS brake lines
- MGW shifter
- Steeda heavy duty front strut mounts

Ok, so some things that I think could maybe causing it...

1. The DS in general could be bad
--I did the measuring as it stated and it was just with in spec
--I used a TQ wrench to TQ to specified to the 57 ft lbs, but its not the best tq wrench so they may be under of over tightened...not sure how much worry that should cause me?
-- I also did not install the upper adjustable UCA, because I was told it was not needed due to the drive shaft having a CV joint at the rear, so it compensates no problem
-- I can tell you, even though the DS was in spec for the cv side measurement...I did have to close about an inch at the tranny side...I figured that was probably normal, because it allows for the instal.

2. I swapped out the SS lines...and to my dismay of not paying attention while the swapping was going on, I took the master cylinder dry...I filled and bled the brakes via the 2 person method, person pumping brakes while I opened each valve and cleared the bubbles (I filled the MC, and then started at passenger rear, then driver rear, then passenger front, driver right. the first time I did until there were no bubbles at all, and repeated the process for good measure, still no bubbles. On the brembos, I did the inside valve first and then the outer). I mention this, becase I believe I have read that the brake system shares itself with the transmission, so I am not sure if I messed something up terribly?
-- I also used ATE super blue DOT 4 (which I know is not stock, but from everything I read its perfectly fine.

here is the situation...

once done, I took it for a 5 min drive, up to 50 mph (city/rural roads) and no issues that I could feel or hear...there was some noticeable feel in the pedals, the shifter and the ride...maybe slight vibration...but I chalked it all up to the newer stiffer suspension parts...did not seem excessive or anything. Went back to my buddies house (where I did all the installing) to clean up and on my drive home about 15 mins I noticed that on deceleration that it started to make a very audible noise...

The noise seems to sound like metal rubbing while spinning at the same time...not high pitch and does not sound like grinding at all...but I guess it could be. It does not do it parked in idel or when on the throttle...I think I may have started to feel some more vibration at this point...

My first thought is the DS, but why would it not do it on all driving, just on deceleration and with the clutch in...so I am lost right now and any experience or info, would be awesome!!!!!!!

* Also, I am not a little freaked that the DS is going to snap and come through the floor bad and take my legs off...or that its going to mess up with the tranny or the rear end...


Sent from my SGH-T989 using AutoGuide.Com Free App
Dgen is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old January 21st, 2013, 03:45 PM
Regular
 
Join Date: Oct 2012
Posts: 338
 
iTrader: 0 reviews
I would guess your getting lots of nvh from the lca.s.Those spherical bushings should be for track only use in my opinion because they transmit everything right through the whole car.
ponywars is offline  
post #3 of 19 Old January 21st, 2013, 04:03 PM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
Re: installed lots of new parts including DS, weird noise on decel...HELP!!!!!!

sorry shperical poly bushings...my fault for being super unclear

Sent from my SGH-T989 using AutoGuide.Com Free App
Dgen is offline  
Sponsored Links
Advertisement
 
post #4 of 19 Old January 21st, 2013, 08:27 PM
Biz Jet Fixer
 
jdos1's Avatar
 
Join Date: Jan 2010
Location: York & Greenville, SC
Posts: 4,985
           
iTrader: 20 reviews
Send a message via Yahoo to jdos1
+1 with what ponywars said.

2011 5.0 6MT, 3.73, Amsoil SS 10w-30 & MTG, Borla S Type A/B, DSS Alum Driveshaft, AirAid CAI, MGW Shifter, BBR Billet LCAs, FRPP Strut Brace, BMR Springs/Adj Panhard/LCA relos/Adj UCA, Koni Sport Shocks/Struts, Tuned by AED!!!
jdos1 is offline  
post #5 of 19 Old January 21st, 2013, 10:14 PM
Hardcore Enthusiast
 
sonicblue's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX / Dalzell, SC
Posts: 1,634
 
iTrader: 2 reviews
Yup what those guys said. You willl hear more whining and feel every bump in the road. Mine whines on deceleration as well after I added the LCA's and UCA. If you are still worried jack the car up and double check your work.

2013 Mustang GT- 6sp, 3.31 Gears Recaro Seats, Brembo Brakes-Mods in garage
2004 Chevy Silverado 2500HD Duramax- DD with the usual go fast parts
1990 5.0 sold
2004 mustang gt 520rwhp, 491 trq sold
sonicblue is offline  
post #6 of 19 Old January 22nd, 2013, 12:26 AM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
Re: installed lots of new parts including DS, weird noise on decel...HELP!!!!!!

so i had the ds safety loop installed and the adjustable upper control arm and it aligned (by a place that is "race spec certified" have no clue what the fuck that means or if it has any real merit, but sound good to me, lol)...took them a few hours...but i dont hear it anymore...but i didnt hear it, on the way to get it aligned, so i dont know.

i do hear a clunk sometimes with engagement of the clutch...but i know thats common with the 2 piece ds...im thinking the 2 piece may not always be the cause.

i had the place also check to make sure nothing was rubbing or looked out of place or "off"...they didnt notice or see anything.

i also had them re torque my ds bolts, to be safe.

i guess i can chalk it up to, just increased nvh...

thx for all the help guys.

Sent from my SGH-T989 using Tapatalk 2
Dgen is offline  
post #7 of 19 Old January 22nd, 2013, 12:27 AM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
Re: installed lots of new parts including DS, weird noise on decel...HELP!!!!!!

Quote:
Originally Posted by sonicblue View Post
Yup what those guys said. You willl hear more whining and feel every bump in the road. Mine whines on deceleration as well after I added the LCA's and UCA. If you are still worried jack the car up and double check your work.
good to know!!!

Sent from my SGH-T989 using AutoGuide.Com Free App
Dgen is offline  
post #8 of 19 Old January 22nd, 2013, 04:19 AM
BHD
Want Camels?
 
BHD's Avatar
 
Join Date: Jul 2012
Location: Dubai- UAE
Posts: 1,041
     
iTrader: 0 reviews
Mind if I asked, what pinion angle you set the UCA with 1 piece DS? I am planning on getting the GT500 CF DS

I double what they said, spherical endings will transfer road noise more than poly-poly

2013 GT-F14/BS Potenza S001-FRPP Handling pack-BMR Panhard,UCA/Mount,LCA/Relo brkts-JLT Oil can-4s Brembo-Roush grille- Boss 302 side pipes
2008 GT/CS-SOLD

BHD is offline  
post #9 of 19 Old January 22nd, 2013, 08:29 AM
I can haz tune?
 
Abilor's Avatar
 
Join Date: May 2012
Location: St Louis
Posts: 104
 
iTrader: 0 reviews
Quote:
Originally Posted by Dgen View Post
so i had the ds safety loop installed and the adjustable upper control arm and it aligned (by a place that is "race spec certified" have no clue what the fuck that means or if it has any real merit, but sound good to me, lol)...took them a few hours...but i dont hear it anymore...but i didnt hear it, on the way to get it aligned, so i dont know.

i do hear a clunk sometimes with engagement of the clutch...but i know thats common with the 2 piece ds...im thinking the 2 piece may not always be the cause.

i had the place also check to make sure nothing was rubbing or looked out of place or "off"...they didnt notice or see anything.

i also had them re torque my ds bolts, to be safe.

i guess i can chalk it up to, just increased nvh...

thx for all the help guys.

Sent from my SGH-T989 using Tapatalk 2
Peace of mind is always nice. I would have done the same in your shoes.

Spending time with Yoda Tuner...
Abilor is offline  
post #10 of 19 Old January 22nd, 2013, 08:58 AM
I can haz tune?
 
Abilor's Avatar
 
Join Date: May 2012
Location: St Louis
Posts: 104
 
iTrader: 0 reviews
Quote:
Originally Posted by Dgen View Post
so i had the ds safety loop installed and the adjustable upper control arm and it aligned (by a place that is "race spec certified" have no clue what the fuck that means or if it has any real merit, but sound good to me, lol)...took them a few hours...but i dont hear it anymore...but i didnt hear it, on the way to get it aligned, so i dont know.

i do hear a clunk sometimes with engagement of the clutch...but i know thats common with the 2 piece ds...im thinking the 2 piece may not always be the cause.

i had the place also check to make sure nothing was rubbing or looked out of place or "off"...they didnt notice or see anything.

i also had them re torque my ds bolts, to be safe.

i guess i can chalk it up to, just increased nvh...

thx for all the help guys.

Sent from my SGH-T989 using Tapatalk 2
Peace of mind is always nice. I would have done the same in your shoes.

Spending time with Yoda Tuner...
Abilor is offline  
post #11 of 19 Old January 24th, 2013, 03:48 PM
Regular
 
frankr's Avatar
 
Join Date: Jun 2011
Location: Orange County, CA
Posts: 190
 
iTrader: 0 reviews
I would suggest that anyone contemplating this type of suspension work install one item or group of items at a time, then perform a road test, this will allow stuff to settle, then re-torque your bolts and do an inspection of your work.

Examples unclude installing a drive shaft. Then check the pinion angle, test drive, recheck the angle, add your front safety loop, test drive, re-torque and re-inspect your work. If you add one thing at a time, you end up not having to guess which change resulted in the noise or handling problem.

I also recommend obtaining replacement fasteners, either from Ford, or equivalent grade, especially when suspension, drivetrain modifications are involved. If this is not convenient, NDT inspection (Non-destructive Testing) is a good idea, if you can get access to a professional. I usually get my used and even new fasteners penetrant or magnetic particle inspected where I work.


430HP to the rear wheels
frankr is offline  
post #12 of 19 Old January 25th, 2013, 02:49 AM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
Re: installed lots of new parts including DS, weird noise on decel...HELP!!!!!!

Quote:
Originally Posted by frankr View Post
I would suggest that anyone contemplating this type of suspension work install one item or group of items at a time, then perform a road test, this will allow stuff to settle, then re-torque your bolts and do an inspection of your work.

Examples unclude installing a drive shaft. Then check the pinion angle, test drive, recheck the angle, add your front safety loop, test drive, re-torque and re-inspect your work. If you add one thing at a time, you end up not having to guess which change resulted in the noise or handling problem.

I also recommend obtaining replacement fasteners, either from Ford, or equivalent grade, especially when suspension, drivetrain modifications are involved. If this is not convenient, NDT inspection (Non-destructive Testing) is a good idea, if you can get access to a professional. I usually get my used and even new fasteners penetrant or magnetic particle inspected where I work.
i dont have the sort of time or the garage on a super regular basis in my schedule to throw a part on, test it out and then move to the next...it's just not a reality for me and id rather spend a full couple of days on the ground doing all of it...then pro longing it over weeks. i understand your point, but while it seems great on paper, but in reality it just doesn't work.

as for fasteners, ive reused ALL on my previous cars that ran for years with no issue...what so ever...i will pay a shop 30 min time to throw my car on a lift and check all tq specs in a month or so, just be safe...but beyond that i wont replace anything and id spend countless days trying to figure out whay i need to replace and i bet the pieces add up to close to what my suspension parts cost altogether. no access to a professional a ndt pro.

Sent from my SGH-T989 using AutoGuide.Com Free App
Dgen is offline  
post #13 of 19 Old June 26th, 2013, 02:10 AM
Regular
 
txcharlie's Avatar
 
Join Date: Jan 2012
Location: East Texas
Posts: 147
 
iTrader: 0 reviews
My vote is MGW shifter. I had it on my Shelby for about a month. Took it out and sold it. Could not stand all the added noise coming into the car. Sounded like I was driving a sewing machine.

2014 Mustang GT Sterling Gray, A6, Roush TVS, FRPP springs, 20" Velgen wheels, Bassani axle back.

2012 Kona blue GT-sold
2008 GT500 stock-sold
2006 GTO 19" Axis shines-sold
1998 SS stock-sold[/B][/FONT]
txcharlie is offline  
post #14 of 19 Old June 26th, 2013, 04:12 AM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
Quote:
Originally Posted by txcharlie View Post
My vote is MGW shifter. I had it on my Shelby for about a month. Took it out and sold it. Could not stand all the added noise coming into the car. Sounded like I was driving a sewing machine.
No...I would say ds before anything...from the reading uve done...the mustang is just a shitty car in terms of noise...due to lack of sound deadening material and the sla that just is a microphone for transmitting noise

Sent from AutoGuide.com Free App
Dgen is offline  
post #15 of 19 Old June 27th, 2013, 11:01 AM
Boss 302
 
nosympathy's Avatar
 
Join Date: Jun 2013
Location: Cincinnati
Posts: 2,886
       
iTrader: 0 reviews
Quote:
Originally Posted by txcharlie View Post
My vote is MGW shifter. I had it on my Shelby for about a month. Took it out and sold it. Could not stand all the added noise coming into the car. Sounded like I was driving a sewing machine.
lol not sure on the shelbys but on the GT the center piece where the shifter is if you pull it up, has a lot of open space. To quiet it back down all you have to do is pack that full of insulation. Plenty of room to add a lot more.
nosympathy is offline  
post #16 of 19 Old June 28th, 2013, 01:00 AM
Regular
 
txcharlie's Avatar
 
Join Date: Jan 2012
Location: East Texas
Posts: 147
 
iTrader: 0 reviews
It came with dynomat and added foam pad, which was twice as much deadening as the stock shifter and still transmitted lots of noise. The stock unit has soft rubber on the trans mount and in the shifter itself and keeps the noise to a minimum. The hard poly bushings and removal of softer rubber in the MGW turned it into a megaphone. I didn't notice much difference in the shifting action either, but I drove it like a granny too.

2014 Mustang GT Sterling Gray, A6, Roush TVS, FRPP springs, 20" Velgen wheels, Bassani axle back.

2012 Kona blue GT-sold
2008 GT500 stock-sold
2006 GTO 19" Axis shines-sold
1998 SS stock-sold[/B][/FONT]
txcharlie is offline  
post #17 of 19 Old June 28th, 2013, 08:36 AM
Regular
 
Join Date: Sep 2011
Posts: 275
 
iTrader: 0 reviews
my MGW shifter is only slightly louder than stock. If you got in my car you wouldn't even notice it. I have poly lower control arms and added an adjustable spherical bushing upper. I noticed noise on decel, but low the fact that my rear is in line with the rest of the drivetrain. I have a dss on order, and will install that as soon as it comes in.

www.teambeefcakeracing.com for all your parts needs.Vortech, Mustang, Performance Cars | TeamBeefcakeRacing.comwww.teambeefcakeracing.com..
bam2012 is offline  
post #18 of 19 Old June 28th, 2013, 06:13 PM
Regular
 
blackbeast12's Avatar
 
Join Date: May 2013
Location: Delaware
Posts: 60
 
iTrader: 0 reviews
I just had to replace my whiteline uca due a design flaw, so went with steeda. The whiteline bushing is bigger and is synthetic elastomer so it was quieter then my steeda. I feel more vibration now then before and I'm certain it was already there from changing lca's and adding relocation brackets, a watts link, heavy duty eurathane motor mounts stiffer sway bars and an aluminum d/s. I only get noise at 2200-2700 rpm in 5th gear then it disipates. What I have concluded is that ford did everything to keep these cars quiet and the vibrations way down with a stock car. As soon as we change something it throws all that outta wack! I don't mind the noise and the vibrations, hell i have a tial 50 mm blow off valve on my Paxton, that thing is loud..its the price you pay for completly altering the car...

2012 GT Premium, 6speed 3:31 gears modded- to much to list!
blackbeast12 is offline  
post #19 of 19 Old June 28th, 2013, 06:27 PM Thread Starter
Regular
 
Join Date: Aug 2012
Posts: 341
 
iTrader: 1 reviews
Quote:
Originally Posted by blackbeast12 View Post
I just had to replace my whiteline uca due a design flaw, so went with steeda. The whiteline bushing is bigger and is synthetic elastomer so it was quieter then my steeda. I feel more vibration now then before and I'm certain it was already there from changing lca's and adding relocation brackets, a watts link, heavy duty eurathane motor mounts stiffer sway bars and an aluminum d/s. I only get noise at 2200-2700 rpm in 5th gear then it disipates. What I have concluded is that ford did everything to keep these cars quiet and the vibrations way down with a stock car. As soon as we change something it throws all that outta wack! I don't mind the noise and the vibrations, hell i have a tial 50 mm blow off valve on my Paxton, that thing is loud..its the price you pay for completly altering the car...
That is what I have heard...and looking at the stock parts, there is a shit load of rubber to cut down on the noise. Im fine with the noise, as long as it's normal ;-)

Sent from AutoGuide.com Free App
Dgen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome