Oil Filter Housing Leak??? - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 12 Old September 15th, 2016, 06:49 PM Thread Starter
raaka kone
 
floodz__'s Avatar
 
Join Date: Sep 2014
Location: Los Angeles
Posts: 89
 
Garage
iTrader: 0 reviews
Oil Filter Housing Leak???

Hey everyone!

I just noticed my car is leaving small puddles now when it sits. The puddle seems to be directly underneath the oil filter and consists of mostly oil with a little bit of coolant. There also seems to be a fair amount of oil on near by components. I've done a bit of research and it seems that my oil filter adapter gasket has gone south. Mostly just looking for opinions or confirmation if anyone else has had experience with this.

The car just went over 122,000 last week.



Here you can kind of see the puddle left by the leak and the location.


Here is some coolant dripping from the oil filter housing.


Here you can see some more of the coolant as well as other components shiny from oil.


There is a streak of coolant running down here from where the lower radiator hose connects. Yes, the hose clamp is tight.


Thanks for your help.

floodz__ is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old September 15th, 2016, 07:19 PM
Hardcore Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 2,561
         
iTrader: 2 reviews
Mine went bad around 120,000 miles. It's easy to replace, just drain the oil and coolant, then remove the oil filter adapter. It's about a 1 hour job. Just make sure you get it cleaned up real good for the new gasket to seal correctly.

I used this fel-pro gasket and it has held up just fine for about 12,000 miles now.
http://www.rockauto.com/en/moreinfo....385670&jsn=467

2002 GT - 5 Speed
Novi 1000 @ 9 psi
Mods in My Garage
Silver GT is offline  
post #3 of 12 Old September 15th, 2016, 10:59 PM Thread Starter
raaka kone
 
floodz__'s Avatar
 
Join Date: Sep 2014
Location: Los Angeles
Posts: 89
 
Garage
iTrader: 0 reviews
Quote:
Originally Posted by Silver GT View Post
then remove the oil filter adapter.
Did you have to remove the power steering pump to get at any of the bolts? I ran out of light as I got to that point today.

floodz__ is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old September 15th, 2016, 11:24 PM
Hardcore Enthusiast
 
Join Date: Feb 2012
Location: USA
Posts: 2,561
         
iTrader: 2 reviews
Quote:
Originally Posted by floodz__ View Post
Did you have to remove the power steering pump to get at any of the bolts? I ran out of light as I got to that point today.
No, you shouldn't have to remove the PS pump. It's been a while since I did mine, so I don't remember how I got to the bolts, but I know I didn't remove the PS pump.

2002 GT - 5 Speed
Novi 1000 @ 9 psi
Mods in My Garage
Silver GT is offline  
post #5 of 12 Old September 16th, 2016, 09:40 AM
Regular
 
Dysturbed87's Avatar
 
Join Date: Jun 2010
Location: Columbia, SC
Posts: 485
   
iTrader: 0 reviews
All the bolts are accessible without removing the PS pump. As mentioned above, make sure to drain the oil and coolant and clean the mating surfaces before installing the new gasket. Also, torque the bolts to the correct spec.

Sent from my HTC6525LVW using Tapatalk
Dysturbed87 is offline  
post #6 of 12 Old September 16th, 2016, 09:25 PM Thread Starter
raaka kone
 
floodz__'s Avatar
 
Join Date: Sep 2014
Location: Los Angeles
Posts: 89
 
Garage
iTrader: 0 reviews
As it turns out, my oil cooler is the same one that came on the cobra's so its a tad different than everyone's been describing. Only 1 bolt was accessible. Did some research and the svt guys have the solution. I have to pull the casing off which contains a heat exchanger by taking out the stud that the oil filter screws on. Once this is removed, I then have access to the other 3 bolts. Then I can finally pull the adapter off and replace the gasket. Much more of a PITA than I thought. I also had to order this kit with the hex head and all the o-rings for the cooler. Needless to say, it will be sitting until the new stuff comes in.

---------- Post added at 05:25 PM ---------- Previous post was at 04:15 PM ----------

Updating with some pictures because I haven't seen any other posts related to this style of oil cooler. I'm not sure if all 96-98 GTs came with this style cooler, but all the posts I have seen have been the 99-04 motors.


Here you can see the location of the four oil filter adapter flange bolts. Bolt 1 is the only one I could access with a socket. Bolts 2 and 3 you can reach with a wrench, a socket will not fit. I was only able to get a wrench in there when I unbolted the power steering pump. Bolt 4 was tucked in between the housing and the exhaust manifold. It was impossible to get any tool in there.


Just another angle. As you can see, bolts 2 and 3 would be very difficult to access without unbolting the power steering pump. According to some other forums, you wouldn't have to unbolt the ps pump to get to those bolts once you remove the housing.

I will post more photos in a few days when I get to removing the housing for the oil filter / heat exchanger.

floodz__ is offline  
post #7 of 12 Old September 23rd, 2016, 10:31 PM
King Trashmouth
 
WickedSnake00's Avatar
 
Join Date: Aug 2010
Location: Freakin' cornfields
Posts: 21,830
                     
iTrader: 1 reviews
Yeah that's a Cobra oil cooler. I'm well familiar with that.

You can't really take it off in one piece. What you have to do is remove the filter, remove the center section with a giant ass hex key, then you rock it back and forth to release it from the block adapter, and then you finally have access to all the bolts. It's kind of a bitch.

Now if it's leaking from the weep hole on the bottom you might have to replace a few seals. It's not a Ford serviceable part, but you can source o-rings from elsewhere to fix it. I rebuilt mine based on the info here:
How to repair leaking oil cooler
WickedSnake00 is offline  
post #8 of 12 Old October 5th, 2016, 04:50 PM Thread Starter
raaka kone
 
floodz__'s Avatar
 
Join Date: Sep 2014
Location: Los Angeles
Posts: 89
 
Garage
iTrader: 0 reviews
Update: Back up and running!

Ok, so here is a quick update. Finally got all the parts and tools I needed to complete this job. As mentioned in my previous post, I found this rebuild kit that came with everything you need to complete the process. New o-rings for the cooler / filter stud, new adapter to block gasket, and the 1/2" hex head bit to remove the stud.


After removing the filter stud, I was able to wiggle the oil cooler out passed all the remaining lines and hoses.


Here's the adapter with the oil cooler removed. As you can see, the remaining bolts are now easily accessible.


Heres the adapter once removed.


Cleaned up the back of the adapter with a razor blade and some 1000 grit sandpaper to ensure a nice clean surface for the new gasket. I also did the same to mounting point on the block.


Removed the old o-ring from the cooler and had to clean up the groove with some elbow grease and a razor to remove all the old RTV silicone.


All surfaces cleaned, new o-rings installed, new gasket, all ready to go back together. I tacked the large o-ring on the backside of the cooler into place with some ultra black rtv silicone to hold it in place once it was ready to re-install.

Once you are ready to re-install everything, its useful to have some silicone lubricant to help everything slide back together easily. Bolt the adapter back up to the block and torque the bolts to around 20 ft/lbs.

I put the filter stud all the way through the cooler with a few threads sticking out the back to make it easier to line up with the adapter. Once you get it on, torque the filter stud down to 50 ft/lbs.

Now you can put on a new filter, fill up the oil, and fill it back up with coolant.

Its been 2 days now, and I'm back to a leak free car.

floodz__ is offline  
post #9 of 12 Old November 23rd, 2016, 03:50 PM
Regular
 
Join Date: Aug 2016
Location: North Carolina
Posts: 60
 
iTrader: 0 reviews
Glad it worked out for you. Nice pics
Harris79 is offline  
post #10 of 12 Old January 14th, 2017, 03:19 PM Thread Starter
raaka kone
 
floodz__'s Avatar
 
Join Date: Sep 2014
Location: Los Angeles
Posts: 89
 
Garage
iTrader: 0 reviews
Quote:
Originally Posted by Harris79 View Post
Glad it worked out for you. Nice pics
Thanks, me too!

I'm going to leave all these pics active on my imgur in case anyone else has this issue, as all the threads I've found for this are text only.

floodz__ is offline  
post #11 of 12 Old January 16th, 2017, 03:06 PM
Regular
 
Join Date: Jul 2010
Location: Virginia Beach, VA
Posts: 136
 
iTrader: 0 reviews
I would have replaced it with a newer one while it was off to avoid the hassle if it ever needs removed again.
soupnutz is offline  
post #12 of 12 Old February 8th, 2017, 05:45 PM
John D
 
MustangJohn89's Avatar
 
Join Date: May 2015
Location: Prior Lake Minnesota
Posts: 52
 
Garage
iTrader: 0 reviews
I would drain the oil with a flashlight shining and see if you see any coolant come out when you first pull the plug and do a hydrocarbon test to make sure everything is good

-The little two valve that could-
MustangJohn89 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome