Forums at Modded Mustangs - Reply to Topic
Thread: New owner looking for help Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
January 29th, 2018 12:46 PM
Mike's03Mach My Mach has been sitting since Aug and the battery died the other day. I'd start it up every few weeks and let it run for a bit.
January 28th, 2018 12:05 PM
Eagle2000GT I have never heard of it being a common problem. My 2000 GT can sit for months without any battery drain.

I came upon this thread by accident. For more responses you need to post it in the 96-04 forum under Modular Mustangs. We have a few years to go before our cars become classics.
January 21st, 2018 10:54 PM
ajzride You might get more help if you post in the forum for modular mustangs, this is for 1965-1973 models.
January 20th, 2018 12:10 PM
Bakerp20
New owner looking for help

Just picked up a 2001 Mustang GT Delux Convertible in a trade today. It has a problem of draining the battery if you donít disconnect it. Previous owner said itís a known problem with this model. I canít find anything on it. Anyone hear of this or know how to fix it?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome