Forums at Modded Mustangs - Reply to Topic
Thread: Burnt Rubber Smell - Help!! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
December 7th, 2018 02:24 AM
07gtS197 Are you sure its not the caliper hanging up on the rotor? Its quite common with these cars, especially if they sit.

You can quickly check by raising both front tires and see how easily/hard it is to spin the tires.
December 6th, 2018 05:03 PM
ThrashMaster 01
Burnt Rubber Smell - Help!!

Okay so I've got a 2000 Mustang v6 5 speed with 155k. Now I've got something pretty weird going on, after driving for about 10 minutes (happens faster if driving faster) of driving you get this burning rubber smell inside and outside the car coming from the front passenger wheel area. I initially thought it might just need an alignment really bad so I had one done and the smell still happens. I was putting my nose on everything trying to see if I could find where it was coming from but it was almost like it was coming from the strut? Now for some background on this car, it has actually been sitting for about 2 years with only being driven about 3 miles once a month. Could the bushing/ isolator be dry rotted and rubbing that is between the strut and strut tower? Has anybody else experienced something like this or anyone has any recommendations as to what I should do? Over the past week of driving 20 miles a day it has gotten probably like 5% better, it is really bad and I just want to try and figure out whats going on. Thanks so much!!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome