Forums at Modded Mustangs - Reply to Topic
Thread: Need help diagnosing a problem with a 97 cobra Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
March 17th, 2016 04:46 AM
c.will Sounds like your guy is on the right track. Hard to start mechanical troubleshooting if the ecu or some sensor has a bad/loose ground. Any more details on the car? How else is it a "drag setup"? any other controllers for the nitrous or launch control?
March 26th, 2015 11:15 AM
Combobreaker codes are -

p0605 - internal control module rom error
p1464 - a/c demand out of self-test range
p1131 - h02s bank 1 sensor indicates lean

new update atm, we're going to rework the wiring & clean it up. Hopefully after that nothing else is wrong. If the problem persists with the computer I can get it redone from a guy with any codes I would need from factory
March 25th, 2015 11:25 PM
Combobreaker
Quote:
Originally Posted by wraitherx View Post
what code is it throwing and what else is done to the car? Was any work done to it prior to the problems?
I don't know exactly what code until tomorrow morning (something with the computer), to my understanding the only things that have been done to it is the...

msd ignition
2" lowering
nos kit
anti theft? part of msd? unsure
short shifter
March 25th, 2015 09:19 PM
wraitherx what code is it throwing and what else is done to the car? Was any work done to it prior to the problems?
March 25th, 2015 09:12 PM
Combobreaker
Need help diagnosing a problem with a 97 cobra

1997 mustang cobra setup as a drag car with MSD ignition/nos. (no nos hooked up atm)
I recently had a problem with getting it to turn over, it would kick hard but wouldnt turn over. I'd let it sit for a little bit and it would start up after ~15 minutes and disconnecting the battery. So I took it into a friends mechanic shop (20+years?exp) and he took a look at it and said it needed a crankshaft position sensor replacement & the wiring was shoddy on the msd ignition (ground wire hanging or setup incorrectly).
So he rewired it, replaced the sensor & sent me on my way. I get a block or two and the car dies out on me sitting in neutral at a red light. I get it towed back to the shop to wait and see what happened... It's now throwing a code for the computer? and the car runs, but not right. and now has the code.
The oo tells me the car needs to be tuned before it'll run correctly, the mechanic states its in rough shape and needs a lot more wiring work to be able to run correctly (never mentioned a tune).
So, any ideas? thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome