Forums at Modded Mustangs - Reply to Topic
Thread: put 351 in 5.0 need tech help Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
June 9th, 2007 04:47 PM
zero
Quote:
Originally Posted by DreFromTheBay
ok the guy who helped me gave me a little more info, my 88 mustang has MAF already but he he doesnt think that the engine is a 351 because it has a different firing order, since the engine is more powerful do you think the problem is the small MAF sensor, because with the O2 sensor unplugged it runs good, i'm lost
ford made two different firing orders for the 351W.
one is for the m code motor which was the 4bbl version in early years
1-3-7-2-6-5-4-8
one is for the h code motor which was the 2bbl version.
1-5-4-2-6-3-7-8

it could still be a 351, just a different one than you thuought. easy way to tell, measure. there are two different deck heights for the 351 though... i think one is 8.2 and one is 9.5 but im sure im wrong about the 8.2. if you want to be thorough in your identification, take off your heads and measure your piston width. as for your other problem, a new maf and a computer will clear things up. a 351 eats more gas than a 302.. so naturally the 302 computer is going to starve it.
June 8th, 2007 11:18 AM
JBIGBOOTSY pull codes
June 8th, 2007 11:13 AM
DreFromTheBay ok the guy who helped me gave me a little more info, my 88 mustang has MAF already but he he doesnt think that the engine is a 351 because it has a different firing order, since the engine is more powerful do you think the problem is the small MAF sensor, because with the O2 sensor unplugged it runs good, i'm lost
June 7th, 2007 10:36 AM
ryans88gt Buy a mass air conversion kit....instructions will come with it. Basically you replace the computer and add a mass air sensor in the intake plumbing. It isn't a hard install, if you are mildly competent at following directions it shouldn't be a problem.

They run around $500 for the cobra kit from ford racing for a recalibrated computer, mass air meter, and they used to come with 24 lb injectors too, not sure if that is still the case.

That should fix your problem, in the mean time don't drive you car like that or you'll blow it up.
June 7th, 2007 04:37 AM
DreFromTheBay do they have a section here on how to do that?
June 6th, 2007 01:55 PM
ryans88gt 88 is a speed density computer, you need to upgrade to mass air or you'll blow it up from running too lean.
June 6th, 2007 09:53 AM
OTreborO
+1

Quote:
Originally Posted by BWAL09
i think you need a new computer
+1 for new computer
June 6th, 2007 12:05 AM
DreFromTheBay well i think that might be a problem, because i dont know all the specs on this engine yet, it runs good but i'm gonna have to deal with a smog check soon
June 5th, 2007 11:54 PM
BWAL i think you need a new computer
June 5th, 2007 11:52 PM
DreFromTheBay
put 351 in 5.0 need tech help

i had a 351 put in my 88 5.0 GT but the computer wont compensate for the bigger engine and i had to disconnect the O2 sensor to keep it running, any ideas where i went wrong?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome