Forums at Modded Mustangs - Reply to Topic
Thread: Loss of power ar high rpms Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
March 13th, 2014 07:21 AM
Anthony05GT Sounds good!
March 12th, 2014 11:02 AM
94racing The owner of the dealership gave me a whole fuel tank with pump and sensor included. I replaced it and its just fine now, thanks for everybodys assistance!! In the next few weeks im gonma tackle the headers!
March 8th, 2014 10:08 PM
94racing Forgot to hit paste
March 8th, 2014 04:35 PM
94racing Freeze frame data off my code reader
March 7th, 2014 07:45 PM
94racing Ill score a cheap pump and im waiting on my sct to come in and im gonna datalog on it. Boss i may send you a pm here in a bit if the local dealer doesnt still has his out of his american iron car laying around
March 7th, 2014 05:21 PM
Anthony05GT ^ That's sound advice. One thing I never do is try parts unless I have parts to rob off of something else or parts laying around. You can make a cheap fix very expensive without proper diagnostics. I know there are situations where you have to try parts, but be smart about it. At least pull the pump and inspect the hoses, but on the other hand if you can score a cheap used pump and that's not the problem you could always sell a used pump yourself.
March 7th, 2014 12:43 PM
07 Boss I have a stock fuel pump sitting in my garage it you are interested in it. Have you data logged yet? And why not? You could eliminate quite a lot of this guess work as opposed to just chasing it with parts.
March 7th, 2014 11:28 AM
Anthony05GT Try to find a good used pump from someone on the forums. I know I had one, but gave it to my son in law for his build. You could get a used one for a song and lots of guys have removed stock pumps. It could also be the fuel lines in the tank. I've heard of a split line causing cavitation due to pulling fuel and then air through the split line.
March 6th, 2014 08:55 PM
94racing changed the fuel filter, that sensor wasnt the problem either so im assuming fuel pump.... dad believes so also. i have a fitting in the fuel hose running into the rail so when it starts acting up again i will get pressure readings but i noticed if i shut it off and turn it back on it runs fine again then degrades the more i run it.
also i have video. it wouldnt climb over 4000 in any gear
free revving to the floor nothing over 4500 and it would bounce back and forth.

videos are uploading on youtube

---------- Post added at 08:55 PM ---------- Previous post was at 08:48 PM ----------

flooring it in 1st
984 - YouTube
driving down the road in 3rd
http://youtu.be/eiYJgl2vp-c
free revving
http://youtu.be/eiYJgl2vp-c
March 6th, 2014 01:18 AM
94racing Cleared codes swapped sensor and no cure(actually this Driving it to work tommoro to change the fuel filter and go from there. Any more suggestions
March 5th, 2014 11:13 AM
Davidx9x +1^ Fuel pressure sensor
March 4th, 2014 03:44 AM
Bullitt95
Quote:
Originally Posted by 94racing View Post
Frps?
Fuel rail pressure sensor.
March 4th, 2014 03:31 AM
94racing Frps?
March 3rd, 2014 03:59 PM
Jason4.6GT It sounds like the FRPS malfunctioning and not seeing fuel pressure. Thus making the car bog, and not put enough fuel in it for the mixture.
March 3rd, 2014 01:25 PM
94racing Well there was no engine light or anything but i ran my code reader on it to do live diagnostics and when i plugged it in p0191 came up.
Fuel rail pressure sensor/range and it wasnt even pending
I figured the light would come on for any code showingnup but i guess not. Im gonna try replacing the fuel filter again since i just did it a few months ago

What i find weird is its not throwing a lean code when it was obviously rjnning lean at 3000 rpms enough to effect the performance, i know ive starved the pump a few times on the track from all the cornering gs so i hope its not the pump... Ill keep it updated. I cant wait to slap those parts on my car
March 3rd, 2014 04:03 AM
Bullitt95
Quote:
Originally Posted by 94racing View Post
Any ideas would be appriciated i have alot of spare parts to swap around.
Sticking charge motion control valves?
You could do a CMCV delete on the stock manifold but if you're planning on getting the FRPP manifold, the CMCVs will be deleted anyway.
March 2nd, 2014 03:42 PM
Anthony05GT I just wonder if a momentary lean condition due to a pump problem would possibly not throw a code. I wouldn't doubt a TPS problem either. The one TPS I had go bad threw a code.
March 2nd, 2014 12:58 PM
BIGCHRISS197 Hmmm quite the oddity youre having. Could be a number of issues, if it were fuel related id think it would throw a lean code and youd be having detonation. If it were vct related I, almost sure it throw a code. Im gonna lean towards the tps or throttle body itself
March 2nd, 2014 12:51 PM
Anthony05GT I guess the fuel pump could be crapping out on you. It's hard to say without experiencing it in person. I know the pcm monitors the fuel system to some extent, but a cavitating fuel pump might not be picked up. Be careful turning up the R's in case it is fuel related.
March 2nd, 2014 11:56 AM
07 Boss I would try doing some data logging while this is going on. And I am assuming that you looked over all of the other obvious mechanical stuff like intake tubing and vacuum hoses and what not. And I don't see any mods listed but could be spark blowout too but probably not. Have you pulled the plugs to check them out and see what they look like? Just taking stabs at it, you need to data log.
This thread has more than 20 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome