Forums at Modded Mustangs - Reply to Topic
Thread: No power whatsoever. 45 mph tops. Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
November 18th, 2014 04:25 PM
ghunt Must've not been a big deal since he hasn't been back in 2 months.
November 18th, 2014 01:44 PM
gibbstroy Ive had an ECM go out on my 2.3, it had the same symptoms.
September 16th, 2014 06:53 AM
Mikel89us Do a compression test. We can go from there.
September 15th, 2014 11:49 PM
byargeon1
No power whatsoever. 45 mph tops.

Guys I have a 93 lx 4cyl 2.3 auto with 112000 miles on it that is driving me nuts. It takes 2-5 tries before it actually will stay running and when it does finally stay it vibrates like crazy. When I go to drive it if I don't hold it to the floor I go nowhere. I can hold the gas pedal all the way to the floor and might be able to reach 45-50 mph in a mile. I have replaced fuel pump twice,filter three times,maf,iat,tps,plugs,wires and checked timing. I am coming over from Chevy so please be gentle to me. It has me about to just give up and sale it. Which I would hate to do cause I love this car. Please help in any way possible. Thank any and all who help. Also it has no knocking,smoking,or overheating at all. It also has straight exhaust so no cats. Thanks.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome