99 v6 Mustang Backfiring - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 5 Old January 10th, 2019, 02:11 PM Thread Starter
Newbie
 
Join Date: Jan 2019
Posts: 2
 
iTrader: 0 reviews
Question 99 v6 Mustang Backfiring

If anyone could help me with my issue that would be lovely. I decided to change the exhaust manifold on my 99 mustang from stock to shorty headers and x pipe. l also in the process did an egr valve delete and installed a cold intake. The first time and i started the car it ran fine but sounded like it was off so i checked the wire placement and re-did it and started it again and didn't want to start. than went back to original wiring and started right up but still sounded off. But than when i went to test drive it afterwards it started to backfire which sounds like pops but only when accelerating and decelerating. But at idle it seems to have a hanging idle and idles around 6-7 k. Also when putting the car into gear(automatic) it seems to bog down when under-load and the rpms drop to 5k. I have also seen that my fuel economy drop because i have to fill it up every two to three days. I think the car needs to flashed. Can anyone help? Only car.
Avany is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old January 14th, 2019, 10:15 PM
MOAR BOOST
 
SlowSix's Avatar
 
Join Date: May 2010
Location: Pittsburgh, PA
Posts: 9,163
             
Garage
iTrader: 4 reviews
Sounds like you have a vacuum leak or your plug wires are mixed up.
EGR delete will require a tune but won't really cause much of an issue other than it will throw a check engine light.


Turbo Build Thread
Status: Collecting parts for a stroker motor
SlowSix is offline  
post #3 of 5 Old January 15th, 2019, 09:10 AM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 334
       
iTrader: 0 reviews
Double check your plug wires. How new are the spark plugs?
ZEN357 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old January 17th, 2019, 01:44 AM Thread Starter
Newbie
 
Join Date: Jan 2019
Posts: 2
 
iTrader: 0 reviews
spark plugs are 3 months old with new wire and coil pack
Avany is offline  
post #5 of 5 Old January 22nd, 2019, 04:28 PM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 334
       
iTrader: 0 reviews
Ok, how old are the injectors? Maybe it's an injector that needs replaced or a fuel pressure regulator.
ZEN357 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome