My Air Conditioning stopped working - Forums at Modded Mustangs
 
LinkBack Thread Tools
post #1 of 11 Old May 29th, 2019, 04:46 PM Thread Starter
Regular
 
Join Date: Aug 2008
Location: California
Posts: 121
   
iTrader: 0 reviews
My Air Conditioning stopped working

Hi All, about 2 months ago I was driving down the freeway with A/C on then it went off, I turn it back on, after 10-30 seconds it went off, I turned it back on and again 10-30 seconds it went off again. So I haven't try it since.
So what do you think is the problem?
Thanks in advance!



Sixpkv6

07 V6 5 speed Coupe in California.
sixpkv6 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old May 30th, 2019, 08:27 AM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 332
     
iTrader: 0 reviews
Compressor.
ZEN357 is offline  
post #3 of 11 Old June 1st, 2019, 10:30 PM Thread Starter
Regular
 
Join Date: Aug 2008
Location: California
Posts: 121
   
iTrader: 0 reviews
Not a shot of Freon?



Sixpkv6

07 V6 5 speed Coupe in California.
sixpkv6 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old June 1st, 2019, 11:11 PM
I Post Entirely Way Too Much
 
Join Date: Aug 2008
Posts: 22,757
                     
iTrader: 8 reviews
I'd get the Freon level checked first. It could also be the a/c pressure switch or even the relay.
BA Mustang is offline  
post #5 of 11 Old June 3rd, 2019, 08:01 AM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 332
     
iTrader: 0 reviews
You can do one of those do-it-yourself refill kits from a local auto parts store. It may save you some money before having to take it in to a shop.
ZEN357 is offline  
post #6 of 11 Old June 3rd, 2019, 06:25 PM
I Post Entirely Way Too Much
 
Join Date: Aug 2008
Posts: 22,757
                     
iTrader: 8 reviews
Those kits aren't good. If he wants it done right he needs to have the actual gauges to see the readout.
BA Mustang is offline  
post #7 of 11 Old June 5th, 2019, 08:05 AM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 332
     
iTrader: 0 reviews
Quote:
Originally Posted by BA Mustang View Post
Those kits aren't good. If he wants it done right he needs to have the actual gauges to see the readout.

They have worked fine for me on two different cars.
ZEN357 is offline  
post #8 of 11 Old June 5th, 2019, 08:45 AM
I Post Entirely Way Too Much
 
Join Date: Aug 2008
Posts: 22,757
                     
iTrader: 8 reviews
Quote:
Originally Posted by ZEN357 View Post
They have worked fine for me on two different cars.
You have no clue what the pressure in the system is when using those. You can use them if you want but I'd never recommend them.
BA Mustang is offline  
post #9 of 11 Old June 5th, 2019, 11:35 AM
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,467
Blog Entries: 3
     
iTrader: 5 reviews
My Air Conditioning stopped working

I agree with BA. There is no way of telling whats going on by looking at only the low side pressure with those “gauges”. And they dont actually show pressure numerically. You need an actual manifold gauge set to see the whole picture.

And before you say anything else Ive worked on both automotive and residential ac.


Sent from my iPhone using Tapatalk

07 GT Tungsten Gray

02 GT Mineral Gray

98 Crown Vic P71
07gtS197 is offline  
post #10 of 11 Old June 6th, 2019, 08:10 AM
Regular
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 332
     
iTrader: 0 reviews
Quote:
Originally Posted by 07gtS197 View Post
I agree with BA. There is no way of telling whats going on by looking at only the low side pressure with those “gauges”. And they dont actually show pressure numerically. You need an actual manifold gauge set to see the whole picture.

And before you say anything else Ive worked on both automotive and residential ac.


Sent from my iPhone using Tapatalk
Sorry! No reason to get upset. We are all here to help.
ZEN357 is offline  
post #11 of 11 Old June 6th, 2019, 10:19 AM
MM Fanatic
 
07gtS197's Avatar
 
Join Date: Mar 2011
Location: Naples, Fl
Posts: 4,467
Blog Entries: 3
     
iTrader: 5 reviews
Quote:
Originally Posted by ZEN357 View Post
Sorry! No reason to get upset. We are all here to help.


Im not upset, I just want to help the op by providing more, correct information so he can diagnose and fix his issue.


Sent from my iPhone using Tapatalk

07 GT Tungsten Gray

02 GT Mineral Gray

98 Crown Vic P71
07gtS197 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Forums at Modded Mustangs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome