Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey People I Just Bought A 2007 Gt Mustang And Brought It All The Way From The Us To Greece Europe That Is. When It Got Here The Tcs Button Was Costantly Off And Wont Turn On And So Is The Abs Light In The Console As Is The Picture Of The Swirving Car.my Problem Is That The Local Ford Dealer S Diagnostic Csoftware Doesnt Work On My Car Since Ford Does Not Import It Here. Does Anyone Know What Might Be The Problem ? Does Anyone Know Of Any Free Software Available On The Net ?
 

·
May 08 ROTM
Joined
·
7,192 Posts
Your not going to find fords diagnostic software pirated onto the net. You may find someones code they wrote themselves, but not fords.

Did your dealer try resetting the ecu and modules by disconnecting the battery for a bit. I'd say minimum of 15 minutes. Sometimes any hiccup like that just hard resets in this manner.
 

·
Registered
Joined
·
817 Posts
Definately sounds like a malfunction somewhere because all those lights are affiliated in some way or the other.Atleast i know the tcs and skid mark picture is affiliated telling you when traction is being lost.Try what Emay said, disconnect the negative battery cable for a while and see what happens.I am assuming the car is used,does it have any mods done to it?
 

·
MM's resident Juice head
Joined
·
7,913 Posts
the car might have an aftermarket tune installed already...with the TCS shut off in the tune, but i dont think the the light should be on. You might have a bad TCS sensor.
 

·
Administrator
Joined
·
83,767 Posts
If you have the traction control shut off with a had held tuner, the light on the override switch, and the light on the dash (the swerving deal) will remain on.

The abs light should not be on however.

It's also possible to consider that there are two separate problems here. Maybe there is an aftermarket tune in place that has the TCS disabled, AND there is a sensor or something gone bad causing the ABS light to stay on.
 

·
Skirt Chasing Philanderer
Joined
·
14,391 Posts
You sure they didnt do anything when it went through customs... I dont know much about other countries policies on importing cars, but for a foriegn car to come into the US they screw with all kinds of **** making it compliant. I thnk in your case this is where I would start.
 

·
Retired MM Ninjas
Joined
·
12,556 Posts
I would try to source out someone who can scan for codes on an american car. Once you have have the codes written down you can find someone to give you can idea.
 

·
Registered
Joined
·
321 Posts
I have this problem and it is a wheel speed sensor that causes my problem. It isn't horribly expensive I just have not had the time to replace it. That is what Ford told me it was through their diagnostic testing.
 

·
IBEATU
Joined
·
5,919 Posts
Your not going to find fords diagnostic software pirated onto the net. You may find someones code they wrote themselves, but not fords.

Did your dealer try resetting the ecu and modules by disconnecting the battery for a bit. I'd say minimum of 15 minutes. Sometimes any hiccup like that just hard resets in this manner.
You can also unhook the negative battery cable and then touch it to the positive battery cable and this will deplenish any thing saved in its memory.
 

·
Registered
Joined
·
1,886 Posts
You can also unhook the negative battery cable and then touch it to the positive battery cable and this will deplenish any thing saved in its memory.
Not too many people know that way of clearing memory from ecu's. Although doing that you erase every module in the vehicle as well. Some take up to 30 seconds to completely clear.

In this case though, I don't think that would happen. ABS codes will clear themselves typically when the problem is corrected (wheel speed sensor for example). Check your connectors at the sensors and the ABS module and motor pack. Any diagnostic via over the net is virtually impossible but it gives you some direction. To me it sounds like a speed sensor wire or harness got damaged in the haul.
 

·
IBEATU
Joined
·
5,919 Posts
Come on now Mike.
Hey man, it works. And I have a hard time posting anything on here when you have already. I find my self staring at your avatar for WAY to long... :yes
 

·
Administrator
Joined
·
83,767 Posts
lol :lol


I just think that's a ... dangerous bit of advice to dole out. You and I know you mean to just quickly 'touch' the terminal.... but Ford would highly advise against doing such a thing. lol
 
1 - 14 of 14 Posts
Top