Modded Mustang Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone, I’ll start with the car... it’s a 97 cobra that has a 2003/2004 cobra long block and pro charged. I’ve owned the car since May 2020 it ran great through all the summer months with no problems it’s a super animal, I put it up for the winter in the garage back in October and I try to start it every week or two and let it run for a while, a couple of weeks ago I went out to start it and it started but seem to run a little rough and then stalled out, I figured it was moisture maybe in the gas that froze since it was minus degree weather that day, so the next day I put a bottle of fuel treatment in there and some fresh 93 octane to go with it it started and ran really rough for about a minute and then when I hit the gas to give it a little rev it died and won’t start again, I checked the fuel filter was fine and I even swapped out one of the fuel pumps even though I could hear fuel pump running before hand. I was told to check the fuel pressure on the Schrader valve but I don’t seem to have one, I do have a gauge in the car for fuel pressure and it looks like the needle is stuck on 35 it doesn’t move when I try to start the car and it doesn’t move if the car is been sitting for a couple days either. The only reason I’d have the build list is because I track down the original builder owner from a small piece of paper I found it it fell behind the glove box with his name on it, I’m going to post the list of what is build was in his text messages so you all can see what it’s made of and maybe give me some ideas of what could’ve happened.
225851
225852
 
1 - 1 of 1 Posts
Top