Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
my GT is running rough and i think that the COPs are bad as i just finished replacing the plugs and cleaning the injectors 1 week ago it only ran good for 2 days and starting running rough again .

I have a set of 8 brand new 2001 cobra ( same as 2003 mach 1 ) COPs and they look the same a part from the long rubber pipe that cover the spring

i can easily replace that peice of rubber from the old GT and put them in teh cobra plugs so they can fit on my GT so they will fit in my car.

but I wanted to ask if i will be able to use them that way before i try them.
as i'm sick of replacing a single cop every year and would just like to replace all but dont want to buy as i had those cobra COPs for years and would like to make good use out of them
 

·
Head Unicorn
Joined
·
5,085 Posts
The polarity is reversed on the Cobra coils. Remove the wires from each of the eight COP harnesses and reverse them, this will make them work.
 

·
Registered
Joined
·
849 Posts
Not to mention that the springs might be broken, which can cause similar problems.
 

·
Registered
Joined
·
648 Posts
You can buy new rubber boots at the auto parts store for about 5 or 6 bucks, that comes with the new spring and the new rubber boot, thats a cheap alternative to using the old rubber boots that could be causing some of your problems.

I change the boots on mine every couple years as a preventative maintenance to keep those pesky miss fires from happening.
 

·
Registered
Joined
·
2,936 Posts
If you run double platinum plugs the reverse polarity will not be an issue...
 
1 - 7 of 7 Posts
Top