Modded Mustang Forums banner

21 - 32 of 32 Posts

·
Just Cheesin'
Joined
·
7,574 Posts
You have a 95 though. OBD2 didn't start until 96. In OBD1 MAF would not turn on the CEL.


But it sounds like a fuel delivery problem. You need to check you TPs for a bad spot too. When I get on my laptop tonight I'll get the intrusions to check it. In the mean time, go get a DVOM. Radioshacks cheapest will do fine.
 

·
Was str8chillng
Joined
·
506 Posts
I do all my own work, just wish I had someone that could pinpoint the exact problem. Without codes this is tricky. At idle it is very smooth and this hesitation is completely random, comes and goes. I have never had to replace a coil pack, can this lead to random hesitation and no codes.
Believe it or not, try replacing the alternator. It fixed all my problems on my mustang with that strange hesitation problem.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #25
I will pick up a dvom tommorow and start poking around.

Where should I test the fuel pump and injectors at?

THis is also a strange revelation. I was tracking back things I done to my car trying to see where im at with reapairs and I remembered this.

When I changed my fuel filler neck ring to stop my fuel leak, I had the peice at the end of the filler tube break off and fall into my tank.:confused: Could this be getting caught up in the syphon and causing my hesitation problem. This could be why it is intermittent and random. I will drop the tank and fish this out anyway just to be sure.
 

·
MM's Official Lucifer
Joined
·
4,081 Posts
Might as well be to be sure. From my math you replaced the plugs 50k miles ago. They'd stand to change out, not sure if you've checked them yet from this.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #27
Guess the next semi warm day , I am going to drop the tank and fish out that piece and possible some of that rubber fuel neck ring. Then test the pump and injectors and coil pack.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #28
Trying to run the gas out, this car is a backup/project car so trying to find time to drive it is kinda wierd. Going to run the gas out tonight however. Obviously I need to get any obstruction out of my gas tank before I continue but could this actually lead to a fuel delivery problem?
 

·
Registered
Joined
·
286 Posts
i know on my car.. i have this problem after a bit of constant driving.. like no hard accel, but constant accel.. Then when i do want to accel more rapidly, it will hesitate, and jolt.. so I pull over, and shut the car off, turn the key back and forth(because my theory is my fuel pump is going bad, to i turn the key on and off to pump fuel into the line) and then start it back up.. and there is no more hesitation on hard accells even up to 5500 RPMS.. so your fuel pump could be going bad.. First dont spend any money, baby the car.. clean wires, check corrosion on the plugs, clean MAF, clean Throttle body, Clean Air intake filter.. Then spend 10$ on a new fuel filter.. See how she drives, and if it starts to hesitate, do what i said to do above.. see how she responds... Let me know how it goes for you.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #30 (Edited)
I am going to drive the rest of the fuel out by tuesday and drop the tank and at least fish all of the crap out of the tank, IE: Pieces of rubber grommet and the end of the fuel neck filler tube.

I am going to purchase a fuel pressure tester and see if I can rule out or confirm the fuel problem.

What is the model number for the svt focus replacement pump. I am getting different numbers and would like clarification.

Also after I run and turn the car off I hear a loud clank for a few minutes every minute or so from under the car around where the cats and mid pipe would be at. I am thinking of a possible cat clog except no codes.

Any tips on testing the fuel pump?
 

·
Registered
Joined
·
1 Posts
Did this problem ever get fixed? I have the exact same problem oddly enough but on a 97 Grand Prix GTP with the 3.8 V6. Yes I know this is a mustang forum, I was looking at buying one so I was checking here and found the same problem as another vehicle lol
 
21 - 32 of 32 Posts
Top