Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have a Red 2003 Mach 1 that i bought used with 68000. Miles on it. I have a miss so I got new set of coils yesterday and went to put them on and the clips on the harness are upside down. Someone put GMS coils on the car and the clip clips upside down. In order to run my new coils you have to twist the clip but when you do that it also switches the wires. I have another blue 2003 mach 1 so i pulled the cover off of it and the clips are right. The new coils work on it. Kind of hard to explain without a picture but basicaly there is a little wire and a big red wire coming from the harness. On the blue car the red wire is on the right, the b + side but on the red car its on the left. Is it possible someone pulled the wires out of the clip on the red car and turned the clip around to make the GMS coils work?
 

·
Head Unicorn
Joined
·
5,085 Posts
The polarity is reversed on 4V COPs, you'll need to disassemble the COP plugs and reverse the wires in the harness. Sounds like the previous owner reversed the polarity to use the 2V style piece of **** GMS COPs. You did find your problem though, its those piece os **** GMS COPs. Joe Granatelli is a member on here, although I haven't seen him around much since our not so friendly conversation about the junk COPs his company sells. He's quick to tell you they have a 12 month warranty, and they need it. If yours are still under warranty I'd return them for replacement and then sell them immediately.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Cool. Didnt know if you could take the connectors apart. Can't wait to throw the gms coils in the trash.
 

·
Head Unicorn
Joined
·
5,085 Posts
Yep, they come apart. It's not just GMS, its all aftermarket COPs at this point..... they don't last more than about a year.
 

·
King Trashmouth
Joined
·
21,891 Posts
Cool. Didnt know if you could take the connectors apart. Can't wait to throw the gms coils in the trash.
Yup it's easy. Get a small screwdriver. Pop out the yellow key piece in between the pins, then force the pins out the back of the connector with the screwdriver. Re-insert them such that the fat, common power wire (red for 4v, WH/BL for 2v) goes to the B+ pin.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
I switched the clips around and put the new coils in. Totally different car now. Before from a dead stop i couldnt even spin tire. It would fall dead on its face. Now the only problem i have is getting traction. I had just about everything changed or checked when i found this site and you guys led me to the coils so thanks to everyone for your help.
 

·
Head Unicorn
Joined
·
5,085 Posts
Glad we were able to help you out and hope you enjoy the car!
 
1 - 7 of 7 Posts
Top