Modded Mustang Forums banner

641 - 642 of 642 Posts

·
Registered
Joined
·
926 Posts
Discussion Starter #641
I saw a post and was coming over to tell you what 07GT said already. Come to SN95forums. It's much more lively and the layout isn't headache inducing.

Jealous as hell on that shop! Come on over. Sadly this place is dead now. I even started a random build thread there because ... why not. I'm stuck at home. Hope to see you soon.
Yeah ill have to sign up and start posting over there for sure, and haha thanks its actually my parents shop and with the Covid-19 it has been slow so I decided to tackle this job that ive been putting off

Nice man! I remember following this thread years ago. My 2001 GT that I bought with 232K on it is still going, at 289,94x as of this morning, will cross over 290K probably Wednesday. Still on original engine, trans, rear. I'll keep it going to half a million if it'll do it with religious maintenance and some luck. I've bought a 2019 5.0 401A PP1 since, but never drive it. Lol. Has 905 miles on it. Always in my 2V.

I rememeber you talking about that car! nice to hear that it is still being driven, almost 300k miles?!? thats awesome
I have a 17 gt pp1 myself and I like it a lot but it doesn’t satisfy me like my 02 gt does. Theres just something about these cars that I love.
I have to agree, just something about these SN95's
 

·
Registered
Joined
·
926 Posts
Discussion Starter #642
Got the trans unbolted from the car, I left it in the car and put a jack stand under it for the time being. Anything I should replace/update "while im in there?" I already bought a new clutch fork, pivot stud, Ford TOB and even new trans bolts as i had a few with questionable looking bolt heads. I was thinking maybe a tail shaft or input shaft seal? Dont know how labor intensive either of those are or if I even need to do so. Didn't clean the input shaft off before this picture, its much nicer than what is shown lol





Obviously there is a leak coming from I believe the shifter base or the vent and dripping down. There is also a little bit of grease on the top side of the trans just in front of the shifter base. Not sure whats going on there? You can see what im talking about below.





Not transmission related, but I have always has a little bit of a wobble/dead spot/delay whatever you want to call it, in my steering. I replaced tie rod ends years ago, and it helped a little but still was there and chalked it up to the steering rack being old and worn. I plan on upgrading to the 03/04 ZM rack soon so that will eliminate that possibility. The picture below, is that the "rag joint" that everyone talks about failing causing play in the steering? Whatever it is, it is completely shot, it crumbled in my hands when I gave it a soft squeeze. I know Maximum Motorsports makes a solid steering shaft, Do they replace this rubber part? Is the solid shaft really worth it or can i just replace this bushing?

 
641 - 642 of 642 Posts
Top