Modded Mustang Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
alright guys...finally started up my car the other day and its not really what i expected considering everyone that has done the swap said they started up there car and it ran fine an they got a tune asap to get full power! this is clearly not my case

ive checked all vacume and have plugged everything in correctly.

as soon as you start it up it shoots up to 3k rpm and then falls down to about 300 rpms and sounds like its cammed...you give it some throttle and has NO response then shoots up an back fires and does its own thing...idk what the deal is..ive tried everything...coil pack polarity's are switched and everythings good there...im stumped guys!

could it be to much fuel messing everything up? its really no different from the other setups ive seen!

Aeromotive fuel rails
24# injectors
focus pump

 

·
Banned
Joined
·
416 Posts
What harness and computer are you running?
 

·
Registered
Joined
·
424 Posts
is the maf the stock one from the gt?

try switching your iac, crank and cam position sensor
 

·
Banned
Joined
·
416 Posts
how so? you are not getting a reading of air flow
True but your o2 sensors will compensate by reading the air/fuel at idle and trying it's best to control the injectors to let the engine idle. Don't believe me? Turn your car on and unplug your MAF. It won't shut off...
 

·
Registered
Joined
·
2,592 Posts
True but your o2 sensors will compensate by reading the air/fuel at idle and trying it's best to control the injectors to let the engine idle. Don't believe me? Turn your car on and unplug your MAF. It won't shut off...
what if the o2s are shot or off like mine?
 

·
Banned
Joined
·
416 Posts
what if the o2s are shot or off like mine?
Your rear O2s are shut off because their only job is to see if your cats are working. The front 02s are never shut off. Their job is to make the car idle.

Edit: if your O2's are shot, then the car probably won't idle.
 

·
Registered
Joined
·
2,592 Posts
My front o2 are off. I broke the wiring harness for one of them when I changed my clutch. Car idles fine tho. Have them off on the tuner so I don't get the check engine light.
 

·
All Homo All The Time
Joined
·
2,917 Posts
My front o2 are off. I broke the wiring harness for one of them when I changed my clutch. Car idles fine tho. Have them off on the tuner so I don't get the check engine light.
Your tuner lets you turn the front 02s off? Mine only let me shut off the rears since I dont have cats.
 

·
Banned
Joined
·
416 Posts
My front o2 are off. I broke the wiring harness for one of them when I changed my clutch. Car idles fine tho. Have them off on the tuner so I don't get the check engine light.
That doesn't sound right...
 
1 - 16 of 16 Posts
Top