Modded Mustang Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
So, I have 5300 miles on my car now. When I drive "regular", like to the store or to work, no strange smell, all is good.

But, if I go out and play a bit and get on it a few times, I start to have a slight "hot engine" smell in my cabin. Gave my neighbor a joyride yesterday and he even commented on it. Engine running fine, all the gauges look good, so nothing appears to be wrong.

I thought this would "go away" after the break in period, but I still have the issue (has always done this). Is this normal? Will it go away with more miles? Anyone else notice this on their car? Thanks fellas :)
 

·
Registered
Joined
·
1,216 Posts
do you have your a/c on? is it set to recycle the air or fresh air from outside?
 

·
Registered
Joined
·
20 Posts
the headers actually glow red if you punish the car hard enough.. that might be the burning smell.
Really? I've only seen that once an a Corvette I was breaking in for new tappet lifters running without load. That's interesting.
 

·
Registered
Joined
·
47 Posts
I know what smell your talking about, Its that break in smell. Even though you broke here in i guess that smell is going to be their when you push it.


My BMW had that smell for the first 7-8k then went away.
 

·
Wanna be show worthy.
Joined
·
11,838 Posts
Ive had this happen to me, While i was racing after the ambulance going to the hospital cause my grandfather had a stroke ( i know wasnt good idea, i was "in the moment") and my car started to have that "hot" smell your talking about and actually worried me pretty bad, but when i started it back up everything was fine...
 

·
Registered
Joined
·
1,580 Posts
Clutch maybe?
 

·
Registered
Joined
·
426 Posts
Hmm Ill be foolin around with it today because I have been having some 5th gear "squeaking" when i rush the gears...

I will sniff around and see if i smell the same thing...
 

·
Registered
Joined
·
1,216 Posts
i woulda said break in period as well...but 5300 miles already! it SHOULD be broken in, but hey you never know!!
 

·
Registered
Joined
·
105 Posts
I see your mods include a Steeda CAI and Boss 302 Blue Coil Covers, that should not be doing it. Having a stock exhaust should rule out any exhaust issues. Did you paint anything under the hood or spray any engine dressing, Armorall etc?

One time I sprayed too much engine dressing and until it burned off, it gave out that same type of smell.
 

·
Registered
Joined
·
1,006 Posts
it sounds like when your getting on it really hard your roasting the clutch
 
1 - 16 of 16 Posts
Top