Modded Mustang Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I bought a 95 that was already split port swapped has some issues starting on cold, it spits and spudders for a bit and will eventually catch itself and run I’ve tried pre priming the fuel pump and still does it fuel pressure stays at 40 all hooked up not running when running goes to about 37 running which I think is normal, it will run somewhat normal when warmed up other than has bad throttle response any ideas I have a video of it just don’t know how to upload
 

·
Super Moderator
Joined
·
4,777 Posts
The easiest way to upload a video is to upload it to YouTube and link it here.

Have you had the codes read?
 

·
Super Moderator
Joined
·
4,777 Posts
Smoke test, either a shop can do it or you could buy a cheap cigar and blow the smoke into a vacuum line and watch if it comes out somewhere.
 

·
Super Moderator
Joined
·
4,777 Posts
Yes that’ll work. I’d use a big vac line like for the brake booster.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
I tried it with a cigar nothing that I could see but I’m gonna try it again with propane and see if I can find anything I just changed the throttle body TPS IAC, they plugged off the egr soo I double checked that and re sealed it it sounds like I can hear something near the intake tube soo I wanna try it with a propane gun and see if I can get any idle changes, now this is gonna be a dumb question is there any vac lines that go to the transmission or clutch
 

·
Super Moderator
Joined
·
4,777 Posts
No but there is a vacuum line that goes to the ac controls. That can go bad causing a vac leak in the car.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
No but there is a vacuum line that goes to the ac controls. That can go bad causing a vac leak in the car.
Ok so I found some vac leaks capped them all off cleaned the MAF while I’m at it it actually has throttle response when it’s warm now but still has a bitch of a time starting still when it’s cold only spits and spudders then will either die or I have to step on the pedal and it will eventually catch itself
 

·
Super Moderator
Joined
·
4,777 Posts
Ok so I found some vac leaks capped them all off cleaned the MAF while I’m at it it actually has throttle response when it’s warm now but still has a bitch of a time starting still when it’s cold only spits and spudders then will either die or I have to step on the pedal and it will eventually catch itself
You might need a tune to fix the cold start issue. It could be not enough fuel on startup. I don’t know who tunes these cars anymore though.
 
1 - 13 of 13 Posts
Top