Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi

I have a 95 GT, thats leaking water. The car was over heating, so i changed the theromstat and gasket. But now it is still over heating and leaking water.
This is what i have done so far,
checked hoses, waterpump seal, overflow tank, and radiator.
They are all good!

Any ideas?
 

·
Registered
Joined
·
11,200 Posts
did you check for water in the oil ? maybe you have a blown head gasket.
Uselly if you car is over heating its a blown head gasket, stuck T-stat, blocked radiator, failing water pump, if you have an electric fan, then its not coming on. Bad radiator cap, or the hoses are leaking
 

·
Registered
Joined
·
1,208 Posts
Thats why I sold my 94 5.0
I replaced everything Ryanw just mentioned
Then 2 years down the road the radiator cracked.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Just went for another drive. Since i have been leaking i haven't put any coolant in it only water. The temp gage never went past R butit moved around alot. When got back i added water. It was bubbling out of the radiator, but wasnt hot. It seemed rusty but not oily. I checked the dipstick and was definitely only oil. Dripping water from somewhere but it isnt pouring out.
 

·
Registered
Joined
·
11,200 Posts
pressure test your cooling system, it maybe as simple as a bad radiator cap.

also, again it could be a stuck T stat
 

·
Registered
Joined
·
545 Posts
pressure test your cooling system, it maybe as simple as a bad radiator cap.

also, again it could be a stuck T stat
^^This. Autozone does it for free.

I have seen the water pumps leak out of that little breather hole on the bottom. If your rad is boiling over and you only see water coming from the rad more then likely exhaust is getting into your radiator from your head gasket. I dont know about you guys but it seems from my experience if a 5.0 gets hot even once it cracks the stock head gasket.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
So far so good. I burped the radiator. I replaced the t-stat earlier. Let's hope all is well from here. Thanks for the help. Hopefully I wont be posting for a while. Just searching, reading, and learning about my GT
 

·
Registered
Joined
·
11,200 Posts
So far so good. I burped the radiator. I replaced the t-stat earlier. Let's hope all is well from here. Thanks for the help. Hopefully I wont be posting for a while. Just searching, reading, and learning about my GT
you dont have to come on here just when you need help, come and help other too.

hang out long enough and youll meet some real cool people and bull **** with them
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
@ohsplat, yesterday when all of this started my oem temp gage hit "a" on normal. I am new to the Mustang scene and dont know if that would crack the head gasket. I hope the hell not.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10 (Edited)
I will be here, i am not new to forums. I have a nissan 300zx twin turbo and am a member of other forums. I just know the importance of searching and learning rather than asking questions that have benn asked and answered millions of times.
 

·
Registered
Joined
·
594 Posts
Well the first problem I see is that you are just adding water..
The water evaporates fairly quickly compared to a good 50/50 mix.

Is there water/coolant under the car that drips? How about under the front of the intake?

I added some stop-leek in mine when I couldn't figure out the leak after new t-stat, gaskets. Ever since then I haven't had a problem.
 

·
Registered
Joined
·
11,200 Posts
The thing about the stop leak stuff is it can plug up your heater core
 

·
Registered
Joined
·
594 Posts
This is true^.

I was really at a loss of how to fix it though. Worked for me. Just sayin. ;)
 
1 - 14 of 14 Posts
Top