Modded Mustang Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,
Well Its spring and time to get back to my project.

Last fall I bought a 96 Cobra that was having over heating problems. The seller told me his repair shop told him he had a blown head gasket and or a warped head. I think he had a warped mechanic. He parked the car for two years hoping to get it repaired but then decided to sell it. I bought it, put in a new battery and it amazingly started right up with the first turn of the key. Within 15 minutes it was running hot but the new radiator he had put in was cold. I ended up replacing the water pump that look brand new but had a broken impeller shaft. The car runs and drives very good now and the body is in great shape so now its onto the real challenge.

I am having electrical problems with the interior of the car. I was told the stereo didn't work, but I'm not sure if everything else worked before it was parked. The seller told me the stereo was missing but looking at it from the driver’s seat the stereo looks all in tacked. I have no interior lights, no power locks & the key fob does nothing, no lights or sound in the stereo, and the odometer isn’t working either.

The speedometer, tach, headlights, taillights, turn signals, and power seat all work properly. I have replaced all the fuses down by the floor in the driver’s side compartment fuse panel and under the hood on the drivers side fender with no change and all the old fuses look fine.

Any suggestions? What is the proper way to diagnose electrical problems? Are there any tools or meters which will help me? I’m not sure where to start or where to go now?
Thanks,
Mike
 

·
Better than Drugs!
Joined
·
2,064 Posts
Does the battery hold a charge? There is a fusible link for the alternator near the battery. Looks just like a black clip together section. Inside this little black cylinder thing is a longer glass light bulb like fuse. That was bad on my 96 and caused these problems. You did say the fuses are good for the radio/dash lights?
 

·
Registered
Joined
·
294 Posts
Had this problem in one of my older ford truck 95'? I t was a bad ground on the body that had came lose. I ended up finding it after I pulled the seats and the carpet kit out and was going through the wring. Is it poping fuses? if it is find a little bit bigger fuse and start working your way around some times you can hear where it is poping on hopeful grounding. Good Luck
 

·
Better than Drugs!
Joined
·
2,064 Posts
not the smartest idea-- increasing fuse size BUT it cant work and...I have done it too. lol.
 

·
Still slow.
Joined
·
8,738 Posts
Get a test light and check if your getting power. I wondered why i had no dome light for about 5 minutes till i realized there was no bulb:rolleyes:
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
I found a connection near the battery that looked like it hold one of those glass fuses but it looks like a pin type connection that has no fuse.

The loose ground wire idea sounds like it makes sense.

I did find a connection missing on wires going to a power booster in the trunk under the back window but I don't think that would shut power off to everything.

Thanks, Mike
 

·
Registered
Joined
·
39 Posts
if you still need a motor I know a guy wanting like 1500 for is low mile 98 cobra motor and another guy wanting like 500 for his lincoln motor.
 
1 - 8 of 8 Posts
Top