Modded Mustang Forums banner

1 - 20 of 58 Posts

·
Registered
Joined
·
921 Posts
Discussion Starter #1 (Edited)
Hi everyone, im new to the 4v/SVT section of the forums but have been around the 99-04 section for a while. I recently picked up a 1997 cobra that needs some loving here's the 97 cobra i recently picked up cheap... it's got some issues lol but i don't plan on keeping the car i plan to fix it over the winter, driver it for a bit and sell it come spring/summer time. Ill take better pictures soon, it's always dark when i get home from work, Anyways here is the rundown

the good

- 1997 Pacific Green Cobra
- Clean title
- 138,617 miles
- Seemingly rust free
- BBk intake, Jet MAF, BBK 65mm TB, BBK long tube headers, MSD plug wires, catted midpipe (can't remember if its a H or X), and some sort of cat back
- Found a steering wheel cover, motorcraft oil filter, 4qts motorcraft synthetic blend oil and two jugs of coolant in the trunk! (These could be warnings of possible issues i guess)

The bad

- Needs driver side headlight (lens is cracked)
- Need to remove all the stickers lol
- Needs rear quarter fixed
- Needs clutch
- Needs steering column (will go more into that later on)
- Needs PA state inspection & Emission
- Find & fix exhaust leak
- Front and rear bumpers could use a respray
- Small hole in driver side seat
- Hood latch sticks horribly
- Hood is loose and zip tied on... :shiftyeyes
- Weak, yet new battery













 

·
RIP Dennis
Joined
·
76,427 Posts
Favorite color
 

·
RIP Dennis
Joined
·
76,427 Posts
Yes its a very rare color and very sought after.
 

·
Registered
Joined
·
921 Posts
Discussion Starter #8
Nice find! curious to see how you are going to go about fixing that quarter panel
Thanks! And my family owns a body shop so i have all the tools & knowledge to fix it. It looks like i can repair it without having to cut the quarter out of the car, which would save me a TON of time. if not a used rear quarter is cheap and ill end up cutting it out, but check back and you'll see how i end up doing it ;)
 

·
Registered
Joined
·
697 Posts
Thanks! And my family owns a body shop so i have all the tools & knowledge to fix it. It looks like i can repair it without having to cut the quarter out of the car, which would save me a TON of time. if not a used rear quarter is cheap and ill end up cutting it out, but check back and you'll see how i end up doing it ;)
Looking forward to it! I'm just starting to get into the body work side of cars. I've been a mechanic for years but never really done any bodywork. Picked up a cheap 01 v6 to practice on and try my hand at painting. fixed some dents and fiberglass cracks so far. Its a slow and tedious process, at least for me, but I enjoy it!
 

·
Registered
Joined
·
921 Posts
Discussion Starter #10
Haven't gotten around to messing with the Cobra yet but I did walk out to start it after letting it sit for about two weeks just to see if the battery held a charge (It did!) anyways while letting it idle i left the heat on full blast because i wanted to see if the heat actually worked which it does, however the car died randomly after idling for maybe 10-20 minutes. It started right up immediately, I left the heat setting exactly the same as when it died the first time, idled fine for a about a minute then died again. I did manage to take a video of it shutting off, not sure if it will help. I wonder if i could plug in my SCT X4 that is still married my 99 GT to monitor anything? At this moment im thinking IAC? but i don't understand why it would shut off after its warm and not every time it idles with the heat on?

You can see in the video the RPM's dip slightly, bounces up to around 900 then it shuts off

NOTE - The car idles perfectly fine without the heat on

 

·
Registered
Joined
·
979 Posts
You can datalog the car with the X4, even though they are not married. Just need a proper config (if you want custom) or the generic ford gas config.

Depending what you are diagnosing, may want your own custom config. SHould be able to plug the X4 into the car and livelink, validate parameters and make your config.
 

·
Registered
Joined
·
921 Posts
Discussion Starter #12
Anything i should look out for in particular that would cause it to die after idling for some time?

You can datalog the car with the X4, even though they are not married. Just need a proper config (if you want custom) or the generic ford gas config.

Depending what you are diagnosing, may want your own custom config. SHould be able to plug the X4 into the car and livelink, validate parameters and make your config.
thanks! good to know that i can plug it in and monitor things without messing it up for my 99 GT.
 

·
Registered
Joined
·
921 Posts
Discussion Starter #13
Havent gotten around to getting started on this project much yet, but I was poking around it the other day trying to narrow down where the exhaust leak is coming from and well.. I found it alright. Not really sure what im going to do about this, the metal looks to brittle to try and weld a patch in along with it being in a bad spot for a patch, these are BBK long tubes i dont know it they were chrome or ceramic coated but either way the finish is looonnnggg gone. My father suggested finding a new collector for it and cutting the rotted section off and welding a new one in, then I'd have to weld a flange on. or worst case scenario which i really don't want to do.. new long tubes :baller: Anyway, the other thing I found odd about this car was there isn't a VIN sticker in the door jam, like at all? either the sticker fell off or someone removed it? there is a sticker up much higher that says something about some sort of Ford calibration? a google search brought up something about a PCM/ECM not sure though. Besides that I have put on a spare from my 1999 GT until i get a chance to plug the nail in the one rear tire, it one ghetto looking cobra at the moment







 

·
Registered
Joined
·
921 Posts
Discussion Starter #14
tinkered with the cobra today since it was 70 out in February, i wanted to inspect the air filter to see if it needed a cleaning or replacement, because i have heard these BBK intakes can rust from the inside. It's a good thing i did check it out, filter was pretty much rusted and not worth cleaning. and the inside intake tube has some surface rust that ill clean off. Also discovered what looks to be the production date of the intake of 8/30/06 and the filter looks to be about that old. The best part of this was i discovered that one of the previous owners put one of those "tornado" fuel saver things inside the intake tube right behind the MAF :bowrofl:









 

·
Registered
Joined
·
921 Posts
Discussion Starter #15
Decided to tackle the odometer/trip meter issues that plague these SN95 cars, I wasn't sure if it was or wasn't working because i havent driven it more then a few feet. So i figured id spend the $10 and buy the gear replacement kit off of amazon and just replace them. It was a good thing that i did because once i got the cluster out and flipped it around the gear drive was so brittle that that gears had just fallen off and the nubs on each side to hold it in place were broken off. It was pretty straightforward install, i followed the video from LMR and it took me a little less then an hour from start to finish. also figured id write on an inconspicuous spot when and at what mileage it was changed for the next owner who might not know if it was done. I did not replace the worm gear as that gear was perfectly fine, so if anyone needs just a worm gear message me. Now i just need to get it down to the shop, throw it on the lift and get to work on it!











 

·
Registered
Joined
·
921 Posts
Discussion Starter #16
Finally got the cobra down to my families shop and on the lift! looked it over to see what it will need for inspection and just general maintenance, the car definitely needs some love. The car drove just fine on the 20 mile drive to the shop however it did throw a check engine light, i quickly scanned it with the SCT X4 and came up with three codes. also turns out the car has a BBK catted X pipe and a flowmaster catback I also think it has 3.55 gears as well

Codes;
P0171 - System too lean bank 1 (passenger side, sensor 1)
P1000 - readiness monitor not ready ( most likely from the dead battery)
P1260 - Theft detected (this relates to my steering column issue that i briefly mentioned earlier, more on that later)

Now its strange that it has a code for the passenger side being lean because that side of the long tube is nowhere near as rotted out as the driver side? (see below)

List of items that need to be replaced;

Front and rear rotors and pads (fronts are horribly warped)
passenger front ball joint (going to replace both)
Passenger front tire has a nail in it
Passenger side fog light bulb is missing... :headscratcher:
Fix the holes in the long tubes, driver side is MUCH worse then the passenger side.
Replace Clutch - most likely ford racing clutch kit, im dreading this with long tubes :(
Oil & filter change
Coolant flush
top off fluids
















Driver side exhaust leak



Passenger side exhaust leak

 

·
Registered
Joined
·
921 Posts
Discussion Starter #17
Got some parts in the mail this week, going to try and work on the cobra this weekend, I'll update this when the parts get installed.







Looked over it some more this week, i think everyone is right. As much as i am going to hate doing it, im going to have to replace the long tubes. I might as well do this right for the next owner, after all this is a cobra, plus they were going to have to come off anyway when i go to replace the clutch. If anyone knows someone selling a used of long tubes set PM me.
 

·
Registered
Joined
·
1,096 Posts
A Tornado fuel saver ha! Wow, never seen one of those things....what a joke.

What are you going to do about the rusted out exhaust? That looks pretty bad...

Good updates man. I'm going to subscribe. I forgot you had this project going on.
 

·
Registered
Joined
·
921 Posts
Discussion Starter #19
Worked on the cobra today, installed the headlights which makes me appreciate just how easy it is to change headlights in New edge mustangs lol. I attempted to tackle the rear rotors and pads, which i shouldn't have because i had other things to do today but i figured ehh why not ive done them before how hard can it be. Before i talk about the brakes, i was able to get the ugly exhaust tips off, for some reason I thought they were welded on but it turns out they are actually just screwed in around the tip, took them off and cleaned them up a bit and they polished up nicely. Back to the brakes, the calipers came off fairly easy, when i went to put the new pads on is where i started running into issues. I am using Powerstop Z17 pads, with Powerstop drilled & Slottled rotors. The new pads came with anti-rattle shims, the pads there were on the car didn't have any. As you can see below i can't get the caliper to slide over the new pads, it's almost as if the new pads are to thick, so for shits and giggles i wanted to see if the caliper would fit with the old pads and to my surprise it didn't only the top caliper bolt would line up, the bottom was about a 1/4 inch off no matter what. I think the parking cable is messing it up some how but At this point i was pressed for time and had to leave so i didn't get a chance to pull the parking brake cable off and see if that helps. ill pick up working on it tomorrow.



















Finished up the rear rotors and pads today, Turns out Rockauto sent me the wrong pads, I assume they are for a GT/V6 because i was able to get the exact same Powerstop Z17 pads at my local parts store the part numbers are exactly the same EXCEPT at the end on the new pads is the letter "A" the pads rockauto sent didn't have "A" anyway once i took them out of the box i noticed the pads were half as thick as the one i was sent from rockauto. (Left pad is new pad, right pad is the rockauto pad.) install was straight forward from there except for the fact that i couldn't get the pads to be installed with the anti-rattle clips installed for whatever reason. While i waited for the pads to get delivered to the shop, I cleaned up the Flowmaster tips a bit better, just used window cleaner and super fine grade steel wool i am surprised how well they shined up, looks much better then the ugly tips that were on it before. Another interesting thing is when i replaced the headlights the driver side headlight, the one that was cracked still had the original factory bulb... from 1996! 21 years later, 138,800 miles and even the light being all smashed up it still works. i have also attached pictures of the interior, yes i know it needs a deep cleaning lol. The pictures show my issue with the steering column. The white box that is hanging is the ignition switch... The reason that is exposed and hanging is because there is a plastic rod in the center of the steering column that engages the ignition switch when you turn the key. In my cobra's case, that plastic rod broke therefore not engaging the ignition switch when the key is turned. In fact when i turn the key it just spins, i can even take the key out when the car is running. I can also start the car without a key HOWEVER it shuts off almost immediately this is why i had a theft detected code thrown. I tried uploading a video of how i start it but it doesnt want to upload, ill try and post it in a few days. Next weekend is front rotors and pads, along with ball joints. then the fun begins with installing the new clutch and long tubes















A Tornado fuel saver ha! Wow, never seen one of those things....what a joke.

What are you going to do about the rusted out exhaust? That looks pretty bad...

Good updates man. I'm going to subscribe. I forgot you had this project going on.
I've never seen a Tornado fuel saver either until this car, in fact a lot of things on this car make me question the previous owners thought process! As for the rotted out exhaust, i am going to replace the long tubes, as much as i don't want to do that because 1) they are expensive and 2) are going to be a pain in the ass to do. Either way they would have to come off to do the clutch anyway :dunno I am currently on the hunt for a lightly used pair before i buy a new set
 

·
Registered
Joined
·
921 Posts
Discussion Starter #20
Alright its been awhile since my last update, life has gotten crazy busy with me starting a new job and all but i do have a small update for those that have followed this thread. this past weekend i was able to track down a complete steering column from a 97 cobra from a local mustang guy off of craigslist. he had a badass white cobra convertible with a Vortech on it. Anyway i bought the column off of him and installed it the next day. My father gave me a hand and it went in with ease and no issues i was worried that PATS would throw a fit with the ignition cylinder being taken out then put back in but it didn't. So i can now start the cobra with the key just like any other car with. I have ordered a new set of BBK long tubes, but apparently they are on national back order everywhere, ordered from three different companies that said they were in stock online but then got a phone call saying its back ordered so who knows when they'll show up, besides that i have to order the clutch which ill do when i get the long tubes then its go time. until then your stuck with this lousy update, in the mean time im going to detail the hell out of the interior, as you can see the carpet is just awful.

EDIT; added short video (and yes i know im holding the phone the wrong way) of a quick pull in the cobra nothing special in fact i think it sounds pretty terrible with the exhaust leak and at the end you can see how badly the front rotors are warped with all the shaking.

http://www.moddedmustangs.com/forums/usertag.php?do=list&action=hash&hash=2

https://vimeo.com/220396152







 
1 - 20 of 58 Posts
Top