Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I recently had my 97 cobra rebuilt and supercharged using a vortech S-trim SC, the engine was rebuilt using diamond pistons, new rings, bearings, APR head bolts ect, ect. I went with a 255 fuel pump, 42lb injectors, ford motorsport ceramic shorty headers, bassani x pipe, and a set of flowmasters. the car ran fine for a few weeks only made a few short trips in it as it is still being broken in but the other day it lost fuel pressure, and oil pressure and just died on me and then would not start. the engine would not turn over at all making me think it was an internal problem. I had it towed home and the next morning it started up with a little hesitation and ran fine in my driveway but when I took it out for a spin around the block it had no power at all and died after maybe 2 blocks, doing the same thing, losing all pressure and shutting off. it started back up and as long as i kept the RPM's up it stayed running but again no power. there is no fluids leaking, no smoke, and no noises can someone please give me a few ideas as to what to check? I have been through everything I can think of "which isnt alot" and have gotten nowhere
 

·
Registered
Joined
·
1,629 Posts
you had it tuned, right?
 

·
Registered
Joined
·
1,351 Posts
bad head gasket sounds like...wont necessarily have smoke from that, friends truck did the same thing, was literally hydrolocking a couple cylinders and killing the engine, after a bit it would fire right back up.
 
1 - 6 of 6 Posts
Top