Modded Mustang Forums banner

1 - 20 of 33 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Well I got a short in my tai lights and my led license plate light. Now my car won't start it just cranks. Fuel pump doesn't make a noise, I bought a body harness from a mustang that was parting out and spliced it into my old one but my car still does the same thing, just cranks. Tai lights won't function properly. All of the wires in the trunk on the harness matched up except 5 of them. There are 2 green/orange ones and 3 brown ones. Maybe I didn't hook those up right idk..... What else should I check? I know mustangs don't have a fuel relay I checked the fuel pump fuse and it is good. Im pretty novice on electrical problems. Pease help me out!!!
 

·
Registered
Joined
·
2,936 Posts
Well I got a short in my tai lights and my led license plate light. Now my car won't start it just cranks. Fuel pump doesn't make a noise, I bought a body harness from a mustang that was parting out and spliced it into my old one but my car still does the same thing, just cranks. Tai lights won't function properly. All of the wires in the trunk on the harness matched up except 5 of them. There are 2 green/orange ones and 3 brown ones. Maybe I didn't hook those up right idk..... What else should I check? I know mustangs don't have a fuel relay I checked the fuel pump fuse and it is good. Im pretty novice on electrical problems. Pease help me out!!!
The light green/orange wires are for the left side brake lights, the brown wires power the tail lamps it would appear your do not have those connected.

There is a fuel pump relay, it is one of the five relays in the CCRM (Common Control Relay Module).

Also check the inertia shut off switch on the left side of the trunk...
 

·
Super Moderator
Joined
·
13,580 Posts
There is also a FPDM fuse in the engine compartment fuse box, if this fuse blows nothing will operate.
 

·
No longer Maching out...
Joined
·
3,368 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #5
Update

Ok inertia switch is pushed in. Fuse in fuel pump slot how would I know if the module is good or not? And what fuse is this fuse that you speak of that if there's nothing in there it won't work? And is there a certain way to hook up the green/orange and brown wires? My turn signal flashers won't work and when I push on the brakes they won't get brighter either. I also have an alarm/ remote system.... I know the flaming is about to start. Just so u guys know! I always leave my car in neutral when parked! My choice please don't try and teach me a lesson about it. But anyways my remote start won't work either I can hear the relays engage but as soon as it wants to start they all shut back off. It doesn't even crank.
So what do you guys think? Imma go tinker with it a little bit.... If you guys need pics of what I'm talking about let me know and I'll try to upload some.
 

·
Super Moderator
Joined
·
13,580 Posts
Did you check every single fuse? in the car and under Wha hood? Hey Cliffy which fuse controls the FPDM? I dont have a book handy but I persoanlly think its a fuse.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #9
Ok I finished checking them all . And some of the fuses aren't getting any power to them. What could that be? I'm looking up a fuse diagram
 

·
Registered
Joined
·
99 Posts
Discussion Starter #11
Ok..... More bad news.... I just found a couple of blown uses so I replaced them and now the car won't even crank
 

·
I Have A FLATULENT Butthole.
Joined
·
7,889 Posts
Which fuses were blown? And don't worry about some of them not lighting up at all, some don't turn on unless that specific accessory is turned on. You're looking for one that lights up on one side, but not the other.

As far as the taillights, it seems to me like you didn't wire it up properly.
 

·
Super Moderator
Joined
·
13,580 Posts
Ok..... More bad news.... I just found a couple of blown uses so I replaced them and now the car won't even crank
You have more fuses blowing which sounds like something is not wired up properly and its shorting out. what fuses are blowing?
 

·
Registered
Joined
·
99 Posts
Discussion Starter #14
Update

Ok some starter fuses blew that's why it wouldn't crank. Now I'm not getting any power to the fuel pump... I'm getting power in my fuse just not my fuel pump. I looked back at my spliced wires and I had accidentally connected the gray and purple to the brown and purple not sure if that messed something up or not. But I'm kind of stuck right now don't know what to do next. Oh and another thing when I start up my car my gauges won't start immediately. They will take about 15 seconds before they decide to move at all. What does that mean?
That's guys for being patient with me.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #16
Yes left it charging with a battery charger over night. But why would my gauges take so long to get active? My fuel pump gauge won't go up at all and my odometer won't turn on either.
 

·
I Have A FLATULENT Butthole.
Joined
·
7,889 Posts
You have something completely screwed up with the wiring. Time to find some ford wiring diagrams and figure it out

Sent from my DROID RAZR HD using AutoGuide.Com Free App
 

·
Registered
Joined
·
257 Posts
forget the gauges we need to figure out why its not starting first. No power to the fuel pump, you need to trace the fuel pump fuse because thats where its getting power, to the fuel pump. See where the power dies off. Wiring sucks dude, the worst problems
 

·
Registered
Joined
·
99 Posts
Discussion Starter #19
Updates

Well it just had to rain today here in Dallas...... No garage means no work. What are the changes of me having a bad fuel pump module?
 
1 - 20 of 33 Posts
Top