Modded Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,059 Posts
Discussion Starter #1
Hey guys, yesterday somehow my radiator cap was loose so when i heated up all my coolant went boiling out, no worries on that because i was only in a residential area so i pulled over and filled up with water.

yesterday my a/c would blow like normal but for some reason today it will only blow out the defrosters or the floor, anyone had this issue before?

all help is greatly appreciated, thanks
 

·
Head Unicorn
Joined
·
5,085 Posts
Bad blend door/broken blend door etc., prepare to pull the dash to get to the box. It sucks.
 

·
Registered
Joined
·
2,059 Posts
Discussion Starter #3
Bad blend door/broken blend door etc., prepare to pull the dash to get to the box. It sucks.
great, i truly dont wanna pull that dash that would ****in suck, where do i get a replacement. i wanna check to make sure its not just a vacuum line or something but im not quite sure which ones out of all the lines are exactly for the a/c
 

·
Registered
Joined
·
2,795 Posts
open up you hood and then towards the drivers side there is going to be a line... make sure its connected, i used duct tape for my old mustang... works perfectly
 

·
Registered
Joined
·
161 Posts
Ducting probably came off. Pass side. Look up and make sure that it is attached.
 

·
Registered
Joined
·
2,059 Posts
Discussion Starter #8
vacuum line most likely, but timing is weird coincidence to your other problem
yeah its a weird coincidence for sure. figured i would mention it though just in case it was somehow related.

some of you are saying lines are on the pass side, some are saying drivers side.... which is it?
 
1 - 9 of 9 Posts
Top