Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4,311 Posts
Discussion Starter #1
hey guys, i have have a few things i need to fix on my car, but I have no idea where to start.

1) my battery light randomly comes on. Some times it just flashes, sometimes it stays on a while. I dropped the alternator the other day when I was working on my car, but it only fell like 2 inches if that helps at all.

2) when ever i try and accelerate at all though 1-2k rpms my car feels really jerky. it also does it occasionally 2-3k rpms, but it never happenes after 2k when i go WOT. oh and i am throwing a few codes for my upstream o2 sensor if that helps at all

any ideas?
 

·
Registered
Joined
·
7 Posts
This is just my opinion and experience:
1) Battery light probably a non-issue. For the last year, every now and then, my coolant light will come on..then go off........pop the hood, and the fluid level is just fine. Hot or cold engine, hot or cold weather, just randomly comes on.
2) I would check the coil-plugs for fitment.....and consider a tune-up (fuel filter, new coils-plugs, new o2 sensors or MIL elims, and flush tranny and gear box)

Again, that is just my thoughts on it. Good luck
 

·
US Air Force (retired)
Joined
·
13,542 Posts
Did this happen before your intake manifold broke? When mine broke I drowned a COP and had to replace it. Then I still had a mild miss for a couple of weeks until the others dried out. You might take off your COPs and clean them with cotton swabs to get rid of any moisture that might be trapped there.

Autozone or Advanced Auto will check your alternator and battery for free.

Didn't you replace your front 02 sensors? If they are not working right the computer cannot properly regulate the fuel and the motor might be running in the open loop fuel tables which create a very rich A/F mix.
 

·
Registered
Joined
·
4,311 Posts
Discussion Starter #5
COPs arent too expensive right? and yeah, I just changed my drivers side upstream o2 sensor, but the lights are still coming on. it kinda pissed me off. I kinda think something else is wrong there. I may switch them to opposite sides and see if the codes follow :dunno and if it is the reason i am running rich, that would explain my 11mpg in the city :bash: you dont need to take off everything to change the COPs do you? i cant remember off hand.

but, i am about to order a new fuel filter and other maintenance things with my $300 cjpp gift card. I honestly dont know what you spend it on. Is there anyway to test a wheel speed sensor?
 

·
Registered
Joined
·
144 Posts
what were you working on? have the alternator checked at advance, take it off the car and test it with a voltmeter on your car too
 

·
Registered
Joined
·
4,311 Posts
Discussion Starter #7
I was changing the intake manifold, I took the alternator off to have more room since I dont have an EGR delete yet. and when I was putting it on, I dropped it :bash:
 
1 - 7 of 7 Posts
Top