Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Been getting an annoying code 34 Air Bag light flashing for the past few weeks now.

From what I've gathered it is a "Low Resistance in the driver's air bag circuit".

Could moisture in the LH primary crash sensor (pictured) cause this code?

Reason I ask is the car has sat outside with the most rain I've seen in years!

The cruise control and horn still work, so I don't think it's the clock spring?

Could it also be the blue air bag module that's behind the HVAC controls?
 

Attachments

·
Registered
Joined
·
3,351 Posts
It could be anything but the airbag diagnostic module is usually at the top of the list. I had that exact same code in my 93 a while back and the module was bad. Before messing with the diagnostic module you should test the system first or you risk replacing parts needlessly. To test the system properly you need an airbag aimulator. The 90-92 require a Ford Rotunda 105-00008 (or OTC 7954), while the 93 requires a Ford Rotunda 105-00010 (or OTC 7956).

How far into it have you gotten so far?

As for that pic you posted, the 92-93 will not have the external battery backup mounted by the glovebox. That was a 90-91 part only as it was integrated into the module for 92-93 models.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
It could be anything but the airbag diagnostic module is usually at the top of the list. I had that exact same code in my 93 a while back and the module was bad. Before messing with the diagnostic module you should test the system first or you risk replacing parts needlessly. To test the system properly you need an airbag aimulator. The 90-92 require a Ford Rotunda 105-00008 (or OTC 7954), while the 93 requires a Ford Rotunda 105-00010 (or OTC 7956).

How far into it have you gotten so far?

As for that pic you posted, the 92-93 will not have the external battery backup mounted by the glovebox. That was a 90-91 part only as it was integrated into the module for 92-93 models.
Thanks for your response, I was begining to think this forum was dead.

I haven't started taking anything apart if that's what you were getting at, that's why I posted here first.

Do you think moisture could have anything to do with my issue?

Also, haven't researched yet, but was wondering if that airbag aimulator you were refering to could be rented somewhere?
 
1 - 3 of 3 Posts
Top