Modded Mustang Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter · #1 ·
rpm will drop low to about 300-400 then rev up to 1500. When I turn on my heater it feels like it sucks the juice out of my car and that's also when the rpms drop low. Im hoping its just the alternator that's going out my car has 93,000 miles
 

·
Registered
Joined
·
124 Posts
Take a DVOM and test your battery on DC, then start the car and test again. If you see an increase your alternator is working. Good, quick way to test your alt and regulator.

Your problem to me sounds more like an issue with the MAF sensor or IAC, make sure everything is has a good connection and not dirty. Did the problem just start happening? Right after you did something? Loose ground?
 

·
I Poop Entirely Way Too Much
Joined
·
8,720 Posts
If its a alt issue all the lights will be dimming. doesnt really affect the engine til you dont have enough juice to run the car. You have a parts store check the battery for you?

Flex whats DVOM?
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #4 ·
the lights do dim when I hit the switch to roll down my windows, i had a different problem with the IAC my car would not idle at all so i cleaned the IAC and that fixed that problem. Im going to check my MAF because when i first got the car i had this issue and there was a nat(bug) on the MAF sensor causing it to idle real low and die sometimes
 

·
☼ny
Joined
·
271 Posts
Remove the drive belt n run the engine when it's cold for a minute n try rotating the alternator pulley by hand. My alternator bearing probably gave out n was not letting the shaft move freely. So my idle rpm was going down...
 

·
I Poop Entirely Way Too Much
Joined
·
8,720 Posts
the lights do dim when I hit the switch to roll down my windows, i had a different problem with the IAC my car would not idle at all so i cleaned the IAC and that fixed that problem. Im going to check my MAF because when i first got the car i had this issue and there was a nat(bug) on the MAF sensor causing it to idle real low and die sometimes
The lights will dim when you open the windows electric motors draw a good bit of power. It sounds like its something with the air metering into your engine.

Does your battery die? If your alt is bad it wont charge your battery.

Remove the drive belt n run the engine when it's cold for a minute n try rotating the alternator pulley by hand. My alternator bearing probably gave out n was not letting the shaft move freely. So my idle rpm was going down...
I dont see why you need to run the car like this? You wont spin the alt fast enough to make any power. IT should spin freely though, if there is resistance trying to spin it with the engine off it goin out, but i dont that is the issue.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top