Modded Mustang Forums banner

21 - 40 of 46 Posts

·
Registered
Joined
·
409 Posts
How do those of us that have already had this unit get the update? And how can I get my Sirius XM ID number?
 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #22
Just an update on the thread...

- No AM Gift card was sent my way...

- Nav hasn't been able to update, this was Rosin (the nav manufacturer) response:

you may have a bad nav card if so you would need to buy a new one
They've sent me an order form to fill out... Requesting credit card information. Wtf?

 

Attachments

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #23
My response:

What do you mean I have to order an SD Card? You sent me this SD Card a week ago in the mail. Now you're saying I need to buy one? This was the tracking #: {removed}

This update was supposed to fix the bad firmware in my navigation. Can I update this without having to 'order' another (possible faulty) SD Card?

Jordan
 

·
Biz Jet Fixer
Joined
·
4,985 Posts
PM the AM rep again.
 

·
Registered
Joined
·
920 Posts
Just an update on the thread...

- No AM Gift card was sent my way...

- Nav hasn't been able to update, this was Rosin (the nav manufacturer) response:



They've sent me an order form to fill out... Requesting credit card information. Wtf?

My response:

What do you mean I have to order an SD Card? You sent me this SD Card a week ago in the mail. Now you're saying I need to buy one? This was the tracking #: {removed}

This update was supposed to fix the bad firmware in my navigation. Can I update this without having to 'order' another (possible faulty) SD Card?

Jordan
Hey Solid,

Thanks for the update and in regards to the Gift card, it's been sent out and should be in your mailbox any day now!

In regards to the GPS, It looks like whoever you talked to on the phone was not too familiar with what is going on and I apologize.

Keep your phone close to you, I have someone from reaching out to you ASAP that will get this fixed.

Hang tight!

-Will
 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #26
Hey Will,

I sent an email to [email protected] with additional details about the situation and I'm waiting to hear their response. Hopefully we can get this squared away....
 

·
Registered
Joined
·
409 Posts
How do those of us that have already had this unit get the update? And how can I get my Sirius XM ID number?
Any update on my questions? Not trying to thread jack but if there's an update available...
 

·
Registered
Joined
·
920 Posts
Any update on my questions? Not trying to thread jack but if there's an update available...
Hey man,

If you currently have the Nav and are not running into the heat issues, then you most likely have the newest update!

If you are having trouble, shoot me over a PM and we'll get a new card sent out to you also.

Hope this helps!

-Will
 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #30
Just an update...

AM's nice present came in the mail today. Thanks Will!

Rosen hasn't really done much but tell me to check my sd card slot, blow in it (lol), and possibly blame my wire harness. Last week they asked for me to video record what the issue is. I don't know how much more clear I can be with them, so I video recorded me trying to update the nav onto Youtube, then I sent them the link. That was last Friday and I have not heard from them since.

---------- Post added at 05:49 PM ---------- Previous post was at 05:42 PM ----------

Just for fun, here's the Youtube video I made for Rosen:

 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #31
It's been 7 days and no response. I sent a follow up email. I can't believe they haven't been able to offer any help so far.
 

·
Registered
Joined
·
43 Posts
It's been 7 days and no response. I sent a follow up email. I can't believe they haven't been able to offer any help so far.
Don't know if this will work but I went on the Rosen site and found this.
http://tinyurl.com/qxm66mf - page 41
Although it doesn't directly apply to your problem and it may not be your exact unit it does state that to get into the calibration screen you hit "NAV" immediately after the self-test completes.
I'd give that a try and if that doesn't work, start again and press a different button.
What sucks is the lack of support you're getting from Rosen.
I had intentions of putting one of these in this summer but now I'm having second thoughts.
Hopefully you get this resolved soon.
Good luck.
 

·
Registered
Joined
·
91 Posts
Pull it out, return it, and get a navi deck with a METRA dash kit. You won't regret it and you won't have anymore issues.
 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #35
Don't know if this will work but I went on the Rosen site and found this.
http://tinyurl.com/qxm66mf - page 41
Although it doesn't directly apply to your problem and it may not be your exact unit it does state that to get into the calibration screen you hit "NAV" immediately after the self-test completes.
I'd give that a try and if that doesn't work, start again and press a different button.
What sucks is the lack of support you're getting from Rosen.
I had intentions of putting one of these in this summer but now I'm having second thoughts.
Hopefully you get this resolved soon.
Good luck.
I'll check that out when I get home later and see if I can get it to work. Thanks for the Tip!

I figured a company like them would be more professional about handling customer support too.

Pull it out, return it, and get a navi deck with a METRA dash kit. You won't regret it and you won't have anymore issues.
I really like the look of these units and they were priced competitively; I like that it integrates with Sync as well. When I was shopping, other navs don't look factory and didn't integrate so well. I'm hoping to avoid having to dig into my dash again.

So, I get this email this morning:



At this point, I can't tell if they're BSing me or being serious. I've gotten all of their other emails just fine until now.
 

Attachments

·
ayyy lmao
Joined
·
932 Posts
Did you check your spam or trash? I've had that happen to me a few times doing help desk related things. Either the exchange server caught my e-mail and tossed it for some reason or it just went directly to the users spam.
 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #37
Did you check your spam or trash? I've had that happen to me a few times doing help desk related things. Either the exchange server caught my e-mail and tossed it for some reason or it just went directly to the users spam.
Yeah, I checked my inbox and spam for any keywords related to 'rosen' and I also searched for their email address in my spam and inbox. The only emails that came up are the ones I've responded to.

I am doubting they sent me an email...
 

·
ayyy lmao
Joined
·
932 Posts
I can dig that then. If they have your contact information then I fail to see why they wouldn't call you or try another means of reaching out if they didn't receive a response after two e-mails. Sounds like their tech support is nothing but a soup sandwich.
 

·
The Aviator
Joined
·
6,305 Posts
Discussion Starter #39
Yeah, so AM actually ended up emailing me asking me to call them. I was trying to keep to emails since I'm at work and I don't have my car with me. But it was a good thing I called. I talked to a guy who isn't their email support, and he seems to be escalating things better. They're going to send me out some new SD cards to try to update. He said if that doesn't work I'll need to contact AM for a third replacement. :facepalm:
 

·
Registered
Joined
·
2 Posts
I'm having an issue with my Raxiom Navigation that I got from American Muscle. Everything works on the unit with the exception of the nav. Each time I press the nav button, the screen either goes blank or it starts to load and then goes back to the home screen for the radio? Any ideas?
 
21 - 40 of 46 Posts
Top