Modded Mustang Forums banner
1 - 12 of 12 Posts

·
I'm Hella From Nor*Cal
Joined
·
1,166 Posts
Discussion Starter · #1 ·
well dad and i were working on it yesterday and today and yesterday we found this;




and after looking them over we put them back and torqued them down and put the cover back on.... and after we put them back it was still making a really wierd clacking noise. so we took the passenger side head off... and found, that ALL, yes ALL of the intake manifold bolts had came loose!!! i had just tightened them down 2 days before. :mad::mad:like to the point you could take them off with your fingers. All of the cylinders and pistons look perfect.



so we reassembled it layed a bead of copper rtv all around the intake and put some on the intake bolts. and torqued the **** out of them.

we re-ran new vacuum lines from the vacuum ported switch, to the dizzy, carb and intake vacuum port, started it up and it was still making a really odd clacking noise, so my dad was messing with it and found that there was a MASSIVE hole in the back of the heads, most likely from the old smog system that was on them... one was 1/2" and the other was 3/4" yup, you just read that right. so we plugged them up and we are waiting for everything to dry and set. so we shall see in the am....but for some messed up reason it still keeps friggin stalling. :mad::mad::mad: gah! the plates i get for this thing are gonna say, CURSED 69, i swear.:mad:
 

·
I'm Hella From Nor*Cal
Joined
·
1,166 Posts
Discussion Starter · #4 ·
:lmao
 

·
I'm Hella From Nor*Cal
Joined
·
1,166 Posts
Discussion Starter · #6 ·
no AC it's long gone
 

·
Golf Pencil Kawk Juggler
Joined
·
2,421 Posts
Meh, sell it and get a cobra.
 

·
Banned
Joined
·
11,614 Posts
must be the egr port, my P heads didnt have them which is why they werent "smog legal" itll be fine plugged mang
 

·
I'm Hella From Nor*Cal
Joined
·
1,166 Posts
Discussion Starter · #10 ·
must be the egr port, my P heads didnt have them which is why they werent "smog legal" itll be fine plugged mang
do you happen to remember what size plugs you used?
 

·
Powered by LSx tears
Joined
·
21,466 Posts
It's hard to tell exactly what I'm looking at from the picture of the hole, but it looks like an accessory bolt hole on the end of the head? If that's what it is, put a heli coil and a bolt in it.

As far as your intake, if you "torqued the **** out of it," I hope it's not an aluminum one, or you took a great chance of ruining it. It should be torqued to 20 ft. lbs, using the proper torque sequence, and if the bolts are backing off, you need new lock washers. Look at the lock washers, and if they're flat, they're bad.
 

·
I'm Hella From Nor*Cal
Joined
·
1,166 Posts
Discussion Starter · #12 ·
lol it's not aluminum its the stock cast iron one. . .
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top