Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
OK everyone, ive reviewed as many post on this topic as i can find on here but I'm still having problems...

MINE: 95 5.0

Issues: its overheating.

while sitting in the car a few days ago I watched the temp gauge rise from the far left to the far right in a split second......
i was sure something was amiss.
upon further inspection i realized i was overheating .....maybe it was the steam .... maybe it was the water on the ground......

i turned the car off and got it towed home.....

the next time i turned on the car the temp gauge didn't move at all ...
so before it got too hot i turned it off


then i got to work researching the common problems on here and other sites.
since then ive changed

waterpump, temp sensor, temp sending sensor &, the thermostat.

then yesterday i noticed that the fan will kick on BUT turn off within 5 seconds.

if i turn on the ac (which should turn the fan on the high setting) it runs for a few seconds and then like before stops

i know that the fans have issues
it has been through the "fan recall" and the dealership installed the integrated circuit to keep it from burning up ..

is there a way to test the circuit?
is there a way to test the fan ?
is there a way to test the ccrm?




P.s.
no there isn't any air in the system & no the thermostat isn't in "upside down"
the head gaskets are fine too
 

·
Resident Headbanger
Joined
·
2,427 Posts
while sitting in the car a few days ago I watched the temp gauge rise from the far left to the far right in a split second......
That sounds like the thermostat sticking closed. Try the simple things like replacing the thermostat, radiator cap, any bad hoses, and doing a complete cooling system flush/refill.
 
1 - 3 of 3 Posts
Top